Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 10:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поменять год во всех документах  (Прочитано 2541 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Гамаюн1991

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-19
  • Сайт: 
  • Профессия: Ученик 1С
Все Добрый день!
Ребята, подскажите пожалуйста как кодом поменять год во всех документах.
Время на сервере сбилось, нужно теперь восстановить год.


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Групповой обработкой справочников и документов.
Или воспользоватся этой http://forum-1c.ru/index.php?topic=46252.msg131730#msg131730
Ссылка на примеры работ https://yadi.sk/d/ksVluPMBkiRzX

Оффлайн Гамаюн1991

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-19
  • Сайт: 
  • Профессия: Ученик 1С
групповой обработкой не получется, надо сделать внешнюю обработку документов...
не подскажите как?

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Выборка = Документы.ТвойДокумент.Выбрать()
Пока Выборка.Следующий() Цикл
    Док = Выборка.ПолучитьОбъект();
    Док.Дата = НужнаяДата;
    Док.Записать();
КонецЦикла
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Гамаюн1991

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-19
  • Сайт: 
  • Профессия: Ученик 1С
Выборка = Документы.ТвойДокумент.Выбрать()
Пока Выборка.Следующий() Цикл
    Док = Выборка.ПолучитьОбъект();
    Док.Дата = НужнаяДата;
    Док.Записать();
КонецЦикла
Спасибо за ответ, а если мне нужно во всех документах, то через метаданные?

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
А почему не получается групповой обработкой?
Ссылка на примеры работ https://yadi.sk/d/ksVluPMBkiRzX

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Гамаюн1991, именно
 
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Гамаюн1991

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-19
  • Сайт: 
  • Профессия: Ученик 1С
Гамаюн1991, именно
Если через метаданные, то обращаться надо к СтандартныеРеквизиты.Дата а данные объект не доступен для изменения. Как с этим быть....?

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Для Каждого Документ из Метаданные Цикл
    Выборка = Документы[Документ].Выбрать();
    Пока Выборка.Следующий() Цикл
        Док = Выборка.Ссылка.ПолучитьОбъект();
        Док.Дата = НужнаяДата;
        Док.Записать();
    КонецЦикла;
КонецЦикла;
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Гамаюн1991

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-19
  • Сайт: 
  • Профессия: Ученик 1С
Для Каждого Документ из Метаданные Цикл
    Выборка = Документы[Документ].Выбрать();
    Пока Выборка.Следующий() Цикл
        Док = Выборка.Ссылка.ПолучитьОбъект();
        Док.Дата = НужнаяДата;
        Док.Записать();
    КонецЦикла;
КонецЦикла;
выдает ошибку " Итератор для значения не определен Для Каждого Документ из Метаданные Цикл
"


Теги:
 

В разделе "Перейти"панели навигации ВСЕХ управляемых форм (новых, старых, вновь создаваемых) конфигурации появляется одна и та же команда. Как избавиться?

Автор CrazyHorseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1297
Последний ответ 23 Июн 2015, 16:49
от CrazyHorse
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 928
Последний ответ 31 Авг 2016, 16:02
от Masik777
Для всех документов нужно сделать проверку при проведении. Где это можно сделать?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 646
Последний ответ 04 Сен 2016, 04:20
от cska-fanat-kz
Часть вторая: переход на «1С ЗУП» версии «3.0». Работа с «Параметрами учета» и проверка всех настроек программы после транспортировки из предыдущей редакции

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4277
Последний ответ 16 Мар 2015, 16:19
от 1cwiki
Если стоимость отгруженного товара изменилась, нужно выдавать корректировочную или обычную счет-фактуру с учетом всех изменений

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1108
Последний ответ 17 Июл 2014, 12:25
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 760
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal