Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание одного документа со спецификацией на основании другого  (Прочитано 625 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Конст_007

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2015-05-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!
Подскажите пожалуйста, где ошибся, а ошибся где то наверняка). Поиском находил похожие вопросы но до конца разобраться не могу.
УТ 11 на упр. формах.

Требуется: На основании имеющейся накладной "ПеремещениеТоваров" создавать документ "ПересчетТоваров" со всей спецификацией.
Пытаюсь пойти стандартным путем: В документе "ПересчетТоваров" через конструктор ввода на основании указываю документ ПеремещениеТовара со всеми нужными полями.
В итоге в модуле документа заменятся стандартная процедура "Обработка заполнения" на процедуру такого вида:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
   //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
   Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ПеремещениеТоваров") Тогда
      // Заполнение шапки
      Комментарий = ДанныеЗаполнения.Комментарий;
      Ответственный = ДанныеЗаполнения.Ответственный;
      Склад = ДанныеЗаполнения.СкладПолучатель;
      Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
         НоваяСтрока = Товары.Добавить();
         НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
         НоваяСтрока.КоличествоУпаковок = ТекСтрокаТовары.КоличествоУпаковок;
         НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
         НоваяСтрока.Серия = ТекСтрокаТовары.Серия;
         НоваяСтрока.СтатусУказанияСерий = ТекСтрокаТовары.СтатусУказанияСерий;
         НоваяСтрока.Упаковка = ТекСтрокаТовары.Упаковка;
         НоваяСтрока.Характеристика = ТекСтрокаТовары.Характеристика;
      КонецЦикла;
   КонецЕсли;
   //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры

Но в документе "ПеремещениеТоваров" при нажатии кнопки "Создать на основании" не появляется новый пункт типа "Создать Пересчет Товара":dfbsdfbsdf:
Как я понимаю надо в форме документа "ПеремещениеТовара" создать команду, которая бы вызывала процедуру создания документа "ПересчетТовара" с заполнением его созданной выше процедурой ОбработкаЗаполнения, что то типа:

&НаКлиенте
Процедура СоздатьПересчетТоваров(Команда)
     ОбработкаЗаполнения();
       Форма = ПолучитьФорму("Документ.ПересчетТоваров.Форма.ФормаДокумента");
       Форма.ЗаполнитьНаКлиенте(Объект.ПеремещениеТоваров, Объект.Товары);
        Форма.Открыть();
КонецПроцедуры

Только вот как правильно написать команду запуска не соображу. Помогите плиз


Оффлайн Конст_007

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2015-05-25
  • Сайт: 
  • Профессия: Ученик 1С
Попробовал с помощью "конструктора ввода на основании" сделать из документа "ПеремещениеТоваров" другой документ (СборкаТоваров - Получилось!
По кнопке "Создать на основании" в "ПеремещенииТоваров" появился новый пункт с добавлением "СборкаТоваров".
В итоге окончательно запутался, почему по одним документам ввод на основании конструктором отрабатывает, а по другим нет?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В конфигураторе для каждого документа и справочника есть закладка "Ввод на основании"


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4198
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 621
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7739
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4775
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 847
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal