Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 06:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: эсм 7  (Прочитано 2148 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zampilot

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Программист 8.1
эсм 7
« Первое сообщение: 21 Май 2015, 07:36 »
Вот это код от б.п 2.0 эсм-7 его надо преоборозовать на б.п помогите 3 день уже ломаю голову

ПредставлениеПодрядчика = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата), "ИНН,КПП,ФактическийАдрес,Телефоны,");  //**В
   ПредставлениеПодрядчика1 = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата), "ПолноеНаименование,");
   ОбластьМакета.Параметры.Подрядчик = ПредставлениеПодрядчика1 + " ," + ПредставлениеПодрядчика;
   //ОбластьМакета.Параметры.ПоставщикУслуг = СсылкаНаОбъект.Организация;
   
   ПредставлениеЗаказчика = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Контрагент, СсылкаНаОбъект.Дата), "ПолноеНаименование,ИНН,КПП,ФактическийАдрес,Телефоны,");  //**В


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: эсм 7
« Ответ #1: 21 Май 2015, 08:05 »
чего ломать-то?

в 3ке описание организации получают примерно так:
СведенияОПоставщике = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Реквизиты.Поставщик, ВыборкаСФ.Дата);
ДанныеШапки.Вставить("ПредставлениеПоставщика", ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "НаименованиеДляПечатныхФорм,"));
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн zampilot

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Программист 8.1
Re: эсм 7
« Ответ #2: 21 Май 2015, 09:53 »
Функция Печать() Экспорт
   ТабДокумент = Новый ТабличныйДокумент;
   Макет       = ПолучитьМакет("ЭСМ7");

   ЗапросШапки = Новый запрос;
   ЗапросШапки.Текст = "ВЫБРАТЬ
                       |   РеализацияТоваровУслуг.Ссылка,
                       |   РеализацияТоваровУслуг.ВерсияДанных,
                       |   РеализацияТоваровУслуг.ПометкаУдаления,
                       |   РеализацияТоваровУслуг.Номер,
                       |   РеализацияТоваровУслуг.Дата,
                       |   РеализацияТоваровУслуг.Проведен,
                       |   РеализацияТоваровУслуг.ВидОперации,
                       |   РеализацияТоваровУслуг.БанковскийСчетОрганизации,
                       |   РеализацияТоваровУслуг.ВалютаДокумента,
                       |   РеализацияТоваровУслуг.Комментарий,
                       |   РеализацияТоваровУслуг.Грузоотправитель,
                       |   РеализацияТоваровУслуг.Грузополучатель,
                       |   РеализацияТоваровУслуг.ДоговорКонтрагента,
                       |   РеализацияТоваровУслуг.АдресДоставки,
                       |   РеализацияТоваровУслуг.Контрагент,
                       |   РеализацияТоваровУслуг.КратностьВзаиморасчетов,
                       |   РеализацияТоваровУслуг.КурсВзаиморасчетов,
                       |   РеализацияТоваровУслуг.Организация,
                       |   РеализацияТоваровУслуг.Ответственный,
                       |   РеализацияТоваровУслуг.Склад,
                       |   РеализацияТоваровУслуг.СтатьяДоходовИРасходовПоТаре,
                       |   РеализацияТоваровУслуг.СуммаВключаетНДС,
                       |   РеализацияТоваровУслуг.СуммаДокумента,
                       |   РеализацияТоваровУслуг.СчетУчетаДоходовПоТаре,
                       |   РеализацияТоваровУслуг.СчетУчетаРасходовПоТаре,
                       |   РеализацияТоваровУслуг.СчетУчетаРасчетовПоАвансам,
                       |   РеализацияТоваровУслуг.СчетУчетаРасчетовПоТаре,
                       |   РеализацияТоваровУслуг.СчетУчетаРасчетовСКонтрагентом,
                       |   РеализацияТоваровУслуг.ТипЦен,
                       |   РеализацияТоваровУслуг.УчитыватьНДС,
                       |   РеализацияТоваровУслуг.РучнаяКорректировка,
                       |   РеализацияТоваровУслуг.СчетНаОплатуПокупателю,
                       |   РеализацияТоваровУслуг.СпособЗачетаАвансов,
                       |   РеализацияТоваровУслуг.Руководитель,
                       |   РеализацияТоваровУслуг.ГлавныйБухгалтер,
                       |   РеализацияТоваровУслуг.ОтпускПроизвел,
                       |   РеализацияТоваровУслуг.ЗаРуководителяПоПриказу,
                       |   РеализацияТоваровУслуг.ЗаГлавногоБухгалтераПоПриказу,
                       |   РеализацияТоваровУслуг.ДеятельностьНаПатенте,
                       |   РеализацияТоваровУслуг.Патент,
                       |   РеализацияТоваровУслуг._ОбъектСтроительства КАК ОбъектСтроительства,
                       |   РеализацияТоваровУслуг._Машина КАК Машина,
                       |   РеализацияТоваровУслуг._Марка КАК Марка,
                       |   РеализацияТоваровУслуг._ГосударственныйНомернойЗнак КАК ГосударственныйНомернойЗнак,
                       |   РеализацияТоваровУслуг._Машинисты КАК Машинисты
                       |ИЗ
                       |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                       |ГДЕ
                       |   РеализацияТоваровУслуг.Ссылка = &Ссылка";
   ЗапросШапки.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
   
   ВыборкаШапки = ЗапросШапки.Выполнить().Выбрать();
   ВыборкаШапки.Следующий();
   
   // // Шапка // *****   
   ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
   ЗаполнитьЗначенияСвойств(ОбластьМакета.Параметры, ВыборкаШапки);
   
   ОбластьМакета.Параметры.ОрганизацияОКПО = СокрЛП(СсылкаНаОбъект.Организация.КодПоОКПО);// ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект, "Акт");
   ОбластьМакета.Параметры.ПолучательОКПО = СокрЛП(СсылкаНаОбъект.Контрагент.КодПоОКПО);
   
//    ОбластьМакета.Параметры.НомерДок= ОбщегоНазначения.ПолучитьНомерНаПечать(ЭтотОбъект); 
//   ОбластьМакета.Параметры.НомерДок = СсылкаНаОбъект.Номер;

//   ТабДокумент.Вывести(ОбластьМакета);

   
//   ОбластьМакета.Параметры.ОрганизацияОКВЭД = СокрЛП(СсылкаНаОбъект.Организация.КодОКВЭД);
   ОбластьМакета.Параметры.Заказчик = "";
   
   // // ищем договор
   Договор = СокрЛП(СсылкаНаОбъект.ДоговорКонтрагента.Наименование);
   НомерД = "№";   
   позиц = Найти(Договор,"от");
   Если Позиц > 0 Тогда
      НомерД = Лев(Договор, Позиц-1);
      ДатаД  = Сред(Договор, Позиц+2);   
   КонецЕсли;
    ОбластьМакета.Параметры.Договор = "по договору № " + СсылкаНаОбъект.ДоговорКонтрагента.Номер + " от " + Формат(СсылкаНаОбъект.ДоговорКонтрагента.Дата,"ДЛФ=ДД"); // bila prosto data
//   ОбластьМакета.Параметры.ДатаДоговора = СсылкаНаОбъект.ДоговорКонтрагента.Дата;
   ОбластьМакета.Параметры.ДатаС=Формат(НачалоМесяца(СсылкаНаОбъект.Дата),"ДЛФ=Д");
   ОбластьМакета.Параметры.ДатаДо=Формат(КонецМесяца(СсылкаНаОбъект.Дата),"ДЛФ=Д");
   // // //
   
   //ОбластьМакета.Параметры.НомерДок = Формат(СсылкаНаОбъект.Номер,"ЧВН ");
     ОбластьМакета.Параметры.НомерДок = СсылкаНаОбъект.Номер;
   //ОбластьМакета.Параметры.НомерДок = ОбщегоНазначения.ПолучитьНомерНаПечать(СсылкаНаОбъект.Номер);
   //ОбластьМакета.Параметры.ДатаДок  = Формат(СсылкаНаОбъект.Дата,"ДЛФ=Д");
   ОбластьМакета.Параметры.ДокДень = Формат(СсылкаНаОбъект.Дата, "ДФ=dd");
   ОбластьМакета.Параметры.ДокМесяц = Формат(СсылкаНаОбъект.Дата, "ДФ=MM");
   ОбластьМакета.Параметры.ДокГод = Формат(СсылкаНаОбъект.Дата, "ДФ=yy");
   
    ПредставлениеПодрядчика = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата), "ИНН,КПП,ФактическийАдрес,Телефоны,");  //**В
   ПредставлениеПодрядчика1 = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата), "ПолноеНаименование,");
   ОбластьМакета.Параметры.Подрядчик = ПредставлениеПодрядчика1 + " ," + ПредставлениеПодрядчика;
   //ОбластьМакета.Параметры.ПоставщикУслуг = СсылкаНаОбъект.Организация;
   
   ПредставлениеЗаказчика = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Контрагент, СсылкаНаОбъект.Дата), "ПолноеНаименование,ИНН,КПП,ФактическийАдрес,Телефоны,");  //**В
//   ОбластьМакета.Параметры.Инвестор = ПредставлениеЗаказчика;
   ОбластьМакета.Параметры.Заказчик = ПредставлениеЗаказчика;
//   ОбластьМакета.Параметры.Получатель = СсылкаНаОбъект.Контрагент;

   
   //Если СсылкаНаОбъект.Проект = неопределено ИЛИ СсылкаНаОбъект.Проект = Справочники.Проекты.ПустаяСсылка() Тогда
   //   ПоказатьОповещениеПользователя("Внимание!", ,"Не выбран проект или незаполнены некоторые поля. Можно заполнить(изменить) вручную.",БиблиотекаКартинок.Внимание48);
   //Иначе
   //   ОбластьМакета.Параметры.ОбъектСтроительства = СокрЛП(СсылкаНаОбъект.Проект.Наименование);
   ////   ОбластьМакета.Параметры.Стройка = СокрЛП(СсылкаНаОбъект.Проект.Наименование);
   //КонецЕсли;

   Сумма    = СсылкаНаОбъект.Услуги.Итог("Сумма");
   СуммаНДС = СсылкаНаОбъект.Услуги.Итог("СуммаНДС");
   СуммаКПрописи = Сумма + ?(СсылкаНаОбъект.СуммаВключаетНДС, 0, СуммаНДС);
//   ОбластьМакета.Параметры.ТекстСметнаяСтоимость = "Сметная (договорная) стоимость в соответствии с договором подряда (субподряда) _______" + СсылкаНаОбъект.ВалютаДокумента.Наименование;//+ОбщегоНазначения.ФорматСумм(СуммаКПрописи, СсылкаНаОбъект.ВалютаДокумента);
   
   ТабДокумент.Вывести(ОбластьМакета);
   
   
// // // // // * * * * * * * * * * * * ** * * * * * * *    
   ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокТаб");
//   ПредставлениеПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата), "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,");  //**В
//   ОбластьМакета.Параметры.ПредставлениеПоставщика = ПредставлениеПоставщика;
//   ОбластьМакета.Параметры.Поставщик             = СсылкаНаОбъект.Организация;
   ТабДокумент.Вывести(ОбластьМакета);

//// // ПОКУПАТЕЛЬ //   
//   ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
//   ПредставлениеПолучателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Контрагент, СсылкаНаОбъект.Дата), "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,");  //**В
//   ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;
//   ОбластьМакета.Параметры.Получатель = СсылкаНаОбъект.Контрагент;
////**В   
//ОснованиеСделки = СокрЛП(СсылкаНаОбъект.ДоговорКонтрагента.Наименование);
//ОбластьМакета.Параметры.ОснованиеСделки = СсылкаНаОбъект.ДоговорКонтрагента.Наименование;
//   ОбластьМакета.Параметры.ДогПолучателя = СсылкаНаОбъект.ДоговорКонтрагента;
//////**В   
//   ТабДокумент.Вывести(ОбластьМакета);
//   
//// // Таблица   
//   ОбластьМакета = Макет.ПолучитьОбласть("ШапкаТаблицы");
//   ТабДокумент.Вывести(ОбластьМакета);
//   
   НомерСтроки = 0;
   Для Каждого ТекСтрокаУслуги Из СсылкаНаОбъект.Услуги Цикл
      НомерСтроки = НомерСтроки + 1;
      ОбластьМакета = Макет.ПолучитьОбласть("Строка");

//Сообщить("услуга:  "+СокрЛП(ТекСтрокаУслуги.Номенклатура)+"  Сумма= "+ТекСтрокаУслуги.Сумма, СтатусСообщения.Информация);
      //ОбластьМакета.Параметры.НомерСтроки = НомерСтроки;
      ОбластьМакета.Параметры.Товар = ?(ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.АктОбОказанииПроизводственныхУслуг"),
                                ТекСтрокаУслуги.Номенклатура.НаименованиеПолное,
                                ТекСтрокаУслуги.Содержание);
//      ОбластьМакета.Параметры.Номенклатура = ТекСтрокаУслуги.Номенклатура;
//      
      ОбластьМакета.Параметры.Количество=ТекСтрокаУслуги.Количество;
//      ОбластьМакета.Параметры.БазоваяЕдИзм = СокрЛП(ТекСтрокаУслуги.Номенклатура.БазоваяЕдиницаИзмерения.НаименованиеПолное);
      ЦенаБезНДС = ТекСтрокаУслуги.Цена;
      Если СсылкаНаОбъект.СуммаВключаетНДС Тогда
         ЦенаБезНДС = Ценообразование.ПересчитатьЦенуПриИзмененииФлаговНалогов(
            ЦенаБезНДС, Неопределено, Истина, Истина, Ложь, УчетНДС.ПолучитьСтавкуНДС(ТекСтрокаУслуги.СтавкаНДС));
      КонецЕсли;
         
      ОбластьМакета.Параметры.ЦенаБезНДС  = ЦенаБезНДС;
       ОбластьМакета.Параметры.СуммаБезНДС = ТекСтрокаУслуги.Сумма - ТекСтрокаУслуги.СуммаНДС;

//    //Сообщить("услуга:  "+СокрЛП(ТекСтрокаУслуги.Номенклатура.НаименованиеПолное)+"  Сумма= "+ТекСтрокаУслуги.Сумма+ " Цена::  "+ТекСтрокаУслуги.Цена, СтатусСообщения.Информация);
      ТабДокумент.Вывести(ОбластьМакета);
   
    КонецЦикла;
//   
   //ОбластьМакета = Макет.ПолучитьОбласть("НаклРасх");
   //ОбластьМакета.Параметры.СумНаклРуб = 0;
   //ТабДокумент.Вывести(ОбластьМакета);

   //ОбластьМакета = Макет.ПолучитьОбласть("ПланНак");
   //ОбластьМакета.Параметры.СумПланНакРуб = 0;
   //ТабДокумент.Вывести(ОбластьМакета);
   
   ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
   //суммируем деньги
   ОбластьМакета.Параметры.ИтогСуммы = СуммаКПрописи - СуммаНДС;//Сумма - СуммаНДС;
   ОбластьМакета.Параметры.ИтогНДС   = СуммаНДС;
   ОбластьМакета.Параметры.ИтогСуммыСНДС = СуммаКПрописи;
   //ОбластьМакета.Параметры.СуммаПрописью=ОбщегоНазначения.СформироватьСуммуПрописью(СуммаКПрописи, СсылкаНаОбъект.ВалютаДокумента);
   
   //суммируем количество(машино-часы)-------------------------   
    ИтогоЧасов = 0;
    Для Каждого ТекСтрокаУслуги Из СсылкаНаОбъект.Услуги Цикл
    ИтогоЧасов = ИтогоЧасов + ТекСтрокаУслуги.Количество;        
     КонецЦикла;
   
    ОбластьМакета.Параметры.ИтогоЧасов = ИтогоЧасов;
    ОбластьМакета.Параметры.Простой = " - ";
      ОбластьМакета.Параметры.СуммаПростой = " - ";
    ОбластьМакета.Параметры.ВсегоЧасов = ИтогоЧасов;   
   
    ФорматСтрока = "Л=ru_RU; НП=Истина; НД=Ложь;";
    ПарамПредмета = "час, часа, часов, м, , , , , 0";
    Если Цел(ИтогоЧасов) <> ИтогоЧасов И (ИтогоЧасов - Цел(ИтогоЧасов)) = 0.5 Тогда
      ТридцатьМинут = " тридцать минут";
      ИтогоЧасов = Цел(ИтогоЧасов);
   Иначе
      ТридцатьМинут = "";
   КонецЕсли;
    ОбластьМакета.Параметры.ЧасовПрописью = ЧислоПрописью(ИтогоЧасов, ФорматСтрока, ПарамПредмета);
    ОбластьМакета.Параметры.ТридцатьМинут = ТридцатьМинут;
   //-----------------------------------------------------------
   
   // Руководитель
   Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата,);
   Руководитель = Руководители.Руководитель;
   ДолжностьРуководителя = Руководители.РуководительДолжность;
   
   ОбластьМакета.Параметры.ДолжностьРуководителя = ДолжностьРуководителя;
   ОбластьМакета.Параметры.ФИОРуководителя = Руководитель;
   
   // Отдельно руководителя
   Попытка
      Если СсылкаНаОбъект.ПодписавшийОтветственный <> Справочники.СотрудникиОрганизаций.ПустаяСсылка() Тогда
         ОбластьМакета.Параметры.ФИОРуководителя = СсылкаНаОбъект.ПодписавшийОтветственный.Наименование
         //+" " + ПармаТелеком.ДоверенностьСотрудника(СсылкаНаОбъект.Дата, СсылкаНаОбъект.Организация, СсылкаНаОбъект.ПодписавшийОтветственный);
      КонецЕсли;
   Исключение
   КонецПопытки;
   
   Попытка
      Если СсылкаНаОбъект.ПодписавшийОтветственный <> Справочники.СотрудникиОрганизаций.ПустаяСсылка() Тогда
         ОбластьМакета.Параметры.ДолжностьРуководителя = ДолжностьРуководителя;   //ПармаТелеком.ДолжностьСотрудника(СсылкаНаОбъект.Дата, СсылкаНаОбъект.Организация, СсылкаНаОбъект.ПодписавшийОтветственный);
         ОбластьМакета.Параметры.ФИОРуководителя = Руководитель; 
      КонецЕсли;
   Исключение
   КонецПопытки;
   
   //Руководители = ОбщегоНазначения.ОтветственныеЛица(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата);
   //ОбластьМакета.Параметры.ДолжностьРуководителя = Руководители.РуководительДолжность;
   //ОбластьМакета.Параметры.ФИОРуководителя = Руководители.РуководительПредставление;
   ТабДокумент.Вывести(ОбластьМакета);
   
   
   ТабДокумент.ТолькоПросмотр=Истина;
   ТабДокумент.АвтоМасштаб = Истина;
   //ТабДокумент.МасштабПечати = 95;   
   //ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   ТабДокумент.ОтображатьГруппировки = ложь;
   ТабДокумент.ОтображатьЗаголовки = ложь;
   ТабДокумент.ОтображатьСетку = ложь;
   
   ТабДокумент.Показать("Справка для расчета за выполненные работы/услуги (Форма ЭСМ-7) для : "+СокрЛП(СсылкаНаОбъект.Контрагент));      

КонецФункции
надо под бп3 схреначить по какому направлению идти или тупо копировать вставить?

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Re: эсм 7
« Ответ #3: 21 Май 2015, 14:48 »
:o
Вот запрос например можно сократить до получения ссылки....этого вам будет достаточно чтобы вытащить все остальное...
А чтоб преобразовать, выдаем макет на печать, смотрим ошибку, исправляем под буху
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн zampilot

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Программист 8.1
Re: эсм 7
« Ответ #4: 22 Май 2015, 05:26 »
:o
Вот запрос например можно сократить до получения ссылки....этого вам будет достаточно чтобы вытащить все остальное...
А чтоб преобразовать, выдаем макет на печать, смотрим ошибку, исправляем под буху
ну под бп3 проблематично будет(( и это же впф, а там мне пф сразу делать(

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Re: эсм 7
« Ответ #5: 22 Май 2015, 13:53 »
Скрепя зубами...
Тем боле вам уже Модератор подсказал, исправляйте, смотрите на другие ошибки, опять исправляйте, да и какая разница какая форма(я про впф или пф)?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн zampilot

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Программист 8.1
Re: эсм 7
« Ответ #6: 23 Май 2015, 06:45 »
Скрепя зубами...
Тем боле вам уже Модератор подсказал, исправляйте, смотрите на другие ошибки, опять исправляйте, да и какая разница какая форма(я про впф или пф)?
Функция Печать() Экспорт
   ТабДокумент = Новый ТабличныйДокумент;
   Макет       = ПолучитьМакет("ЭСМ7");

   ЗапросШапки = Новый запрос;
   ЗапросШапки.Текст = "ВЫБРАТЬ
                       |   РеализацияТоваровУслуг.Ссылка,
                       |   РеализацияТоваровУслуг.ВерсияДанных,
                       |   РеализацияТоваровУслуг.ПометкаУдаления,
                       |   РеализацияТоваровУслуг.Номер,
                       |   РеализацияТоваровУслуг.Дата,
                       |   РеализацияТоваровУслуг.Проведен,
                       |   РеализацияТоваровУслуг.ВидОперации,
                       |   РеализацияТоваровУслуг.БанковскийСчетОрганизации,
                       |   РеализацияТоваровУслуг.ВалютаДокумента,
                       |   РеализацияТоваровУслуг.Комментарий,
                       |   РеализацияТоваровУслуг.Грузоотправитель,
                       |   РеализацияТоваровУслуг.Грузополучатель,
                       |   РеализацияТоваровУслуг.ДоговорКонтрагента,
                       |   РеализацияТоваровУслуг.АдресДоставки,
                       |   РеализацияТоваровУслуг.Контрагент,
                       |   РеализацияТоваровУслуг.КратностьВзаиморасчетов,
                       |   РеализацияТоваровУслуг.КурсВзаиморасчетов,
                       |   РеализацияТоваровУслуг.Организация,
                       |   РеализацияТоваровУслуг.Ответственный,
                       |   РеализацияТоваровУслуг.Склад,
                       |   РеализацияТоваровУслуг.СтатьяДоходовИРасходовПоТаре,
                       |   РеализацияТоваровУслуг.СуммаВключаетНДС,
                       |   РеализацияТоваровУслуг.СуммаДокумента,
                       |   РеализацияТоваровУслуг.СчетУчетаДоходовПоТаре,
                       |   РеализацияТоваровУслуг.СчетУчетаРасходовПоТаре,
                       |   РеализацияТоваровУслуг.СчетУчетаРасчетовПоАвансам,
                       |   РеализацияТоваровУслуг.СчетУчетаРасчетовПоТаре,
                       |   РеализацияТоваровУслуг.СчетУчетаРасчетовСКонтрагентом,
                       |   РеализацияТоваровУслуг.ТипЦен,
                       |   РеализацияТоваровУслуг.УчитыватьНДС,
                       |   РеализацияТоваровУслуг.РучнаяКорректировка,
                       |   РеализацияТоваровУслуг.СчетНаОплатуПокупателю,
                       |   РеализацияТоваровУслуг.СпособЗачетаАвансов,
                       |   РеализацияТоваровУслуг.Руководитель,
                       |   РеализацияТоваровУслуг.ГлавныйБухгалтер,
                       |   РеализацияТоваровУслуг.ОтпускПроизвел,
                       |   РеализацияТоваровУслуг.ЗаРуководителяПоПриказу,
                       |   РеализацияТоваровУслуг.ЗаГлавногоБухгалтераПоПриказу,
                       |   РеализацияТоваровУслуг.ДеятельностьНаПатенте,
                       |   РеализацияТоваровУслуг.Патент,
                       |   РеализацияТоваровУслуг._ОбъектСтроительства КАК ОбъектСтроительства,
                       |   РеализацияТоваровУслуг._Машина КАК Машина,
                       |   РеализацияТоваровУслуг._Марка КАК Марка,
                       |   РеализацияТоваровУслуг._ГосударственныйНомернойЗнак КАК ГосударственныйНомернойЗнак,
                       |   РеализацияТоваровУслуг._Машинисты КАК Машинисты
                       |ИЗ
                       |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                       |ГДЕ
                       |   РеализацияТоваровУслуг.Ссылка = &Ссылка";
   ЗапросШапки.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
Вот эту чать куда впихывать вообще не понял что за запросы такие и вот самое главное " РеализацияТоваровУслуг.Ссылка = &Ссылка";
   ЗапросШапки.УстановитьПараметр("Ссылка", СсылкаНаОбъект);"
я остальное понял

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Re: эсм 7
« Ответ #7: 23 Май 2015, 11:19 »
Перепишете запрос на:
ЗапросШапки = Новый запрос;
ЗапросШапки.Текст = "ВЫБРАТЬ
                    |   РеализацияТоваровУслуг.Ссылка,
                    |ИЗ
                    |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                    |ГДЕ
                    |   РеализацияТоваровУслуг.Ссылка = &Ссылка";
ЗапросШапки.УстановитьПараметр("Ссылка", СсылкаНаОбъект);

Вы получите ссылку на объект, в которой есть вся нужная информация
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
100 Сообщений
alex0402
30 Сообщений
pavl_vs
19 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
BuhRust
12 Сообщений

* Кто онлайн

  • Точка Гостей: 248
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal