Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переменная не определена!  (Прочитано 1049 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Бак Хрени

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Простите, вопрос дурацкий. Объясните, почему этот кусок кода не работает!

Перем ПроцессНачат экспорт;

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПроцессНачат = Ложь;   
КонецПроцедуры


&НаКлиенте
Процедура Далее(Команда)
   Если ПроцессНачат = Ложь Тогда;

Синтаксис контоль выдает:
 Переменная не определена (ПроцессНачат)
   Если <<?>>ПроцессНачат = Ложь Тогда; (Проверка: Тонкий клиент)


Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Простите, вопрос дурацкий. Объясните, почему этот кусок кода не работает!

Перем ПроцессНачат экспорт;

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПроцессНачат = Ложь;   
КонецПроцедуры


&НаКлиенте
Процедура Далее(Команда)
   Если ПроцессНачат = Ложь Тогда;

Синтаксис контоль выдает:
 Переменная не определена (ПроцессНачат)
   Если <<?>>ПроцессНачат = Ложь Тогда; (Проверка: Тонкий клиент)

А где КонцЕсли??
Если......Тогда.....Иначе...КонецЕсли

Оффлайн Бак Хрени

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Ученик 1С
КонецЕсли тоже имеется.

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Точку остановы, и смотрите что у вас в переменной ПроцессНачат
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Бак Хрени

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Ошибку выдает синтаксический контроль (Ctrl + F7), а не платформа при исполнении.
Добавлено: 20 Май 2015, 11:28

Вот так наверное оно полнее, Но проблема та-же

    Текст модуля формы

Перем Шаг экспорт;

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   Шаг = 1;   
КонецПроцедуры

&НаКлиенте
Процедура Далее(Команда)
   Если Шаг = 1 Тогда;
      Шаг=Шаг+1;
      Шаг1();
   ИначеЕсли Шаг = 2 Тогда;
      Шаг2();
   КонецЕсли;
   
КонецПроцедуры

+Процедура Шаг1()


+Процедура Шаг2()

Синтаксис контроль выдает:
{Обработка.ПроцессХЗ.Форма.Форма.Форма(11,7)}: Переменная не определена (Шаг)
   Если <<?>>Шаг = 1 Тогда; (Проверка: Тонкий клиент)

Последний раз редактировалось: Бак Хрени; 20 Май 2015, 11:28. Причина: Объединение сообщений

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
весь код процедуры предоставьте пожалуйста
Добавлено: 20 Май 2015, 11:48

&НаКлиенте
Перем Шаг экспорт;
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Последний раз редактировалось: Rasty; 20 Май 2015, 11:48. Причина: Объединение сообщений

Оффлайн Бак Хрени

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Текст модуля формы

Перем Шаг экспорт;

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   Шаг = 1;   
КонецПроцедуры

&НаКлиенте
Процедура Далее(Команда)
   Если Шаг = 1 Тогда;
      Шаг=Шаг+1;
      Шаг1();
   ИначеЕсли Шаг = 2 Тогда;
      Шаг2();
   КонецЕсли;
   
КонецПроцедуры

+Процедура Шаг1()


+Процедура Шаг2()

Это все пока! Процедуры Шаг1() и Шаг2() тоже пока пустуют. Начал писать обработку где нужно по 1 кнопке вызывать разные действия, номер действия решил хранить в переменной но наткнулся на данную проблему. Реализовать  задуманное можно и другими путями попробовать, но все же интересно что здесь не так.

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
А точка с запятой после слова тогда, зачем она нужна.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн Бак Хрени

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Rasty,
&НаКлиенте
Перем Шаг экспорт;

Точно! Спасибо большое!


А точка с запятой после слова тогда, зачем она нужна.
\

Привычка, да и никому она там не мешает!



Теги:
 

Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6330
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Ошибка Процедура или функция с указанным именем не определена

Автор ser36Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2567
Последний ответ 26 Май 2015, 09:45
от cska-fanat-kz
Процедура или функция с указанным именем не определена (Записать)

Автор oo ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1868
Последний ответ 02 Фев 2017, 13:04
от oo oo
Процедура или функция с указанным именем не определена

Автор asd_123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5604
Последний ответ 24 Янв 2012, 16:07
от asd_123
Для каждого запроса, области макета новая переменная?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 827
Последний ответ 29 Июн 2016, 10:15
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 341
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal