Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 10:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как в реквизите сделать ЗАГЛАВНЫЕ БУКВЫ ?  (Прочитано 3710 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте!

Есть реквизит ФИО при вводе нужно чтобы сразу вводилось ЗАГЛАВНЫМИ БУКВАМИ.
В Событие добавил след.код, но он почему то не работает :(.

&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
   ФИО = Строка (ВРег (Объект.ФИО));
КонецПроцедуры

Спасибо.
 


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
ИзменениеТекстаРедактирования (EditTextChange)
Синтаксис:

ИзменениеТекстаРедактирования(<Текст>, <СтандартнаяОбработка>)
Параметры:

<Текст>

Тип: Строка.
Содержит редактируемый текст.
<СтандартнаяОбработка>

Тип: Булево.
В данный параметр передается признак выполнения стандартной (системной) обработки события. Если после вызова обработчика данный параметр содержит значение Ложь, то не будут выполняться действия по автоподбору (в том числе, не будет вызван обработчик события АвтоПодбор).
Значение по умолчанию: Истина.
Описание:

Вызывается при изменении текста в поле ввода – при наборе текста, при работе с буфером обмена, при вызове команд "Отменить"/"Вернуть", а также при отмене ввода.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Да есть такое событие. Вставил код привед. выше. Не работает.

Оффлайн Kironten

  • *****
  • Сообщений: 899
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Как вариант, можно у реквизита сделать маску: "!!!!!!!!!!!!!!!" (без кавычек)

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Здравствуйте!

Есть реквизит ФИО при вводе нужно чтобы сразу вводилось ЗАГЛАВНЫМИ БУКВАМИ.
В Событие добавил след.код, но он почему то не работает :(.

&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
   ФИО = Строка (ВРег (Объект.ФИО));
КонецПроцедуры

Спасибо.
 

при вводе регистр верхний не будет, но при выходе из поля регистр должен поменяться.
сейчас не так? так не устраивает?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
при вводе регистр верхний не будет, но при выходе из поля регистр должен поменяться.
сейчас не так? так не устраивает?
[/quote]

При выходе не меняется. Вообще просто хотелось знать так можно сделать или нет ?

Оффлайн Kironten

  • *****
  • Сообщений: 899
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
при вводе регистр верхний не будет, но при выходе из поля регистр должен поменяться.
сейчас не так? так не устраивает?

При выходе не меняется. Вообще просто хотелось знать так можно сделать или нет ?
[/quote]

Попробуй сделать по другой обработке:
&НаКлиенте
Процедура ФИООкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, Параметры, СтандартнаяОбработка)
Объект.ФИО = ВРег(Текст);
КонецПроцедуры
тогда будет меняться по окончании ввода.
Если же нужно именно в процессе ввода, то тогда проще маской сделать.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Процедура ФИООкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, Параметры, СтандартнаяОбработка)
Объект.ФИО = ВРег(Текст);
КонецПроцедуры
тогда будет меняться по окончании ввода.
Если же нужно именно в процессе ввода, то тогда проще маской сделать.
[/quote]
Да работает.Спасибо Kironten.
Причём мой код - нет :(


Теги:
 

Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2026
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 221
Последний ответ 18 Авг 2017, 11:57
от ZSS
Как "Наименование" сделать числом

Автор zedikusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1723
Последний ответ 24 Авг 2015, 06:26
от cska-fanat-kz
Добрый вечер! Прошу помочь, кто знает, подскажите пож. В счете не выводит грузоотправителя и грузополучаетля. Куда их внести ? Как сделать что бы выводило ? У меня 1с 8.3 редакция 11.1 управление торговлей Спасибо!

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1960
Последний ответ 07 Фев 2016, 14:34
от pavl_vs
1 страница - портрет, 2 страница - ландшафт Подскажите как сделать?

Автор YaposhaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4551
Последний ответ 05 Апр 2012, 11:37
от Yaposha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal