Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2018, 05:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Комментарий в документе Закрытие заказов покупателей при закрытии.  (Прочитано 2413 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн leonid_adm

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-01
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!
Подскажите как можно реализовать.
Нужно чтобы комментарий из документа заказы покупателей подтягивался в документ Закрытие заказов покупателей при закрытии.


Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Получи ссылку на документ реализации, а из нее тащи комментарий...
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн leonid_adm

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-01
  • Сайт: 
  • Профессия: Программист 1С
Спасибо большое!
Добавил в процедуру Комментарий = Документы.ЗаказПокупателя.ПолучитьСсылку(Комментарий);

Добавлено: 15 Май 2015, 14:37

Хотя нет, выдает ошибку.
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{Документ.ЗакрытиеЗаказовПокупателей.МодульОбъекта(348)}: Ошибка при вызове метода контекста (ПолучитьСсылку)

по причине:
Несоответствие типов (параметр номер '1')

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Добрый день!
Подскажите как можно реализовать.
Нужно чтобы комментарий из документа заказы покупателей подтягивался в документ Закрытие заказов покупателей при закрытии.


как между собой "контачат" документ Заказ и документ Закрытие?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн leonid_adm

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-01
  • Сайт: 
  • Профессия: Программист 1С
КА 1.1.
Пробую
Комментарий = Документы.ЗаказПокупателя.ПолучитьОбъект(Комментарий);
            Комментарий.Записать();
Выдает ошибку несоответствия типов.

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
В общем заказы покупателя располагаются в табличной части "Заказы" документа ЗакрытиеЗаказовПокупателей. Реквизит ТЧ - ЗаказПокупателя.
Теоретически, надо обойти ТЧ. И из каждого документа выдрать комментарий.
Что то вроде:
СтрокаКомментария = "";
Для Каждого ЗаказДок Из Заказы Цикл
    СтрокаКомментария = СтрокаКомментария + ЗаказДок.ЗаказПокупателя.Комментарий + ", ";
КонецЦикла
Комментарий = Лев(СтрокаКомментария, СтрДлина(СтрокаКомментария) - 2);

Оффлайн leonid_adm

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-01
  • Сайт: 
  • Профессия: Программист 1С
Вставил в процедуру, значение подставляется при нажатии "записать", но при нажатии "ОК", выдается ошибка
Преобразование значения к типу Булево не может быть выполнено

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   
   Если ОбменДанными.Загрузка  Тогда
      Возврат;
   КонецЕсли;
   
    //Доработка
   Если НачалоДня(Дата) = НачалоДня(РабочаяДата) Тогда
      Дата = РабочаяДата + (ТекущаяДата() - НачалоДня(ТекущаяДата()));
   КонецЕсли;
   //КонецДоработка
   
СтрокаКомментария = "";
Для Каждого ЗаказДок Из Заказы Цикл
    СтрокаКомментария = ЗаказДок.ЗаказПокупателя.Комментарий;
КонецЦикла;
Комментарий = Лев(СтрокаКомментария, СтрДлина(СтрокаКомментария) - 2);
   
КонецПроцедуры // ПередЗаписью

Добавлено: 16 Май 2015, 11:40

Разобрался. Всем спасибо за помощь.

Последний раз редактировалось: leonid_adm; 16 Май 2015, 11:40. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для Каждого ЗаказДок Из Заказы Цикл
    СтрокаКомментария = ЗаказДок.ЗаказПокупателя.Комментарий;
КонецЦикла;

так вы получаете комментарий документа в последней строке!
посмотрите как написал Kironten (если конечно вам не именно так надо ;) )

можно тогда не гонять цикл а написать
Комментарий = Заказы[Заказы.Количество()-1].ЗаказПокупателя.Комментарий;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
можно тогда не гонять цикл а написать
Комментарий = Заказы[Заказы.Количество()-1].ЗаказПокупателя.Комментарий;

Если строк не будет, отвалится с ошибкой. Визгу от пользователей будет...
А прецеденты будут, к гадалке не ходи.


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3710
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 454
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3852
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2173
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 989
Последний ответ 31 Авг 2016, 16:02
от Masik777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
100 Сообщений
AIFrame
57 Сообщений
alex0402
29 Сообщений
kiksi
24 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
Norfolk
16 Сообщений
andron81_81
16 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 299
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal