Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Комментарий в документе зарытие заказов покупателей.  (Прочитано 707 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн leonid_adm

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-01
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!
Подскажите как можно реализовать.
Нужно чтобы комментарий из документа заказы покупателей подтягивался в документ Закрытие заказов покупателей при закрытии.


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Как закрываешь? отменой заявки?
тогда можно в список действий внести , и соответственно процедуру переваять типа:
Процедура С1Действия(Конт,СписокДействий)
Перем Действие;     
    Если СписокДействий.ВыбратьЗначение(Действие,,,,1)>0 Тогда   
Если Действие = "Отмена Заявки" Тогда
ОткрытьФорму("Документ.ОтменаЗаявок",Конт);
Конт.ДатаДок = РабочаяДата();
Конт.Фирма = Фирма;
                        Конт.КОММЕНТАРИЙ = Комментарий;
Конт.НоваяСтрока();
Конт.Заявка = Текущийдокумент();
Иначе
    глДействия1(Конт,Действие);
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Это не полная процедура, проверь еще если существует док. тогда не создавать , а просто открыть

Ну и прорцедуру  С1Действия(Контекст,СписокДействий) вместо  глДействия1 на кнопку
"кнДействия" повесь


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal