Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 02:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печатная форма  (Прочитано 2230 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Как можно в заголовке печатной формы вывести "Приходная накладная № (номер документа) от (дата документа)"
??


Оффлайн Дмитрий@

  • *****
  • Сообщений: 759
  • РЕПУТАЦИЯ: 138
  • КПД: 18%
  • Регистрация: 2015-02-27
  • Сайт: 
  • Профессия: Программист 1С
Re: Печатная форма
« Ответ #1: 14 Май 2015, 22:54 »
В макете печатной форме добавляете шаблон с параметрами, и при формировании печатной формы заполняете параметры.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Печатная форма
« Ответ #2: 15 Май 2015, 02:07 »
Именно об этом я и спрашиваю, не знаю как эти параметры записать

Оффлайн tapasko

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-05
  • Сайт: 
  • Профессия: Программист 1С
Re: Печатная форма
« Ответ #3: 15 Май 2015, 10:01 »
Именно об этом я и спрашиваю, не знаю как эти параметры записать

<Приходная накладная № [НомерДокумента] от [ДатаДокумента]>
НомерДокумента, ДатаДокумента - параметры, <..> - шаблон.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Печатная форма
« Ответ #4: 15 Май 2015, 16:59 »
Именно об этом я и спрашиваю, не знаю как эти параметры записать

<Приходная накладная № [НомерДокумента] от [ДатаДокумента]>
НомерДокумента, ДатаДокумента - параметры, <..> - шаблон.

<Приходная накладная № [НомерДокумента] от [ДатаДокумента]> это я вставил в печатную форму, а в код куда нужно пихнуть чтобы отображали?


Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   Макет = Документы.ПриходныеНакладные.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ПриходныеНакладные.Дата,
   |   ПриходныеНакладные.Номер,
   |   ПриходныеНакладные.Основание,
   |   ПриходныеНакладные.Поставщик,
   |   ПриходныеНакладные.Склад,
   |   ПриходныеНакладные.Товары.(
   |      НомерСтроки,
   |      Артикул,
   |      Наименование,
   |      ЕдИзм,
   |      Количество,
   |      Цена,
   |      СуммаНДС,
   |      Всего
   |   )
   |ИЗ
   |   Документ.ПриходныеНакладные КАК ПриходныеНакладные
   |ГДЕ
   |   ПриходныеНакладные.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   НомерДокумента, ДатаДокумента - параметры, <..> - шаблон.
         
   

   Шапка = Макет.ПолучитьОбласть("Шапка");
   ОбластьТоварыШапка = Макет.ПолучитьОбласть("ТоварыШапка");
   ОбластьТовары = Макет.ПолучитьОбласть("Товары");
   ОбластьИтог = Макет.ПолучитьОбласть("Всего");
   ОбластьСуммаНДС = Макет.ПолучитьОбласть("СуммаНДС");
   ТабДок.Очистить();

   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;

      ТабДок.Вывести(ОбластьЗаголовок);

      Шапка.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Шапка, Выборка.Уровень());

      ТабДок.Вывести(ОбластьТоварыШапка);
      ВыборкаТовары = Выборка.Товары.Выбрать();
      СуммаИтог = 0;
      СуммаСуммаНДС = 0;
      Пока ВыборкаТовары.Следующий() Цикл
         ОбластьТовары.Параметры.Заполнить(ВыборкаТовары);
         ТабДок.Вывести(ОбластьТовары, ВыборкаТовары.Уровень());
         СуммаИтог = СуммаИтог + ВыборкаТовары.Всего;
         СуммаСуммаНДС = СуммаСуммаНДС + ВыборкаТовары.СуммаНДС;
      КонецЦикла;
      
      ОбластьИтог.Параметры.ВсегоПоДокументу = СуммаИтог;
      ТабДок.Вывести(ОбластьИтог);
      ОбластьСуммаНДС.Параметры.СуммаНДСПоДокумету = СуммаСуммаНДС;
      ТабДок.Вывести(ОбластьСуммаНДС);
      
      ВставлятьРазделительСтраниц = Истина;
   КонецЦикла;
   //}}
    // Вывести подвал
       Всего = СуммаИтог;
       ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
      ОбластьПодвал.Параметры.Пропись = ЧислоПрописью(Всего,, "Рубль, рубля,рублей, м, копейка, копейки, копеек, ж ,2");
      ТабДок.Вывести(ОбластьПодвал);
      
      // Вывести Ввод
       
       ОбластьВвод = Макет.ПолучитьОбласть("Ввод");
            ТабДок.Вывести(ОбластьВвод);
   
КонецПроцедуры

Оффлайн Дмитрий@

  • *****
  • Сообщений: 759
  • РЕПУТАЦИЯ: 138
  • КПД: 18%
  • Регистрация: 2015-02-27
  • Сайт: 
  • Профессия: Программист 1С
Re: Печатная форма
« Ответ #5: 15 Май 2015, 17:23 »
Цитировать
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   НомерДокумента, ДатаДокумента - параметры, <..> - шаблон.
Там где вы указали.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Печатная форма
« Ответ #6: 15 Май 2015, 17:30 »
Решил сделать чуть по другому:

Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   Макет = Документы.ПриходныеНакладные.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ПриходныеНакладные.Дата,
   |   ПриходныеНакладные.Номер,
   |   ПриходныеНакладные.Основание,
   |   ПриходныеНакладные.Поставщик,
   |   ПриходныеНакладные.Склад,
   |   ПриходныеНакладные.Товары.(
   |      НомерСтроки,
   |      Артикул,
   |      Наименование,
   |      ЕдИзм,
   |      Количество,
   |      Цена,
   |      СуммаНДС,
   |      Всего
   |   )
   |ИЗ
   |   Документ.ПриходныеНакладные КАК ПриходныеНакладные
   |ГДЕ
   |   ПриходныеНакладные.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ТекстНомер =
   ТекстДата =
   ОбластьЗаголовок.Параметры.ТекстЗаголовка = "Приходная Накладная №" + ТекстНомер + " От " + ТекстДата;


А как присвоить переменным значения Номера и даты?
Добавлено: 15 Май 2015, 21:59

Нашел) :zebzdr:

Шапка = Запрос.Выполнить().Выбрать();
   Шапка.Следующий();
   ОбластьЗаголовок.Параметры.ТекстЗаголовка = "Приходная Накладная №" + Шапка.Номер + " от " + Шапка.Дата;

Последний раз редактировалось: Smokez; 15 Май 2015, 21:59. Причина: Объединение сообщений


Теги:
 

УТ 11.3 форма "УправлениеЭквайринговымТерминалом"

Автор skelaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 238
Последний ответ 09 Фев 2018, 21:23
от Геннадий ОбьГЭС
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5541
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94
Вопрос по УНФ (форма "Задание на работу")

Автор tantonyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 622
Последний ответ 22 Июн 2017, 18:22
от tantony
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5482
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7875
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
30 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal