Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 00:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расчет НДС  (Прочитано 21316 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, Интересует такой вопрос.
Есть документ Приходная накладная где реквизиты ... , цена, %НДС , сумма НДС.
Для %НДС используются перечисления (без НДС и 18%)
Требуется чтобы цена умножалась на %НДС и рассчитывалась сумма.
Каким образом можно это реализовать если в перечислении используется тип строка?


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Расчет НДС
« Ответ #1: 13 Май 2015, 22:35 »
>Каким образом можно это реализовать если в перечислении используется тип строка?
В перечислении не используется тип строка - оно самодостаточно, является типообразующим элементом.
В коде конфигурации посмотреть как оно реализовано - религия не позволяет?

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчет НДС
« Ответ #2: 13 Май 2015, 23:36 »
считаю НДС
СтрокаТабличнойЧасти.СуммаНДС = СтрокаТабличнойЧасти.НДС * СтрокаТабличнойЧасти.Сумма;
выдает ошибку "{Документ.ПриходныеНакладные.Форма.ФормаДокумента.Форма(17)}: Преобразование значения к типу Число не может быть выполнено СтрокаТабличнойЧасти.СуммаНДС = "
Нужно присвоить значениям (18% и БезНДС) перечисления числовые значения (18% - 0.18) и (БезНДС - 1)
не знаю как это сделать

Оффлайн Sandi

  • Hit any key to continue
  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-02-25
  • Сайт: 
Re: Расчет НДС
« Ответ #3: 14 Май 2015, 00:17 »
Самый простой вариант, если лень искать в конфигураторе:


Если СтрокаТабличнойЧасти.НДС= Перечисления.СтавкиНДС.НДС18 Тогда
     СтрокаТабличнойЧасти.СуммаНДС = 0.18 * СтрокаТабличнойЧасти.Сумма
ИначеЕсли СтрокаТабличнойЧасти.НДС= Перечисления.СтавкиНДС.БезНДС Тогда
      СтрокаТабличнойЧасти.СуммаНДС = 0
КонецЕсли

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчет НДС
« Ответ #4: 14 Май 2015, 00:35 »
{Документ.ПриходныеНакладные.Форма.ФормаДокумента.Форма(17,34)}: Переменная не определена (Перечисления)
   Если СтрокаТабличнойЧасти.НДС = <<?>>Перечисления.СтавкиНДС.НДС Тогда (Проверка: Тонкий клиент)
Стыдно, но все же, как исправить?

Оффлайн Sandi

  • Hit any key to continue
  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-02-25
  • Сайт: 
Re: Расчет НДС
« Ответ #5: 14 Май 2015, 08:21 »
попробуйте вынести получение этой ставки в  функцию, выполняемую на сервере

&НаСервере
Функция ПолучитьСтавкуНДС18()
Возврат Перечисления.СтавкиНДС.НДС18
КонецФункции


и потом вызовите ее в своей процедуре:

 Если СтрокаТабличнойЧасти.НДС = ПолучитьСтавкуНДС18() Тогда 


и т.д.

Оффлайн Евгений@

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 4
  • КПД: 36%
  • Регистрация: 2015-05-12
  • Сайт: 
Re: Расчет НДС
« Ответ #6: 14 Май 2015, 09:33 »
попробуйте вынести получение этой ставки в  функцию, выполняемую на сервере

&НаСервере
Функция ПолучитьСтавкуНДС18()
Возврат Перечисления.СтавкиНДС.НДС18
КонецФункции


и потом вызовите ее в своей процедуре:

 Если СтрокаТабличнойЧасти.НДС = ПолучитьСтавкуНДС18() Тогда 


и т.д.

Наверное, чуть более правильно: сделать один внеконтекстный серверный вызов для получения процента и выполнить расчет
&НаСервереБезКонтекста
Функция ПолучитьПроцентНДС(Ставка)

Если Ставка = Перечисления.СтавкиНДС.НДС18 Тогда
Возврат 18;
//ИначеЕсли  Ставка = Перечисления.СтавкиНДС.НДС9 Тогда
// Возврат 9;
Иначе
Возврат 0;
КонецЕсли;

КонецФункции

СтрокаТабличнойЧасти.СуммаНДС = ПолучитьПроцентНДС(СтрокаТабличнойЧасти.НДС) * СтрокаТабличнойЧасти.Сумма;

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчет НДС
« Ответ #7: 14 Май 2015, 14:53 »
попробуйте вынести получение этой ставки в  функцию, выполняемую на сервере


&НаСервере
Функция ПолучитьСтавкуНДС18()
Возврат Перечисления.СтавкиНДС.НДС18
КонецФункции


и потом вызовите ее в своей процедуре:

 Если СтрокаТабличнойЧасти.НДС = ПолучитьСтавкуНДС18() Тогда 


и т.д.

Пробовал но все равно пишет: Переменная не определена (Перечисления)
&НаСервере
Функция ПолучитьНДС18(СтавкаНДС)
Возврат Перечисления.СтавкиНДС.НДС18
КонецФункции

&НаСервере
Функция ПолучитьБезНДС(СтавкаНДС)
Возврат Перечисления.СтавкиНДС.БезНДС
КонецФункции

&НаКлиенте
Процедура ТоварыНДСПриИзменении(Элемент)
   СтрокаТабличнойЧасти = Элементы.Товары.ТекущиеДанные;
   Если СтрокаТабличнойЧасти.НДС= Перечисления.СтавкиНДС.НДС18 Тогда
     СтрокаТабличнойЧасти.СуммаНДС = 0.18 * СтрокаТабличнойЧасти.Сумма
   ИначеЕсли СтрокаТабличнойЧасти.НДС= Перечисления.СтавкиНДС.БезНДС Тогда
      СтрокаТабличнойЧасти.СуммаНДС = 0
   КонецЕсли
КонецПроцедуры

ui;;t;

Оффлайн Sandi

  • Hit any key to continue
  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-02-25
  • Сайт: 
Re: Расчет НДС
« Ответ #8: 14 Май 2015, 15:03 »
попробуйте вынести получение этой ставки в  функцию, выполняемую на сервере


&НаСервере
Функция ПолучитьСтавкуНДС18()
Возврат Перечисления.СтавкиНДС.НДС18
КонецФункции


и потом вызовите ее в своей процедуре:

 Если СтрокаТабличнойЧасти.НДС = ПолучитьСтавкуНДС18() Тогда 


и т.д.

Пробовал но все равно пишет: Переменная не определена (Перечисления)
&НаСервере
Функция ПолучитьНДС18()  -  убирайте парамеитр "СтавкаНДС" Он в теле функции не используется
Возврат Перечисления.СтавкиНДС.НДС18
КонецФункции

&НаСервере
Функция ПолучитьБезНДС()  - то же самое
Возврат Перечисления.СтавкиНДС.БезНДС
КонецФункции

&НаКлиенте
Процедура ТоварыНДСПриИзменении(Элемент)
   СтрокаТабличнойЧасти = Элементы.Товары.ТекущиеДанные;
   Если СтрокаТабличнойЧасти.НДС= Перечисления.СтавкиНДС.НДС18 Тогда надо писать Если СтрокаТабличнойЧасти.НДС= ПолучитьНДС18() Тогда
     СтрокаТабличнойЧасти.СуммаНДС = 0.18 * СтрокаТабличнойЧасти.Сумма
   ИначеЕсли СтрокаТабличнойЧасти.НДС= Перечисления.СтавкиНДС.БезНДС Тогда надо писать ИначеЕсли СтрокаТабличнойЧасти.НДС= ПолучитьБезНДС() Тогда
      СтрокаТабличнойЧасти.СуммаНДС = 0
   КонецЕсли
КонецПроцедуры

ui;;t;


или сделайте, как Евгений предложил - его метод более удачный.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчет НДС
« Ответ #9: 14 Май 2015, 15:42 »
Огромное спасибо, все заработало :zebzdr:


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3186
Последний ответ 21 Мар 2015, 20:24
от дфтын
1с82 ЗУП: Расчет по среднему:надбавка учитывается и не учитывается

Автор PushastРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3836
Последний ответ 05 Окт 2011, 11:13
от Pushast
Отчет о НЕ уволенных сотрудниках и расчет начислений, как для уволенных

Автор medoedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3674
Последний ответ 02 Фев 2012, 14:49
от medoed
Расчет процента автоматической скидки и скидки наценки

Автор Max99990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 4484
Последний ответ 31 Янв 2016, 02:33
от дфтын

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 178
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal