Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создние ВПФ: Переменная не определена (ОтпускРазрешил)  (Прочитано 1475 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RomanSKV

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Конфигурация: Комплексная автоматизация, редакция 1.1 + CRM, редакция 1.4 (1.1.59/1.4.10)

Создаю внешнюю печатную форму "АктНаОказаниеУслуг" из встроенной. Тема заезженная и в интернете технология создания таких ВПФ уже описана, и довольно подробно.
Создал внешнюю обработку, в ней добавил реквизит "СсылкаНаОбъект" нужного типа... И так далее по инструкции.
Но в конце концов всё равно вылезает насущная ошибка :(:
Переменная не определена (ОтпускРазрешил)
И
Переменная не определена (ЗаРуководителяПоПриказу)

Ниже сокращенный текст. Жирным выделяю место с ошибкой:

Перем мВалютаРегламентированногоУчета Экспорт;

Функция Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь) Экспорт
      Если ИмяМакета = "Акт" Тогда
      ТабДокумент = ПечатьАктаОбОказанииУслуг(Ложь);
        Возврат ТабДокумент;
     КонецЕсли
   КонецФункции

Функция ПечатьАктаОбОказанииУслуг(СуммыВРублях = Ложь)
   
   ЗапросШапка = Новый Запрос;
   ЗапросШапка.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
   ЗапросШапка.Текст =
***********************
   
   ТабДокумент.Вывести(ОбластьМакета);

   ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
   Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Организация, Дата);
   Если Руководители.РуководительДолжность = "" Тогда
      ДолжностьИНазваниеОрганизации = Организация.НаименованиеПолное;
   Иначе
      ДолжностьРук = Руководители.РуководительДолжность;
      ДолжностьИНазваниеОрганизации = ?(НЕ ЗначениеЗаполнено(ДолжностьРук), Организация.НаименованиеПолное, ДолжностьРук + " " + Организация.НаименованиеПолное);
   КонецЕсли;
   
   Если ЗначениеЗаполнено(ОтпускРазрешил) И ОтпускРазрешил <> Руководители.Руководитель Тогда
      ЗаместительПоПриказу = "("+ОбщегоНазначения.ФамилияИнициалыФизЛица(ОтпускРазрешил) + " " + ЗаРуководителяПоПриказу+")";
   Иначе
      ЗаместительПоПриказу = Руководители.Руководитель;
   КонецЕсли;
   
   ОбластьМакета.Параметры.ДолжностьИНазваниеОрганизации    = ДолжностьИНазваниеОрганизации;
   ОбластьМакета.Параметры.ЗаместительПоПриказу          = ЗаместительПоПриказу;
   ТабДокумент.Вывести(ОбластьМакета);

   Возврат ТабДокумент;
   
КонецФункции // ПечатьАктаОбОказанииУслуг()

мВалютаРегламентированногоУчета = глЗначениеПеременной("ВалютаРегламентированногоУчета");

:dfbsdfbsdf:
Подскажите, пожалуйста, где и как правильно определить эти переменные.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну может что нить вроде
"Док.ОтпускРазрешил" или "Шапка.ОтпускРазрешил"?
Правильно ругается, у обработки (читай "у ВПФ") таких реквизитов нет.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн RomanSKV

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-21
  • Сайт: 
  • Профессия: Ученик 1С
ну может что нить вроде
"Док.ОтпускРазрешил" или "Шапка.ОтпускРазрешил"?
Правильно ругается, у обработки (читай "у ВПФ") таких реквизитов нет.

Спасибо за ответ.
Пытался подставлять "СсылкаНаОбъект.ОтпускРазрешил" и "Подписи.ОтпускРазрешил", где "Подписи" - область макета.
В первом случае возникают новые ошибки о том, что не определены "Организация" и "Дата"
Во втором - не определена переменная "Подписи"

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вы зря пропустили текст после
"ЗапросШапка = Новый Запрос;
   ЗапросШапка.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
   ЗапросШапка.Текст ="

тут идет запрос к шапке вашего документа.
вангую: далее встретите текст типа
    ЧтоТо = ЗапросШапка.Выполнить().Выбрать();
    ЧтоТо.Следующий()

Соответственно все реквизиты шапки документа надо использовать в виде
    ЧтоТо.РеквизитШапки

Вариант "СсылкаНаОбъект." также рабочий, но лучше так не делать )

Само собой исправили обращение к одним реквизитам, начали выходить ошибки про другие.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6365
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Ошибка Процедура или функция с указанным именем не определена

Автор ser36Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2581
Последний ответ 26 Май 2015, 09:45
от cska-fanat-kz
Процедура или функция с указанным именем не определена (Записать)

Автор oo ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1884
Последний ответ 02 Фев 2017, 13:04
от oo oo
Процедура или функция с указанным именем не определена

Автор asd_123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5609
Последний ответ 24 Янв 2012, 16:07
от asd_123
Для каждого запроса, области макета новая переменная?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 832
Последний ответ 29 Июн 2016, 10:15
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 343
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal