Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 23:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расчёт даты  (Прочитано 3400 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Есть такой вопрос как расчёт времени.
Т.е. У меня есть документ стоянка. В ней есть реквизит Дата. Как рассчитать время отбытия если учитывать что рассчитывается по часам, суткам, неделям, месяцам (перечисления в реквезите тарификация)


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Расчёт даты
« Ответ #1: 12 Май 2015, 23:45 »
Я б написал запрос. В нем есть хорошая функция РазностьДат

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Расчёт даты
« Ответ #2: 13 Май 2015, 07:57 »
МояДата постарела на 1 час:
МояДата = МояДата + 60*60;

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчёт даты
« Ответ #3: 13 Май 2015, 08:19 »
МояДата постарела на 1 час:
МояДата = МояДата + 60*60;
Не совсем понятно почему 60*60?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Расчёт даты
« Ответ #4: 13 Май 2015, 08:28 »
МояДата постарела на 1 час:
МояДата = МояДата + 60*60;
Не совсем понятно почему 60*60?

потому что если к дате прибавить число, то это считается как количество секунд
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчёт даты
« Ответ #5: 13 Май 2015, 08:30 »
МояДата постарела на 1 час:
МояДата = МояДата + 60*60;
Ну могу предположить, что это в секундах...
Но всё ровно многое не понятно... Написал такой код:
&НаКлиенте
Процедура СрокСтоянкиПриИзменении()
    Объект.ДатаОтбытия = ПолучитьДату();
КонецПроцедуры

 &НаСервере
 Функция ПолучитьДату();
Если Объект.Тарификация = Перечисления.Тарификация.Час Тогда
Дата = Объект.Дата+60*60*объект.СрокСтоянки;
ИначеЕсли Объект.Тарификация = Перечисления.Тарификация.Сутки Тогда   
        Дата = Объект.Дата+60*60*24*объект.СрокСтоянки;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификация.Неделя Тогда
        Дата = Объект.Дата+60*60*24*7*объект.СрокСтоянки;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификация.Месяц Тогда
        Дата = Объект.Дата+60*60*24*7*30*объект.СрокСтоянки;
КонецЕсли;
КонецФункции


Ни чего не считает
Добавлено: 13 Май 2015, 08:35

Всем спасибо за помощь!!! Разобрался, в конце забыл прописать Возврат Даты;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Расчёт даты
« Ответ #6: 13 Май 2015, 09:10 »
ИначеЕсли Объект.Тарификация = Перечисления.Тарификация.Месяц Тогда         
    Дата = Объект.Дата+60*60*24*7*30*объект.СрокСтоянки;

а если дней в месяце 31 или 28? )))
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчёт даты
« Ответ #7: 13 Май 2015, 09:13 »
ИначеЕсли Объект.Тарификация = Перечисления.Тарификация.Месяц Тогда         
    Дата = Объект.Дата+60*60*24*7*30*объект.СрокСтоянки;

а если дней в месяце 31 или 28? )))

А ещё может быть 29.. Но я это уже точно сделать не смогу :(

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Расчёт даты
« Ответ #8: 13 Май 2015, 09:17 »
Я б написал запрос. В нем есть хорошая функция РазностьДат

а также ооооооочень хорошая функция ДОБАВИТЬКДАТЕ()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Расчёт даты
« Ответ #9: 13 Май 2015, 09:21 »
Функция ДобавитьКДате(Дата, Тип, Количество)

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ДОБАВИТЬКДАТЕ(&Дата, "+Тип+", &Количество) КАК Результат";

   Запрос.УстановитьПараметр("Дата", Дата);
   Запрос.УстановитьПараметр("Количество", Количество);

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   ВыборкаДетальныеЗаписи.Следующий();
   
   Возврат ВыборкаДетальныеЗаписи.Результат;

КонецФункции // ДобавитьКДате()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3184
Последний ответ 21 Мар 2015, 20:24
от дфтын
1с82 ЗУП: Расчет по среднему:надбавка учитывается и не учитывается

Автор PushastРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3836
Последний ответ 05 Окт 2011, 11:13
от Pushast
Отчет о НЕ уволенных сотрудниках и расчет начислений, как для уволенных

Автор medoedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3672
Последний ответ 02 Фев 2012, 14:49
от medoed
Расчет процента автоматической скидки и скидки наценки

Автор Max99990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 4481
Последний ответ 31 Янв 2016, 02:33
от дфтын

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
41 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 219
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal