Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание и изменение быстрого отбора в отчёте  (Прочитано 6401 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Golickoff

  • ****
  • Сообщений: 359
  • РЕПУТАЦИЯ: 36
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет.
Есть отчёт из типовой конфигурации. На его форме есть кнопка "Отбор" при нажатии на которую на форме появляются 2 строки с быстрым отбором. Выглядит это вот так:

При нажатии на кнопку "Отбор" срабатывает вот такой код:
Если БыстрыйОтборРазвернут Тогда

Форма.ЭлементыФормы.ПанельБыстрыеОтборы.Свертка = РежимСверткиЭлементаУправления.Нет;

Иначе

Форма.ЭлементыФормы.ПанельБыстрыеОтборы.Свертка = РежимСверткиЭлементаУправления.Верх;

КонецЕсли;
То есть, поле с быстрым отбором просто разворачивается, либо сворачивается. А теперь вопрос: как мне отредактировать это поле с быстрыми отборами, если я не вижу ПанельБыстрыеОтборы при открытии формы отчёта в конфигураторе?
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
А что вы там хотите "науправлять"? список быстрых отборов задается при инициализации начальных настроек в модуле отчета.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
В контрукторе СКД на закладке отбор для отборов указывается быстрый доступ. Именно эти отборы и включаются в эту панель автоматом.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В контрукторе СКД на закладке отбор для отборов указывается быстрый доступ. Именно эти отборы и включаются в эту панель автоматом

Это отчет на построителе отчетов.

Оффлайн Golickoff

  • ****
  • Сообщений: 359
  • РЕПУТАЦИЯ: 36
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
А что вы там хотите "науправлять"? список быстрых отборов задается при инициализации начальных настроек в модуле отчета.
Я лишь хочу добавить ещё один отбор и хотел бы понять как мне это сделать.
Цитировать
В контрукторе СКД на закладке отбор для отборов указывается быстрый доступ. Именно эти отборы и включаются в эту панель автоматом.
Я первым делом полез в эту закладку и был очень удивлён отсутствием в ней отборов. При добавлении туда своего отбора с указанием быстрого доступа он не отобразился на форме, что вполне логично -- форма уже создана, т.е. генерируется не автоматически.
Цитировать
Это отчет на построителе отчетов.
Это отчёт на СКД.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн Евгений@

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 4
  • КПД: 36%
  • Регистрация: 2015-05-12
  • Сайт: 
Это отчет на основании универсального отчета (реквизит УниверсальныйОтчет). Из обработчика "ПриОткрытии" формы универсального отчета вызывается процедура ДобавитьПанельБыстрыеОтборы

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Это отчёт на СКД.

:) Ну, тогда печаль. Печаль что вы столько времени занимаетесь этим вопросом и до сих пор не разобрались что это отчет на построителе. 
У вас на скрине отчет из типовой, скорее всего, торговли 10. А там все на построителе. И если вы там нашли СКД - значит вы ОООООООООООООчень хорошо искали черную кошку в черной комнате.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Чтобы не спорить на чем отчет, предлагаю выложить скриншот СКД или констуктора запроса и закрыть этот вопрос.

Оффлайн Golickoff

  • ****
  • Сообщений: 359
  • РЕПУТАЦИЯ: 36
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
У вас на скрине отчет из типовой, скорее всего, торговли 10
Цитировать
предлагаю выложить скриншот СКД

Добавлено: 14 Май 2015, 06:46

Это отчет на основании универсального отчета (реквизит УниверсальныйОтчет). Из обработчика "ПриОткрытии" формы универсального отчета вызывается процедура ДобавитьПанельБыстрыеОтборы
Можно более подробно про этот реквизит? Где он должен быть? У отчёта его нет. Что касается процедуры ПриОткрытии, самое интересное в ней выглядит так
Если КраткийВидНастройки Тогда

Если НЕ Константы.ИспользоватьХарактеристикиНоменклатуры.Получить() Тогда
УбратьУстановленныеГруппировкиИОтборы(ЭтотОбъект, "ХарактеристикаНоменклатуры");
КонецЕсли;

Если НЕ Константы.УчетПартийПоФирмам.Получить() Тогда
УбратьУстановленныеГруппировкиИОтборы(ЭтотОбъект, "Фирма");
КонецЕсли;

КонецЕсли;

СтруктураДанных.Вставить("МассивБыстрыхОтборов", МассивБыстрыхОтборов);

отчДобавитьПанельБыстрыеОтборы(ЭтотОбъект, ЭтаФорма, СтруктураДанных);
ЭлементыФормы.ДействияФормы.Кнопки.БыстрыйОтбор.Пометка = Ложь;
отчУправлениеПанельюБыстрыеОтборы(ЭтотОбъект, ЭтаФорма, ЭлементыФормы.ДействияФормы.Кнопки.БыстрыйОтбор.Пометка);
Не подскажете что за МассивБыстрыхОтборов?
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Последний раз редактировалось: Golickoff; 14 Май 2015, 06:46. Причина: Объединение сообщений

Оффлайн Евгений@

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 4
  • КПД: 36%
  • Регистрация: 2015-05-12
  • Сайт: 
В УПП в отчетах, внешний вид которых похож на отчет ТС, для того чтобы добавить отборы и прочее нужно в модуле объекта отчета внести изменения в процедуру:
// Процедура установки начальных настроек отчета по метаданным регистра накопления
//
Процедура УстановитьНачальныеНастройки(ДополнительныеПараметры = Неопределено) Экспорт
//...
//...
// Добавление предопределенных отборов отчета.
// Необходимо вызывать для каждого добавляемого отбора.
// УниверсальныйОтчет.ДобавитьОтбор(<ПутьКДанным>);
УниверсальныйОтчет.ДобавитьОтбор("Контрагент");
УниверсальныйОтчет.ДобавитьОтбор("Номенклатура");
УниверсальныйОтчет.ДобавитьОтбор("Проект");
УниверсальныйОтчет.ДобавитьОтбор("Подразделение");
//...
//...
КонецПроцедуры // УстановитьНачальныеНастройки()


 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4510
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4457
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3888
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание заказаов на производство на основании заказа на производство.

Автор Елена1986Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 7888
Последний ответ 09 Сен 2015, 13:01
от Елена1986
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1193
Последний ответ 26 Сен 2016, 16:25
от NataVl

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 225
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal