Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2017, 01:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматическая ставка данных в табличную часть документа  (Прочитано 1062 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nadeev

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-04
  • Сайт: 
  • Профессия: Ученик 1С
Есть документ "Зачисление на курсы" в этом документе есть табличная часть с реквизитами: ФИО и должность. Как можно сделать так чтобы при выборе ФИО, должность ставилась автоматический. Его нужно брать из справочника "Должность". Не могу осуществить, подскажите хотя бы направление...


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
как связано ФИО и должность?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн nadeev

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-04
  • Сайт: 
  • Профессия: Ученик 1С
Есть справочник "Сотрудники", там есть реквизиты ФИО, должность)
Добавлено: 11 Май 2015, 17:22

&НаСервере
Функция ЗаполнитьДолжность()
   
  Должность=Справочники.Должность.НайтиПоНаименованию("охранник");
   Возврат Должность;   

КонецФункции

&НаКлиенте
Процедура ТабличнаяЧасть1СотрудникПриИзменении(Элемент)
      СтрокаТабличнойЧасти=Элементы.ТабличнаяЧасть1.ТекущиеДанные;
      СтрокаТабличнойЧасти.Должность=ЗаполнитьДолжность();
КонецПроцедуры

Добавлено: 11 Май 2015, 17:24

Хотел написать в таком виде, только так можно вывести только какую нибудь конкретную должность, то есть так выводит только определенную должность, которая указывается в функции

Оффлайн enniskillen

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 4
  • КПД: 44%
  • Регистрация: 2015-05-11
  • Сайт: 
Например, вот так.

&НаКлиенте
Процедура ТабличнаяЧастьСотрудникПриИзменении(Элемент)
ТекущиеДанные = Элементы.ТабличнаяЧасть.ТекущиеДанные;
ТекущиеДанные.Должность = ПолучитьДолжность(ТекущиеДанные.Сотрудник);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьДолжность(Сотрудник)
Возврат Сотрудник.Должность;
КонецФункции

Обращение на сервер необходимо потому, что на клиенте невозможно обращение к базе данных. Без контекста потому, что нам не требуются данные формы для получения должности. Достаточно передать ссылку на сотрудника, а от нее получить должность, обращаясь через точку.

Оффлайн nadeev

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-04
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо большое :zebzdr::zebzdr::zebzdr:, мучился несколько дней


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4491
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15972
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4215
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 651
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7764
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame
73 Сообщений
alex0402
52 Сообщений
ilyay ilyay
51 Сообщений
andron81_81
44 Сообщений
oleg-x
35 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal