Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 11:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Бухгалтерские итоги. Периодичность  (Прочитано 1221 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mirsobit Musayev

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: ГлавБух
Здравствуйте!
 у меня 1с 7.7.
 создал отчет по пенсионным взносам граждан.
 отчет ежеквартально сформируется.
 графы отчеты:
 1. ФИО
 2. ИНН
 3. суммы взноса с начала года до настоящего квартала
 4.5.6. сумма взноса за 1-2-3-й месяца текущего квартала
 7. общая сумма взноса в ПФ с начала года, т.е. гр.3+гр.4+гр.5+гр.6
 текс модула:

НачУд=СоздатьОбъект("Справочник.НачисленияИУдержания");  
  НачУд.НайтиПоКоду("1020"); 
  Взнось=НачУд.ТекущийЭлемент(); 
  Таб = СоздатьОбъект("Таблица"); 
  Таб.ИсходнаяТаблица("Свод"); 
   
  Ит = СоздатьОбъект("БухгалтерскиеИтоги"); 
  Ит.ИспользоватьСубконто(ВидыСубконто.НачУд,Взнось,2); 
  Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники); 
  Ит.ВыполнитьЗапрос(НачГода(ДатаН1мес),ДатаК3мес,,,,2,"Месяц","С"); 
   
  Таб.ВывестиСекцию("Шапка"); 
  Ит.ВыбратьСубконто(ВидыСубконто.Сотрудники); 
  НомПП=0; 
  Пока Ит.ПолучитьСубконто(ВидыСубконто.Сотрудники) = 1 Цикл 
  Если Ит.ДО()<>0 Тогда 
  НомПП=НомПП+1; 
  сум1м=Ит.ДО();    // сумма взноса за 1-й месяц квартала 
  сум2м=Ит.ДО();    // сумма взноса за 2-й месяц квартала 
  Сум3м=Ит.ДО();    // сумма взноса за 3-й месяц квартала 
  Таб.ВывестиСекцию("Строка"); 
  КонецЕсли 
  КонецЦикла; 
  Таб.ВывестиСекцию("Подвал"); 
  Таб.ТолькоПросмотр(1); 
  Таб.Показать("Сформировать",""); 
  КонецПроцедуры
как мне получить бух.итоги за определенный месяц?
 в книге написано, что Ит.ВыполнитьЗапрос(НачГода(ДатаН1мес),ДатаК3мес,,,,2,"Месяц","С")
<Периодичность> - число или символьная строка (см. документацию).Позволяет получить дополнительный разрез итогов по периодам. По умолчанию периодичность не задана.


Оффлайн nemox

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 4
  • КПД: 31%
  • Регистрация: 2015-04-18
  • Сайт: 
  • Профессия: Программист 1С
На сколько я помню, перед выполнением запроса нужно сделать временный расчет итогов


Теги:
 

0503769 форма Отрицательные итоги кредиторской задолженности отражаются с плюсом в дебиторке и соответственно отрицательная дебиторская задолженность ложится в кредиторку

Автор Alexandra_m_cРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2299
Последний ответ 07 Апр 2015, 11:15
от Alexandra_m_c
Dive In MARKETING & SALES 2016! Winter session. Итоги года и прогноз на 2017г

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 458
Последний ответ 08 Ноя 2016, 17:04
от mixqn
Как вывести развернутые итоги по задолженности клиентов (покупателей/контраген.)

Автор DenPlusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3875
Последний ответ 14 Дек 2010, 22:20
от DenPlus
Проблема с запросом 1с (итоги, начальный, конечный остатки)

Автор cbr900Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3149
Последний ответ 13 Янв 2010, 16:31
от cbr900
Итоги конференции INFOSTART EVENT 2013 EVOLUTION

Автор MuI_I_IkaРаздел Блоги

Ответов: 0
Просмотров: 1894
Последний ответ 24 Май 2013, 19:57
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 868
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal