Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 08:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вычисление суммы  (Прочитано 1811 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, подскажите пожалуйста как рассчитать сумму в документе. Формула такая: "Сумма=Тарификация*СрокСтоянки" учитывая, что Тарификация - это перечисления словами, т.е. ещё нужно слово задать как число


Оффлайн nemox

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 4
  • КПД: 31%
  • Регистрация: 2015-04-18
  • Сайт: 
  • Профессия: Программист 1С
Re: Вычисление суммы
« Ответ #1: 10 Май 2015, 20:32 »
Какой тип у реквизита Тарификация? Разные варианты есть.
Во первых создаете обработку события ПриИзменении() Тарификация и СрокСтоянки.
В них прописываете как вариант:

Если Объект.Тарификация = "Один рубль" Тогда
    Объект.Сумма = 1*Объект.СрокСтоянки;
ИначеЕсли Объект.Тарификация = "Два рубля" Тогда
    Объект.Сумма = 2*Объект.СрокСтоянки;
КонецЕсли;
И т.д.

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вычисление суммы
« Ответ #2: 11 Май 2015, 06:23 »
Какой тип у реквизита Тарификация? Разные варианты есть.
Во первых создаете обработку события ПриИзменении() Тарификация и СрокСтоянки.
В них прописываете как вариант:

Если Объект.Тарификация = "Один рубль" Тогда
    Объект.Сумма = 1*Объект.СрокСтоянки;
ИначеЕсли Объект.Тарификация = "Два рубля" Тогда
    Объект.Сумма = 2*Объект.СрокСтоянки;
КонецЕсли;
И т.д.


Тарификация типа (Ссылка из перечисления) имеет час, сутки, неделю, месяц
И вы можете чутка подробнее рассказать, а то я ещё очень новичёк

Оффлайн nemox

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 4
  • КПД: 31%
  • Регистрация: 2015-04-18
  • Сайт: 
  • Профессия: Программист 1С
Re: Вычисление суммы
« Ответ #3: 11 Май 2015, 11:53 »
Выбираете на созданной вами форме в режиме конфигуратор реквизит Тарификация. Появляется справа палитра свойств. В ней в самом низу есть события. Напротив события ПриИзменении() щелкаете на лупу. Создаете процедуру #НаКлиенте, а затем Функцию #НаСервере:
#НаКлиенте
Процедура ТарификацияПриИзменении()
    Объект.СуммаСтоянки = ПолучитьСумму();
КонецПроцедуры

#НаСервере
Функция ПолучитьСумму()
    Если Объект.Тарификация = Перечисления.Тарификации.Час Тогда
        Сумма = Объект.СрокСтоянки*300;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификации.Сутки Тогда   
        Сумма = Объект.СрокСтоянки*1000;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификации.Неделя Тогда
        Сумма = Объект.СрокСтоянки*5000;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификации.МесяцТогда
        Сумма = Объект.СрокСтоянки*10000;
    КонецЕсли;

    Возврат Сумма;
КонецФункции

И по аналогии Создаете процедуру ПриИзменении для СрокСтоянки

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вычисление суммы
« Ответ #4: 12 Май 2015, 07:35 »
Выбираете на созданной вами форме в режиме конфигуратор реквизит Тарификация. Появляется справа палитра свойств. В ней в самом низу есть события. Напротив события ПриИзменении() щелкаете на лупу. Создаете процедуру #НаКлиенте, а затем Функцию #НаСервере:
#НаКлиенте
Процедура ТарификацияПриИзменении()
    Объект.СуммаСтоянки = ПолучитьСумму();
КонецПроцедуры

#НаСервере
Функция ПолучитьСумму()
    Если Объект.Тарификация = Перечисления.Тарификации.Час Тогда
        Сумма = Объект.СрокСтоянки*300;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификации.Сутки Тогда   
        Сумма = Объект.СрокСтоянки*1000;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификации.Неделя Тогда
        Сумма = Объект.СрокСтоянки*5000;
    ИначеЕсли Объект.Тарификация = Перечисления.Тарификации.МесяцТогда
        Сумма = Объект.СрокСтоянки*10000;
    КонецЕсли;

    Возврат Сумма;
КонецФункции

И по аналогии Создаете процедуру ПриИзменении для СрокСтоянки

Простите, может быть я вас сильно нагружаю, но у реквизитов в свойствах Событий я не увидел :(

Оффлайн nemox

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 4
  • КПД: 31%
  • Регистрация: 2015-04-18
  • Сайт: 
  • Профессия: Программист 1С
Re: Вычисление суммы
« Ответ #5: 12 Май 2015, 09:39 »
Свойства смотрите не реквизита, а элемента формы(В редакторе форм). Во вложении пример.

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вычисление суммы
« Ответ #6: 12 Май 2015, 18:49 »
Свойства смотрите не реквизита, а элемента формы(В редакторе форм). Во вложении пример.

Получилась вот такая вот ерунда

Оффлайн Евгений@

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 4
  • КПД: 36%
  • Регистрация: 2015-05-12
  • Сайт: 
Re: Вычисление суммы
« Ответ #7: 12 Май 2015, 19:11 »
Вместо #НаКлиенте #НаСервере нужно использовать &НаКлиенте и &НаСервере

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вычисление суммы
« Ответ #8: 12 Май 2015, 20:28 »
Вместо #НаКлиенте #НаСервере нужно использовать &НаКлиенте и &НаСервере
Спасибо большое.
Добавлено: 12 Май 2015, 20:34

Свойства смотрите не реквизита, а элемента формы(В редакторе форм). Во вложении пример.
И вам огромное спасибо

Оффлайн Евгений@

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 4
  • КПД: 36%
  • Регистрация: 2015-05-12
  • Сайт: 
Re: Вычисление суммы
« Ответ #9: 12 Май 2015, 20:54 »
&НаКлиенте
Процедура ТарификацияПриИзменении()
    ТД = Элементы.ИмяТабличнойЧасти.ТекущиеДанные;
    ТД.СуммаОплаты = ПолучитьСумму(ТД.Тарификация);
КонецПроцедуры

&НаКлиенте
Процедура СрокСтоянкиПриИзменении()
    ТД = Элементы.ИмяТабличнойЧасти.ТекущиеДанные;
    ТД.СуммаОплаты = ПолучитьСумму(ТД.Тарификация);

КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСумму(Тарификация)
    Если Тарификация = Перечисления.Тарификации.Час Тогда
        Сумма = Объект.СрокСтоянки*300;
    ИначеЕсли Тарификация = Перечисления.Тарификации.Сутки Тогда   
        Сумма = Объект.СрокСтоянки*1000;
    ИначеЕсли Тарификация = Перечисления.Тарификации.Неделя Тогда
        Сумма = Объект.СрокСтоянки*5000;
    ИначеЕсли Тарификация = Перечисления.Тарификации.Месяц Тогда
        Сумма = Объект.СрокСтоянки*10000;
    КонецЕсли;

    Возврат Сумма;
КонецФункции
Я думаю должно как то так, только ИмяТабличнойЧасти поменять на нужное.


 

Как правильно ввести услугу "страховка груза" (рассчитывается процентом от указанной суммы)

Автор ElenaAlmazРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2282
Последний ответ 28 Окт 2014, 15:26
от ElenaAlmaz
Обработка "Регистрация счетов-фактур на аванс" не видит суммы зачета авансов.

Автор omahiРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2412
Последний ответ 21 Апр 2015, 21:21
от omahi
Отчет "Ведомость по товарам в рознице" отрицательные суммы

Автор OLGA БуслаеваРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 247
Последний ответ 15 Авг 2017, 12:57
от AIFrame
Задать отображение суммы в отчёте "Анализ счёта" и подобных ему

Автор stardragonРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1930
Последний ответ 05 Апр 2011, 20:49
от stardragon
Минфин напомнил правопреемникам о порядке учета в расходах суммы убытка, полученного присоединенной организацией

Автор newsРаздел Новости

Ответов: 0
Просмотров: 388
Последний ответ 28 Июл 2016, 02:15
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 183
  • Точка Скрытых: 1
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal