Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 18:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Движения ПоступлениеТоваровУслут  (Прочитано 4574 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Игорь_M

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-19
  • Сайт: 
  • Профессия: Ученик 1С
В ОбработкуПроведения  вставил такой код:
Движения.МатериалыПодтвержденные.Записывать = Истина;
Движения.МатериалыПодтвержденные.Очистить();
Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.МатериалыПодтвержденные.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
КонецЦикла;
Движения.Записать();

Движения.МатериалыОприходованные.Записывать = Истина;
Движения.МатериалыОприходованные.Очистить();
Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.МатериалыПодтвержденные.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
КонецЦикла;
Движения.Записать();

ПроверкиСобытий.СтатусыУстановить();

почему не добавляются движения в соответствующие регистры?


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Движения.МатериалыПодтвержденные.Записать()
Движения.МатериалыОприходованные.Записать()
вместо Движения.Записать()
Ссылка на примеры работ https://yadi.sk/d/ksVluPMBkiRzX

Оффлайн SamMan

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 1
  • КПД: 11%
  • Регистрация: 2015-04-20
  • Сайт: 
  • Профессия: Программист 1С
Движения.МатериалыПодтвержденные.Записать()
Движения.МатериалыОприходованные.Записать()
вместо Движения.Записать()

Почему так? Разве Движения.Записать() не обслуживает всю коллекцию Движения? Кроме того, так как написано у ТС много лучше предлагаемого вами в плане борьбы со взаимоблокировками, объяснения/пруфы - тут.

Оффлайн Игорь_M

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Дмитрий, не помогло
вот полный текст процедуры, может там блокировки какие:
Процедура ОбработкаПроведения(Отказ, РежимПроведения)



Перем СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоТаре, ТаблицаПоОборудованию, ТаблицаПоУслугам, ТаблицаПоАгентскимУслугам, ТаблицаПоОбъектамСтроительства;

    Движения.МатериалыПодтвержденные.Записывать = Истина;
Движения.МатериалыПодтвержденные.Очистить();
Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.МатериалыПодтвержденные.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
КонецЦикла;
Движения.МатериалыПодтвержденные.Записать();

Движения.МатериалыОприходованные.Записывать = Истина;
Движения.МатериалыОприходованные.Очистить();
Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.МатериалыПодтвержденные.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
КонецЦикла;
Движения.МатериалыОприходованные.Записать();

ПроверкиСобытий.СтатусыУстановить();

РозницаВПродажныхЦенах = ((НЕ Склад.ВидСклада = Перечисления.ВидыСкладов.Оптовый)
И мУчетВПродажныхЦенах
И (ВидОперации = Перечисления.ВидыОперацийПоступлениеТоваровУслуг.ПокупкаКомиссия)
И (НЕ ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомитентом));


// Заголовок для сообщений об ошибках проведения.
Заголовок = ОбщегоНазначения.ПредставлениеДокументаПриПроведении(Ссылка);
     
// Проверка ручной корректировки
Если ОбщегоНазначения.РучнаяКорректировкаОбработкаПроведения(РучнаяКорректировка,Отказ,Заголовок,ЭтотОбъект) Тогда
Возврат
КонецЕсли;

ПодготовитьСтруктуруШапкиДокумента(Заголовок, СтруктураШапкиДокумента, Отказ);

// Проверим правильность заполнения шапки документа
ПроверитьЗаполнениеШапки(СтруктураШапкиДокумента, Отказ, Заголовок);

ПодготовитьТаблицыДокумента(СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоТаре, ТаблицаПоОборудованию, ТаблицаПоУслугам, ТаблицаПоАгентскимУслугам, ТаблицаПоОбъектамСтроительства);

// Проверить заполнение ТЧ
ПроверитьЗаполнениеТабличнойЧастиТовары(ТаблицаПоТоварам, СтруктураШапкиДокумента, Отказ, Заголовок);
ПроверитьЗаполнениеТабличнойЧастиУслуги(ТаблицаПоУслугам, СтруктураШапкиДокумента, Отказ, Заголовок);
ПроверитьЗаполнениеТабличнойЧастиАгентскиеУслуги(ТаблицаПоАгентскимУслугам, СтруктураШапкиДокумента, Отказ, Заголовок);
ПроверитьЗаполнениеТабличнойЧастиОборудование(ТаблицаПоОборудованию, СтруктураШапкиДокумента, Отказ, Заголовок);
ПроверитьЗаполнениеТабличнойЧастиВозвратнаяТара(ТаблицаПоТаре, СтруктураШапкиДокумента, Отказ, Заголовок);
ПроверитьЗаполнениеТабличнойЧастиОбъектыСтроительства(ТаблицаПоОбъектамСтроительства, СтруктураШапкиДокумента, Отказ, Заголовок);

// Зачет авансов
ТаблицаЗачетаАвансов = ПодготовитьТаблицуЗачетаАвансов(СтруктураШапкиДокумента);
ПроверитьЗаполнениеТабличнойЧастиЗачетАвансов(ТаблицаЗачетаАвансов, СтруктураШапкиДокумента, Отказ, Заголовок);

УправлениеВзаиморасчетами.ПроверкаВозможностиПроведенияВ_БУ_НУ(
СтруктураШапкиДокумента, СтруктураШапкиДокумента.ДоговорКонтрагента, Отказ, Заголовок);

// Движения по документу
ПартионныйУчет = УправлениеЗапасами.ВедетсяПартионныйУчет(
ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитики(КонецМесяца(Дата), Отказ, Организация), "БУ");
мПоддержкаПБУ18 = НалоговыйУчет.ПрименениеПБУ18(Организация, Дата);

Если Не Отказ Тогда
ДвиженияПоРегистрам(
РежимПроведения, СтруктураШапкиДокумента,
ТаблицаПоТоварам, ТаблицаПоТаре, ТаблицаПоУслугам, ТаблицаПоАгентскимУслугам, ТаблицаПоОборудованию, ТаблицаПоОбъектамСтроительства,
ТаблицаЗачетаАвансов,
Отказ, Заголовок);
КонецЕсли;

Если НЕ Отказ Тогда
Движения.Записать();
УчетНДС.ПроверитьСоответствиеРеквизитовСчетаФактуры(ЭтотОбъект, "СчетФактураПолученный");
КонецЕсли;




КонецПроцедуры // ОбработкаПроведения()

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"Движения.Записать()" уместно если вам движения нужны внутри ОбработкиПроведения(),
в противном случае запишется автоматом по окончании ОбработкиПроведения()
(если конечно не Отказ=ИСТИНА и ...Записывать=ИСТИНА)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Игорь_M

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-19
  • Сайт: 
  • Профессия: Ученик 1С
помогите до конца разобраться:
Документ ПоступлениеТоваровУслуг проводится  - в списке документов у него стоит зеленая галочка. Следовательно все движения связанные с этим доком должны записываться? Отладчиком смотрел - Отказ = Ложь, однако движений в нужных мне регистрах не наблюдается. Где я тут туплю?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Движения.МатериалыОприходованные???.Очистить(); Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.МатериалыПодтвержденные???.Добавить();


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Зеленая галочка - это просто показывает что у документа стандартный реквизит Проведен установился в ИСТИНА.
И не более.
Надо проверить настройки самого документа а именно свойство "Запись движений при проведении"...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Поставьте точку останова в конце процедуры и посмотрите есть ли там движения по интересующим нас регистрам.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMBkiRzX

Оффлайн Игорь_M

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Поставьте точку останова в конце процедуры и посмотрите есть ли там движения по интересующим нас регистрам.


не могу прикрепить скрин - https://cloud.mail.ru/public/3MpU1q4mSj6U/11.png - ссылка

Зеленая галочка - это просто показывает что у документа стандартный реквизит Проведен установился в ИСТИНА.
И не более.
Надо проверить настройки самого документа а именно свойство "Запись движений при проведении"...
записывать модифицированные

Движения.МатериалыОприходованные???.Очистить(); Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.МатериалыПодтвержденные???.Добавить();
это конечно, пипец ... но исправил - не помогает(((


[/quote]


Теги:
 

Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1969
Последний ответ 05 Апр 2016, 10:15
от vitasw
Регистр накоплений - себестоимость, не записываются движения документа "Реализация товаров"

Автор ekaterinka87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2838
Последний ответ 20 Июл 2015, 11:10
от ferrari314
К отчету "Движения денежных средств" привязать номенклатуру

Автор ofryРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 4497
Последний ответ 04 Окт 2014, 21:22
от дфтын
Для номенклатуры " " движения сформировались без суммовой оценки по регламентированному учету

Автор fsaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 803
Последний ответ 28 Сен 2016, 21:24
от fsa
Бухгалтерия, ред. 2.0 начальные и конечные сальдо по статьям движения дс в Оборотно сальдовой ведомости

Автор LValoryРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1860
Последний ответ 13 Янв 2016, 15:01
от LValory

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 272
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal