Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Июн 2018, 07:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как перебрать строки в табличной части документа в форме документа  (Прочитано 10400 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Iater

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-12
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет!

Помогите, пожалуйста, разобраться с циклами. Я хочу из формы документа перебрать строки табличной части документа, чтобы заполнить столбец "цены".
Проблема в цикле - ошибку выдаёт то итератор не определен то Переменная не определена

&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
ПроцентСкидки = РасчетСкидки.ПроцентСкидки(Объект.Дата, Объект.Клиент);

Для Каждого ТекСтрокаНоменклатура Из Номенклатура Цикл

    Док.ЦенаСоСкидкой = Док.Цена*(100-ПроцентСкидки)/100;

КонецЦикла;

КонецПроцедуры



Я совсем новичок и в упор не понимаю как перебрать строчки табличной части. Переписал из учебника, но это фигня не работает


Оффлайн pavl_vs

  • *****
  • Сообщений: 1209
  • РЕПУТАЦИЯ: 184
  • КПД: 15%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Iater, как я понимаю, в ТЧ, имя которой "Номенклатура" есть колонка "Цена", тогда цикл запишется так:
Для Каждого ТекСтрокаНоменклатура Из Номенклатура Цикл
    ЦенаСоСкидкой = ТекСтрокаНоменклатура.Цена*(100-ПроцентСкидки)/100;
    Сообщить(ЦенаСоСкидкой);
КонецЦикла;

Не понятно куда нужно записать цену со скидкой я "записал" в сообщение.

Оффлайн Iater

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-12
  • Сайт: 
  • Профессия: Ученик 1С
не работает

{Документ.РасходнаяНакладная.Форма.ФормаДокумента.Форма(19,39)}: Переменная не определена (Номенклатура)
   Для Каждого ТекСтрокаНоменклатура Из <<?>>Номенклатура Цикл (Проверка: Тонкий клиент)


нужно не в сообщение записать а в столбец ЦенаСоСкидкой, но это пока не важно - не работает. Видимо это моло бы работать, если я делал в Обработке проведения т.е. в модуле объекта. А я делаю в модуле формы документа, т.к. хочу чтобы ценаСоСкидкой вписывалась сразу, а не только после нажатия на кнопку "провести"
Добавлено: 06 Май 2015, 23:12

Для Каждого ТекСтрокаНоменклатура Из Номенклатура Цикл

Вообще, кстати, у меня же там нет переменной ТекСтрокаНоменклатура. Догадываюсь это потому, что курсор мой стоит на строке документа Клиент, ну или вообще нигде не стоит.
Добавлено: 07 Май 2015, 20:58

Вот так заработало:

&НаКлиенте // в модуле ФОРМЫ документа
Процедура КлиентПриИзменении(Элемент)

    ПроцентСкидки = РасчетСкидки.ПроцентСкидки(Объект.Дата, Объект.Клиент);

    ТекСтрокаНоменклатура = Элементы.Номенклатура.ТекущиеДанные; // забрали строки из табличной части в переменную "ТекСтрокаНоменклатура"

    Для Каждого ТекСтрокаНоменклатура Из Объект.Номенклатура Цикл // работает из-за "Объект." если убрать, то выдает ошибку как в первом посте

ТекСтрокаНоменклатура.ЦенаСоСкидкой = ТекСтрокаНоменклатура.Цена*(100-ПроцентСкидки)/100; // записываем в поле значение выражения

    КонецЦикла;

КонецПроцедуры

Последний раз редактировалось: Iater; 07 Май 2015, 20:58. Причина: Объединение сообщений


 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2192
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2585
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3193
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Модуль к форме "Настройка заполнения"

Автор oyufedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4889
Последний ответ 17 Янв 2014, 16:35
от oyufed
Отображение HTML-макета в форме с HTML-полем.

Автор spikee666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4033
Последний ответ 21 Авг 2014, 17:51
от spikee666

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
125 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
116 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
40 Сообщений
alex0402
28 Сообщений
buketov.av buketov.av
24 Сообщений
magnifico61
21 Сообщений
wise wise
16 Сообщений
ilyay ilyay
15 Сообщений
mixei
14 Сообщений

* Кто онлайн

  • Точка Гостей: 310
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal