Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Строка найти с условием  (Прочитано 614 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RomanCasper

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-23
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте.

Возможно ли найти строку в таблице значений соблюдая условие?

Метод .Найти(); находит первую попавшуеся, но мне так не нужно.

Мне нужно так:
Найти Где Колонка1 = 10 И Колонка2 = 12
Возвращать ссылку на строку в ТЗ.



Оффлайн RomanCasper

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-23
  • Сайт: 
  • Профессия: Программист 1С
Знаю можно реализовать как-то так:
Для каждого строка из ТЗ Цикл
    Если строка.колонка1 = 10 Тогда
        Если строка.колонка2 = 12 Тогда
            НайденнаяСтрока = Строка.Ссылка;
            Прервать;
        КонецЕсли;
    КонецЕсли;
КонецЦикла;

Но можно как то проще обойтись?
p.s. если найдете ошибку в коде, это не важно, важен алгоритм :D
Добавлено: 04 Май 2015, 13:18

Хотя я так подумал. и этот метод не плохой, в функцию запихну и будет красота)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
СтруктураПоиска = Новый Структура("Колонка1, Колонка2", 10, 12);
НайденныеСтроки = ТЗ.НайтиСтроки(СтруктураПоиска);
Если НайденныеСтроки.Количество() > 0 Тогда
....
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн RomanCasper

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-23
  • Сайт: 
  • Профессия: Программист 1С
cska-fanat-kz, спасибо!


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 315
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal