Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отчет по реализации продукции  (Прочитано 5156 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ШЛК

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-07
  • Сайт: 
Делаю отчет по реализации продукции за период.
 
При выводе на печать строк Суммы  все печатаются в первой колонке, а надо  как в 111.jpg


Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
а кодддддд???

Оффлайн ШЛК

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-07
  • Сайт: 
НПП = 0;
   Для J=1 по СписокТоваров.РазмерСписка()Цикл   
          Товар = ТЗТовар.ПолучитьЗначение(J,"Товар");
          НПП = НПП + 1;
        Таб.ВывестиСекцию("Товар|Начало");   
         Для K=1 по ТЗСчет.КоличествоСтрок() Цикл
            Счет=ТЗСчет.ПолучитьЗначение(K,"ДтСчет");
              
            ТЗ.ВыбратьСтроки();
            Пока ТЗ.ПолучитьСтроку()=1 Цикл
               Если ТЗ.Товар = Товар  Тогда   
                  Если ТЗ.КорСчет = Счет  Тогда   
                      Контрагент = ТЗ.Контрагент   ;
                      Основание = ТЗ.Основание;
                      Количество = ТЗ.Количество;
                      Сумма = ТЗ.Сумма;   
                      Таб.ВывестиСекцию("Строка|Начало");
                     Таб.ПрисоединитьСекцию("Строка|ДтСч");
                   КонецЕсли;
               КонецЕсли;
            КонецЦикла;    
         КонецЦикла;   
     КонецЦикла;

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Товар|Начало - все верно.проблема в секциях.
Читайте:
ВывестиСекцию
ПрисоединитьСекцию

Оффлайн ШЛК

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-07
  • Сайт: 
Мне кажется не хватает цикла для того, чтобы ПрисоединитьСекцию вывести за пределы этого цикла.

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Прикрепляй файл как получается,и как нада.

Оффлайн ШЛК

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-07
  • Сайт: 
Все получилось. Код такой кому будет интересно. Спасибо всем


   Для J=1 по СписокТоваров.РазмерСписка()Цикл   
       Товар = ТЗТовар.ПолучитьЗначение(J,"Товар");
       Таб.ВывестиСекцию("Товар|Начало");
      
       ТЗ.ВыбратьСтроки();
       Пока ТЗ.ПолучитьСтроку()=1 Цикл
           Если ТЗ.Товар = Товар  Тогда
               Контрагент = ТЗ.Контрагент    ;
               Основание = ТЗ.Основание;
               Количество = ТЗ.Количество;
               КорСчет = ТЗ.КорСчет;
            СуммаСч = ТЗ.Сумма;
               Таб.ВывестиСекцию("Строка|Начало");
           
               Для K=1 по ТЗСчет.КоличествоСтрок() Цикл
               Счет=ТЗСчет.ПолучитьЗначение(K,"ДтСчет");
                   Сумма = ?(КорСчет = Счет, СуммаСч, 0);
                   Таб.ПрисоединитьСекцию("Строка|ДтСч");
            КонецЦикла;
         КонецЕсли;
         
      КонецЦикла;   
   КонецЦикла;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 261
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal