Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2018, 10:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавляется пустая строка в отчете  (Прочитано 1127 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rudzeeff

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-03
  • Сайт: 
  • Профессия: Ученик 1С
Процедура КнопкаСформироватьНажатие(Кнопка)
   Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
                 |   ТоварыОрганизацийОстатки.КоличествоОстаток КАК КоличествоОстаток,
                 |   ЦеныНоменклатурыСрезПоследнихЗакупочные.Цена КАК Закупочная,
                 |   ЦеныНоменклатурыСрезПоследнихРозничные.Цена КАК Розничная,
                 |   ТоварыОрганизацийОстатки.Номенклатура КАК Номенклатура,
                 |   ТоварыОрганизацийОстатки.Организация КАК Организация
                 |ИЗ
                 |   РегистрНакопления.ТоварыОрганизаций.Остатки(
                 |         &КонДата,
                 |         Организация = &Организация
                 |            И Номенклатура В ИЕРАРХИИ (&Номенклатура)) КАК ТоварыОрганизацийОстатки
                 |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&КонДата, ) КАК ЦеныНоменклатурыСрезПоследнихЗакупочные
                 |      ПО (ЦеныНоменклатурыСрезПоследнихЗакупочные.ТипЦен = &Закупочные)
                 |         И ТоварыОрганизацийОстатки.Номенклатура = ЦеныНоменклатурыСрезПоследнихЗакупочные.Номенклатура
                 |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&КонДата, ) КАК ЦеныНоменклатурыСрезПоследнихРозничные
                 |      ПО (ЦеныНоменклатурыСрезПоследнихРозничные.ТипЦен = &Розничные)
                 |         И ТоварыОрганизацийОстатки.Номенклатура =                        ЦеныНоменклатурыСрезПоследнихРозничные.Номенклатура
                 |
                 |СГРУППИРОВАТЬ ПО
                 |   ТоварыОрганизацийОстатки.Номенклатура,
                 |   ТоварыОрганизацийОстатки.Организация,
                 |   ТоварыОрганизацийОстатки.КоличествоОстаток,
                 |   ЦеныНоменклатурыСрезПоследнихЗакупочные.Цена,
                 |   ЦеныНоменклатурыСрезПоследнихРозничные.Цена
                 |ИТОГИ ПО
                 |   ОБЩИЕ";
             
      Запрос.УстановитьПараметр("КонДата",КонецДня(КонДата));       
      Запрос.УстановитьПараметр("Номенклатура",Номенклатура);
      Запрос.УстановитьПараметр("Организация",Организация);
      Запрос.УстановитьПараметр("Закупочные",Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Закупочные"));
      Запрос.УстановитьПараметр("Розничные",Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Розничные"));
   
      тз=Запрос.Выполнить().Выгрузить();
     Т=Новый ТабличныйДокумент;
   Макет=ПолучитьМакет("Макет");
   ОблШапка=Макет.ПолучитьОбласть("Шапка");
   ОблСтрока=Макет.ПолучитьОбласть("Строка");
   Т.Вывести(ОблШапка);
   тз=Запрос.Выполнить().Выгрузить();
   пп=0;
   
   Для каждого стр из тз Цикл
      ОблСтрока.Параметры.Заполнить(стр);
      пп=пп+1;
      ОблСтрока.Параметры.пп=пп;
      Т.Вывести(ОблСтрока);
                  
   КонецЦикла;           
   
   Т.АвтоМасштаб=Истина;
   Т.ОтображатьЗаголовки=Ложь;
   Т.ОтображатьСетку=Ложь;
   Т.Показать();



№   Номенклатура   Остатки   Закупочная   Розничная   СуммаЗакупочная   СуммаРозничная
1                  
2   Вино МОНАСТЫРСКАЯ ТРАПЕЗА МЗВВ кр п/сл 10-12% 2л   2   221,84   369      



Первая строка пустая, как исправить подскажите) Спасибо за внимание.


Оффлайн RomanCasper

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-23
  • Сайт: 
  • Профессия: Программист 1С
Я сильно не вникал, но заметил что у вас дважды вызывается
 тз=Запрос.Выполнить().Выгрузить();

Попробуйте 1 раз, может поможет)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
RomanCasper, не поможет :P

rudzeeff, у вас запрос с итогами, т.е. в исходной таблице первая строка - строка общих итогов.
обойдите результат запроса двойным циклом. примерно так:
ВыборкаИтоги = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаИтоги.Следующий() Цикл
    ВыборкаДетальные = ВыборкаИтоги.Выбрать();
    Пока ВыборкаДетальные.Следующий() Цикл
        ОблСтрока.Параметры.Заполнить(ВыборкаДетальные);
        ...
    КонецЦикла;
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 398
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1181
Последний ответ 13 Мар 2016, 00:55
от дфтын
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 514
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7627
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
в отчете показывает остатки в файловой базе, в sql не показывает

Автор StanforevaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1202
Последний ответ 12 Апр 2016, 12:18
от Stanforeva

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
105 Сообщений
alex0402
28 Сообщений
kiksi
17 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
pavl_vs
13 Сообщений
LexaK
13 Сообщений
BuhRust
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 1021
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal