Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 14:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание на основании  (Прочитано 2126 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Как при помощи создать на Основании создать сразу несколько документов по определенному признаку


Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
с помощью обработки.

в обработке пишете запрос по которому получаете несколько нужных документов,
а потом в цикле создаете нужный новый документ-объект и
вызываете у него метод Заполнить(СсылкаНаДокументИзЗапроса)
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
с помощью обработки.

в обработке пишете запрос по которому получаете несколько нужных документов,
а потом в цикле создаете нужный новый документ-объект и
вызываете у него метод Заполнить(СсылкаНаДокументИзЗапроса)
т.е. это получается создать команду и по кнопке ее вызывать?

Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Как при помощи создать на Основании создать сразу несколько документов по определенному признаку
не совсем понятна постановка вопроса, что значит
создать сразу несколько документов по определенному признаку
что за признак? приведите пример из каких документов, какие вы хотите создать?
в 1С
и одного документа можно создать несколько документов разных тиипов
и из документов разного типа можно создать несколько документов одного типа,
у вас какая задача?

По кнопке меню Создать на основании, за одно нажатие создается один документ,
если вам надо за одно нажатие создавать несколько документов, нужно программировать.
Для начало надо четко представлять какие документы на основании каких вы хотите создавать.

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Как при помощи создать на Основании создать сразу несколько документов по определенному признаку
не совсем понятна постановка вопроса, что значит
создать сразу несколько документов по определенному признаку
что за признак? приведите пример из каких документов, какие вы хотите создать?
в 1С
и одного документа можно создать несколько документов разных тиипов
и из документов разного типа можно создать несколько документов одного типа,
у вас какая задача?

По кнопке меню Создать на основании, за одно нажатие создается один документ,
если вам надо за одно нажатие создавать несколько документов, нужно программировать.
Для начало надо четко представлять какие документы на основании каких вы хотите создавать.
Есть Документ "А", в ТЧ которго есть "Номенклатура" и "Поставщик". На основании доку "А" создается "ЗаказПоставщику". Нужно, чтобы создалось столько документов "ЗаказПоставщику", сколько "Поставщиков(Сгруппированных)" в ТЧ дока "А"

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В качестве идеи
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказПоставщикуТовары.Заказ.Контрагент КАК Контрагент,
| ЗаказПоставщикуТовары.Номенклатура КАК Номенклатура,
| ЗаказПоставщикуТовары.Количество КАК Количество,
| ЗаказПоставщикуТовары.Сумма КАК Сумма
|ИЗ
| Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
|ИТОГИ
| СУММА(Количество),
| СУММА(Сумма)
|ПО
| Контрагент,
| Номенклатура";

Результат = Запрос.Выполнить();

ВыборкаЗаказКонтрагент = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаЗаказКонтрагент.Следующий() Цикл
СтрДокумент=Новый Структура;
СтрДокумент.Вставить("Контрагент",ВыборкаЗаказКонтрагент.Контрагент);
        Счетчик=1;
СтрТабЧасть=Новый Структура;
ВыборкаНоменклатура = ВыборкаЗаказКонтрагент.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаНоменклатура.Следующий() Цикл
СтрТабЧасть.Вставить("Строка"+Строка(Счетчик),Новый Структура("Номенклатура,Количество,Сумма",ВыборкаНоменклатура.Номенклатура,ВыборкаНоменклатура.Количество,ВыборкаНоменклатура.Сумма));
Счетчик=Счетчик+1;
КонецЦикла;
СтрДокумент.Вставить("Товары",СтрТабЧасть);

ДокОб=Документы.ЗаказПокупателя.СоздатьДокумент();
ДокОб.Заполнить(СтрДокумент);
КонецЦикла;

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
В качестве идеи
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказПоставщикуТовары.Заказ.Контрагент КАК Контрагент,
| ЗаказПоставщикуТовары.Номенклатура КАК Номенклатура,
| ЗаказПоставщикуТовары.Количество КАК Количество,
| ЗаказПоставщикуТовары.Сумма КАК Сумма
|ИЗ
| Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
|ИТОГИ
| СУММА(Количество),
| СУММА(Сумма)
|ПО
| Контрагент,
| Номенклатура";

Результат = Запрос.Выполнить();

ВыборкаЗаказКонтрагент = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаЗаказКонтрагент.Следующий() Цикл
СтрДокумент=Новый Структура;
СтрДокумент.Вставить("Контрагент",ВыборкаЗаказКонтрагент.Контрагент);
        Счетчик=1;
СтрТабЧасть=Новый Структура;
ВыборкаНоменклатура = ВыборкаЗаказКонтрагент.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаНоменклатура.Следующий() Цикл
СтрТабЧасть.Вставить("Строка"+Строка(Счетчик),Новый Структура("Номенклатура,Количество,Сумма",ВыборкаНоменклатура.Номенклатура,ВыборкаНоменклатура.Количество,ВыборкаНоменклатура.Сумма));
Счетчик=Счетчик+1;
КонецЦикла;
СтрДокумент.Вставить("Товары",СтрТабЧасть);

ДокОб=Документы.ЗаказПокупателя.СоздатьДокумент();
ДокОб.Заполнить(СтрДокумент);
КонецЦикла;
Спасибо большое.
В общем создал команду и сделал что хотел.
Вопрос теперь отсюда: при нестандартном методе ввода на основании, "включить" структуру подчиненности?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Это почему вдруг стало нестандартным? смотрите критерии отбора и в документах правильно заполняйте реквизиты документов-оснований.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Это почему вдруг стало нестандартным? смотрите критерии отбора и в документах правильно заполняйте реквизиты документов-оснований.
Не верно мыслил я..да Вы правы в критериях отбора добавил и всё норм..


Теги:
 

Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4974
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4241
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1384
Последний ответ 26 Сен 2016, 16:25
от NataVl
Создание расчета "курсовой разницы" 1С 8.3 УТ

Автор HabiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2102
Последний ответ 18 Фев 2017, 17:47
от Геннадий ОбьГЭС
Создание конфигурации "Электронный ценник"

Автор Серега МошенскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 520
Последний ответ 14 Май 2017, 20:40
от Artjomrgv

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
42 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
31 Сообщений

* Кто онлайн

  • Точка Гостей: 704
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal