Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 11:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расшифровка 1С СКД  (Прочитано 1632 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nata92

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-20
  • Сайт: 
  • Профессия: Ученик 1С
Читала множество форумов, например вот тема на этом же форуме http://forum-1c.ru/index.php?topic=30896.0  ничего не помогает.
Вот есть отчет сформированный в СКД. Нужно сделать расшифровку по полю "Заявитель, задача, выполненная работа" - тип строка, это поле формируется из данных документа. Если нажать "расшифровать" то открывается окном с выбором поля, я выбираю Регистратор и уже открывает отчет расшифровка с нужной ссылкой на документ и можно потом открыть сам документ. Как можно промежуточные шаги миновать. Просмотрела видео 110 уроков по СКД, немного кода написала по уроком,но требуется все таки при двойном нажатии мышкой по полю с текстом открыть определенный документ. Боюсь что вы скажите что не получиться сделать как мне нужно.Помогите, пожалуйста.

Код:


&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)

   Перем ВыполненноеДействие;
   
   СтандартнаяОбработка = Ложь;
   
   Если ТипЗнч(Расшифровка) <> Тип("ИдентификаторРасшифровкиКомпоновкиДанных") Тогда
      Возврат;
   КонецЕсли;
   Элемент =  ПолучитьКоллекцию(Расшифровка);
   Если ЗначениеЗаполнено(Элемент) Тогда
      ОткрытьЗначение(Элемент);
   КонецЕсли;
   
КонецПроцедуры



&НаСервере
Функция ПолучитьКоллекцию(Расшифровка)
   
   ДанныеРасшифровкиОтчета = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
   ЭлементРасшифровки = ДанныеРасшифровкиОтчета.Элементы[Расшифровка];
   
   
   Если ТипЗнч(ЭлементРасшифровки) = Тип("ЭлементРасшифровкиКомпоновкиДанныхПоля") Тогда
      Для Каждого ЗначениеПоляРасшифровки Из ЭлементРасшифровки.ПолучитьПоля() Цикл
         Значение = ЗначениеПоляРасшифровки.Значение;
         Если Документы.ТипВсеСсылки().СодержитТип(ТипЗнч(Значение)) Тогда
            Возврат Значение;
         КонецЕсли;
      КонецЦикла;
   КонецЕсли;
   
   Возврат Неопределено;
   
   
КонецФункции


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
"Заявитель, задача, выполненная работа"  - имеет всегда только один регистратор?, если да - то сделайте свой макет и туда в качестве расшифровки запихните регистратор.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
а если изначально поле будет "Регистратор", а выражение представления сформировать ему как "Заявитель + задача + выполненная работа"?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн nata92

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-20
  • Сайт: 
  • Профессия: Ученик 1С
"Заявитель, задача, выполненная работа"  - имеет всегда только один регистратор?, если да - то сделайте свой макет и туда в качестве расшифровки запихните регистратор.


Да, регистратор один всегда, попробую сделать
Добавлено: 27 Апр 2015, 09:51

а если изначально поле будет "Регистратор", а выражение представления сформировать ему как "Заявитель + задача + выполненная работа"?

А вот на счет этого не думала, что можно так попробовать сделать. Вообще поле Заявитель, задача, выполненная работа формируется в вычисляемых полях:

 Выбор
   Когда Заявка = Значение(Документ.Заявка.ПустаяСсылка) Тогда 
         ""
   Иначе
      Выбор
         Когда Заявка.КонтактноеЛицо = Значение(Справочник.КонтактныеЛица.ПустаяСсылка) Тогда
            Заявка.ПостановкаЗадачи + "
"
+"--------------------------------------------------------------------------------------------------------------------------------------
"
      Иначе
         Заявка.КонтактноеЛицо.Наименование +  ". " +" " + Заявка.ПостановкаЗадачи +" "
+"--------------------------------------------------------------------------------------------------------------------------------------
"
   Конец
Конец
+ Регистратор.ОписаниеПроделаннойРаботы


Теги:
 

Отчет - расшифровка по статье затрат "услуги автотранспорта"

Автор marismurРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2888
Последний ответ 22 Авг 2014, 14:36
от morph1991
Расшифровка в отчете на СКД, который вызывается из формы справочника(управляемые формы)

Автор anna_vsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 6142
Последний ответ 09 Дек 2015, 14:39
от vitasw
ОСВ по 20 счету (отсутствует расшифровка статей затрат на конец месяца )

Автор ирина56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4320
Последний ответ 02 Апр 2013, 17:23
от MuI_I_Ika
Расшифровка по Регистратору на СКД не получается оформить макет

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 576
Последний ответ 29 Сен 2016, 15:19
от ZSS
расшифровка ячейки счет-фактуры

Автор ruslan_k-1Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 3488
Последний ответ 17 Окт 2010, 23:15
от progmikon

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 875
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal