Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Сен 2020, 21:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сортировка товара  (Прочитано 6608 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн СерьезныйЧеловек

  • ***
  • Сообщений: 165
  • РЕПУТАЦИЯ: 12
  • КПД: 7%
  • Регистрация: 2010-08-13
  • Сайт: 
Добрый день!
Делаю сортировку товаров по артикулу.
  Процедура КнопкаВыполнитьНажатие(Кнопка)
    
   Запрос=Новый Запрос;
   Запрос.Текст=
   "ВЫБРАТЬ
   |   РеализацияТоваровУслуг.Ссылка
   |ИЗ
   |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг";
   
   Выборка=Запрос.Выполнить().Выгрузить();
   
   Для каждого Строка из Выборка Цикл
      Документ=Строка.Ссылка.ПолучитьОбъект();   
      ТабЧасть=Документ.Товары.Выгрузить();
      ТабЧасть.Сортировать("Артикул УБЫВ");
      Документ.Товары.Загрузить(ТабЧасть);
      Документ.Записать();
   КонецЦикла;
   
      

КонецПроцедуры

Ошибка: неправильное имя колонки. Хотя по любой другой колонке сортирует(цена, номенклатура....). Когда отлаживал в ТЗ колонки артикул не было, хотя видимость колонки включил. Где проблема?


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
А в таб.части Товары разве есть колонка Артикул? Сортировать можно только по существующей колонке в ТЗ. Если хотите сортировать по артикулу, то придется делать так:

Для каждого Строка из Выборка Цикл
      Документ=Строка.Ссылка.ПолучитьОбъект();   
      ТабЧасть=Документ.Товары.Выгрузить();
      ТабЧасть.Колонки.Добавить("Артикул");
     
      Для каждого Стр из ТабЧасть цикл
            Стр.Артикул=Строка.Номенклатура.Артикул;
      КонецЦикла;
     
      ТабЧасть.Сортировать("Артикул УБЫВ");
      Документ.Товары.Загрузить(ТабЧасть);
      Документ.Записать();
   КонецЦикла;

И по мелочи: лучше использовать конструкцию
Выборка=Запрос.Выполнить.Выбрать() ;
Пока Выборка.Следующий() цикл
...
КонецЦикла;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн СерьезныйЧеловек

  • ***
  • Сообщений: 165
  • РЕПУТАЦИЯ: 12
  • КПД: 7%
  • Регистрация: 2010-08-13
  • Сайт: 
таким обходом быстрее работает?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Если речь про цикл
Пока Выборка.Следующий() - то быстрее. Потому как в твоем случае, ты в начале выгружаешь результат запроса в таблицу значений (Выгрузить()), а потом все-равно обходишь каждый элемент подряд, а в моем варианте - мы сразу обходим результат запроса, никуда его не выгружая
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн СерьезныйЧеловек

  • ***
  • Сообщений: 165
  • РЕПУТАЦИЯ: 12
  • КПД: 7%
  • Регистрация: 2010-08-13
  • Сайт: 
Тут очептка не большая
Для каждого Стр из ТабЧасть цикл
            Стр.Артикул=Строка.Номенклатура.Артикул;(Надо Строка исправить на Стр)
      КонецЦикла;

Оффлайн СерьезныйЧеловек

  • ***
  • Сообщений: 165
  • РЕПУТАЦИЯ: 12
  • КПД: 7%
  • Регистрация: 2010-08-13
  • Сайт: 
Спасибо большое :zebzdr: :zebzdr: :zebzdr:

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
хех, а это, так сказать, проверка на вшивость ;) (как говаривали у нас преподы, когда делали ошибки на доске)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

при загрузке цен в 1с предприятие управление торговлей 11.1 возникают дубли товаров разной цены, т.e. новый товар при загрузке не суммируется с уже загруженным. как можно объединять при загрузке товары с последней загруженной ценой товара? Есть ли такая о

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1313
Последний ответ 01 Авг 2019, 12:43
от Геннадий ОбьГЭС
УТ 10.3 Цена единицы товара в партии и цена списания этой единицы при реализации не совпадают????????????????????????

Автор i_antonРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6869
Последний ответ 31 Янв 2014, 12:22
от i_anton
Отгрузка товара по 0,5 кг. - 1С 8.3 "УНФ 1.6"

Автор mamapapaРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 571
Последний ответ 01 Окт 2019, 17:40
от BuhRust
Не списано 0,0004 кг товара "XXXXX", счет учета 1310, склад Склад материалов

Автор RamirasРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6530
Последний ответ 30 Июл 2015, 09:21
от Макси
1C БП 1.6. Отражение возврата товара не День-В-День, по Б/Н оплате.

Автор LexiusРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4242
Последний ответ 21 Янв 2011, 16:57
от Lexius

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
77 Сообщений
IL2016
30 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
oooo800
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
alexandr_ll
14 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 243
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal