Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку запустить обработку.  (Прочитано 1261 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн commiethebeastie

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-14
  • Сайт: 
Скачал из интернетов обработку для экспорта в CSV. Изменил запрос в ней. Конфигуратор ошибок не показывает.

Если запускать через 1С:предприятие рарус, то получаю пустое окошко. Конструктор запросов ругается на функцию. Как вообще определить ошибку? В си например я использую valgrind + символы. Разрешение записи в C:\Обмен есть.

// Выполним запрос к справочнику Номенклатуры
// Получим Таблицу Значений
Функция ПолучитьНоменклатуру()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ //ПЕРВЫЕ 1000
| мфоДоговорыКонтрагентов.ДатаНачалаДействия,
| мфоДоговорыКонтрагентов.ДатаОкончанияДействия,
|   мфоДоговорыКонтрагентов.Дата,
| мфоДоговорыКонтрагентов.Контрагент,
|ИЗ
| Справочник.мфоДоговорыКонтрагентов КАК мфоДоговорыКонтрагентов";
Результат = Запрос.Выполнить();
ТаблицаЗначений = Результат.Выгрузить();
возврат ТаблицаЗначений;
КонецФункции //

// Создаем строку загоовков для CSV-файла
Функция СоздатьЗаголовкиCSV(ТаблицаЗначений,разделитель)
//разделитель = "|";
колонкиТЗ=ТаблицаЗначений.колонки;
Для каждого колонка Из колонкиТЗ Цикл
стрКолонки = "" + стрКолонки + колонка.Имя + разделитель ;
КонецЦикла;
Возврат стрКолонки;
КонецФункции

// Создаем текст CSV:
// текст заголовков и
// текст данных
Функция СоздатьДанныеCSV(ТаблицаЗначений,разделитель)

текст="";
для каждого запись из ТаблицаЗначений Цикл
если текст="" тогда
текст=СоздатьЗаголовкиCSV(ТаблицаЗначений,разделитель)
+ Символы.ПС;
КонецЕсли;

сообщить(запись.Наименование);
текст = текст + запись.Ссылка
+ разделитель + запись.Код
+ разделитель + запись.Родитель
+ разделитель + запись.Наименование
+ Символы.ПС;
КонецЦикла;

    //сообщить(текст);
Возврат текст;

КонецФункции //

// Запишем данные в файл
Функция ЗаписатьCSV(текст,имяФайла)         
кодировка = КодировкаТекста.ANSI;

    ТекстовыйФайлЗапись = Новый ЗаписьТекста(имяФайла,Кодировка);
ТекстовыйФайлЗапись.ЗаписатьСтроку(текст);
ТекстовыйФайлЗапись.Закрыть();
Возврат 0;

КонецФункции //

// Основная логика:
Функция ВыгрузитьВCSV(имяФайлаCSV);
    разделитель = "|";
ТаблицаЗначений = ПолучитьНоменклатуру();
текст = СоздатьДанныеCSV(ТаблицаЗначений,разделитель);
ЗаписатьCSV(текст,имяФайлаCSV);

КонецФункции

ВыгрузитьВCSV("C:\Обмен\my.csv");
 


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. а вы чего код на встроенном языке запихнули в КОНСОЛЬ ЗАПРОСОВ?? однако!
2. в СИ нет точек останова? открыли обработку в конфигураторе, наставили точки, запустили режим "Предприятие" из этого же конфигуратора и отлаживайте себе на здоровье
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн commiethebeastie

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-14
  • Сайт: 
В си точки остановки через дебаггер по символам ставятся, скомпиленный же код.

А то что пустое окошко открывается это реакция на неправильный код?
Добавлено: 14 Апр 2015, 15:57

Я меня глупый вопрос. А как main определяется?

Последний раз редактировалось: commiethebeastie; 14 Апр 2015, 15:57. Причина: Объединение сообщений

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
В обработке есть просто модуль обработки. Дополнительно его не нужно объявлять.
Он по умолчанию присутствует в контексте.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Я меня глупый вопрос. А как main определяется?
main определяется под текстом всех функций и процедур

в твоем случае
ВыгрузитьВCSV("C:\Обмен\my.csv");


Добавлено: 15 Апр 2015, 03:36

commiethebeastie, ты хоть бы текст ошибки привел, а то так сложно сориентироваться где ты чего ломаешь...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
commiethebeastie, тут по ходу нужен принцип "забудьте все что вы знали до этого" )))
возьмите книжки по 1С для начинающих и вперед изучать.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги: Рарус 
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4304
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5563
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5902
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4390
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1987
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 220
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal