Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 10:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: НайтиСтроки()  (Прочитано 4270 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Используя метод НайтиСтроки().. как узнать какая строка не была найдена??


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НайтиСтроки()
« Ответ #1: 14 Апр 2015, 11:52 »
НайденныеСтроки = ТЗ.НайтиСтроки(...);
НЕНайденныеСтроки = Новый Массив;
Для Каждого СтрокаТЧ Из ТЗ Цикл
    НайденоВМассивеСтрок = НайденныеСтроки.Найти(СтрокаТЧ);
    Если НайденоВМассивеСтрок = Неопределено Тогда
        НЕНайденныеСтроки.Добавить(СтрокаТЧ);
    КонецЕсли;
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: НайтиСтроки()
« Ответ #2: 14 Апр 2015, 12:17 »

интересная постановка задачки, получить/показать то что не выбралось :xfbnsdfb:

еще вариант,

НайденныеСтроки = ТЗ.НайтиСтроки(...);
лкТЗКопия = ТЗ.Скопировать();
Для каждого лкСтр Из НайденныеСтроки Цикл
лкТЗКопия.Удалить(лкСтр);
КонецЦикла;
//просмотр чего не было выбрано
лкТЗКопия.ВыбратьСтроку();
Добавлено: 14 Апр 2015, 12:20

кто знает, почему формат в кодах сбивается? перенос строк заменяется на <вк> ?
Добавлено: 14 Апр 2015, 12:21


интересная постановка задачки, получить/показать то что не выбралось :xfbnsdfb:

еще вариант,

НайденныеСтроки = ТЗ.НайтиСтроки(...);
лкТЗКопия = ТЗ.Скопировать();
Для каждого лкСтр Из НайденныеСтроки Цикл
лкТЗКопия.Удалить(лкСтр);
КонецЦикла;
//просмотр чего не было выбрано
лкТЗКопия.ВыбратьСтроку();
Добавлено: 14 Апр 2015, 12:20

кто знает, почему формат в кодах сбивается? перенос строк заменяется на <вк> ?
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Re: НайтиСтроки()
« Ответ #3: 14 Апр 2015, 13:52 »
НайденныеСтроки = ТЗ.НайтиСтроки(...);
НЕНайденныеСтроки = Новый Массив;
Для Каждого СтрокаТЧ Из ТЗ Цикл
    НайденоВМассивеСтрок = НайденныеСтроки.Найти(СтрокаТЧ);
    Если НайденоВМассивеСтрок = Неопределено Тогда
        НЕНайденныеСтроки.Добавить(СтрокаТЧ);
    КонецЕсли;
КонецЦикла;
"Неопределенно"  относится ко всему Массиву или к каждой строке??


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НайтиСтроки()
« Ответ #4: 14 Апр 2015, 13:56 »
"Неопределенно"  относится ко всему Массиву или к каждой строке??

не понял... :dfbbdrfb:
"Неопределено" возвращает метод Найти() массива если не нашел...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Re: НайтиСтроки()
« Ответ #5: 14 Апр 2015, 14:11 »
"Неопределенно"  относится ко всему Массиву или к каждой строке??

не понял... :dfbbdrfb:
"Неопределено" возвращает метод Найти() массива если не нашел...

К примеру "НайденныеСтроки" возвращает массив из 3 строк.... а в ТЗ 4 строки....и  "НайденоВМассивеСтрок" находит и возвращает тоже 3 строки, соответственно "НайденоВМассивеСтрок" НЕ неопределенно.. я правильно понял?

Последний раз редактировалось: cska-fanat-kz; 14 Апр 2015, 14:24

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НайтиСтроки()
« Ответ #6: 14 Апр 2015, 14:24 »
Вообще то в Найти() отправляются строки исходной ТЗ одна за одной (обратите внимание на цикл "Для каждого..." и "Найти(СтрокаТЧ)")...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Re: НайтиСтроки()
« Ответ #7: 14 Апр 2015, 14:32 »
Вообще то в Найти() отправляются строки исходной ТЗ одна за одной (обратите внимание на цикл "Для каждого..." и "Найти(СтрокаТЧ)")...
да я то обратил внимание... только я не пойму из Вашего примера, как я выявлю не найденную строчку...

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НайтиСтроки()
« Ответ #8: 14 Апр 2015, 15:02 »
НайтиСтроки() возвращает массив НАЙДЕННЫХ строк
соответственно НЕНАЙДЕННАЯ строка при поиске по этому массиву даст Неопределено!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НайтиСтроки()
« Ответ #9: 14 Апр 2015, 15:05 »
Ну рассмотрите вариант LexaK - тот же результат, только с другой стороны ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
51 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 248
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal