Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 21:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка в Excel не работает  (Прочитано 3181 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Помогите люди добрые! Есть модуль который выгружает некоторые данные в Эксель, он работает на всех компьютерах-клиентах кроме моего( При запуске он зависает и висит до бесконечности, а на других компах сразу открывается Эксель и все данные выгружаются! В чем может быть проблема, может что то с Экселем?


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Возможно Эксель открывает при старте модальное окошко, которое вы не видите.

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
Помогите люди добрые! Есть модуль который выгружает некоторые данные в Эксель, он работает на всех компьютерах-клиентах кроме моего( При запуске он зависает и висит до бесконечности, а на других компах сразу открывается Эксель и все данные выгружаются! В чем может быть проблема, может что то с Экселем?
дело может быть и в версии. EXEL имеет кучу разновидностей. Попробуйте переустановить и именно такой, как на клиентах

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Помогите люди добрые! Есть модуль который выгружает некоторые данные в Эксель, он работает на всех компьютерах-клиентах кроме моего( При запуске он зависает и висит до бесконечности, а на других компах сразу открывается Эксель и все данные выгружаются! В чем может быть проблема, может что то с Экселем?
дело может быть и в версии. EXEL имеет кучу разновидностей. Попробуйте переустановить и именно такой, как на клиентах

да вроде нет, версии одинаковые. на Эксель 2013 тоже работает у других юзеров.
Добавлено: 14 Апр 2015, 08:39

Возможно Эксель открывает при старте модальное окошко, которое вы не видите.

А как можно посмотреть что он открывает? что можно сделать?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
отлаживайте обработку.
перво наперво убедитесь что КОМ объект корректно создается,
потом непосредственно выгрузку...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Можно внутри самой обработки свойство visible сделать истиной и посмотреть что там происходит.

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Еще очень часто откроют тот же самый эксель самостоятельно и ждут, что программа его откроет. Не откроет. Дважды один и тот же файл открыть нельзя.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
//Выгрузка в Excel
Процедура ВыгрузитьВЭксельНажатие(Элемент)
Если ТЗ.Колонки.Количество() = 0 Тогда
Предупреждение("Нет данных для выгрузки.");
Возврат;
КонецЕсли;


Эксель  = Новый  COMОбъект("Excel.Application") ;
Книга = Эксель.WorkBooks.Add();
Пока  Книга.Sheets.Count > 1 Цикл
Книга.Sheets(1).Delete();
КонецЦикла;
Лист = Книга.WorkSheets(1);
Лист.Name = "ВыгрузкаДанных";

i = 0;

Для Каждого Стр Из ТЗ Цикл
i = i + 1;
//Val_2 = Формат(Стр.Год,"ЧГ=0;ЧЦ=10")+"."+Мц;
Лист.Cells(i,1).NumberFormat = "@";
Лист.Cells(i,1).Value = Стр.Период;
Лист.Cells(i,2).NumberFormat = "@";
Лист.Cells(i,2).Value = Стр.КодОрганизации;
Лист.Cells(i,3).NumberFormat = "@";
Лист.Cells(i,3).Value = Стр.НомерСчета;
Лист.Cells(i,4).NumberFormat = "@";
Лист.Cells(i,4).Value = Стр.А1;
Лист.Cells(i,5).NumberFormat = "@";
Лист.Cells(i,5).Value = Стр.А2;
Лист.Cells(i,6).NumberFormat = "@";
Лист.Cells(i,6).Value = Стр.А3;
Лист.Cells(i,7).NumberFormat = "@";
Лист.Cells(i,7).Value = Стр.А4;
Лист.Cells(i,8).NumberFormat = "@";
Лист.Cells(i,8).Value = Стр.А5;
Лист.Cells(i,9).NumberFormat = "@";
Лист.Cells(i,9).Value = Стр.А6;
Лист.Cells(i,10).NumberFormat = "@";
Лист.Cells(i,10).Value = Стр.А7;
Лист.Cells(i,11).NumberFormat = "@";
Лист.Cells(i,11).Value = Стр.А8;
Лист.Cells(i,12).NumberFormat = "@";
Лист.Cells(i,12).Value = Стр.А9;
Лист.Cells(i,13).NumberFormat = "@";
Лист.Cells(i,13).Value = Стр.А10;
Лист.Cells(i,14).NumberFormat = "@";
Лист.Cells(i,14).Value = Стр.А11;
Лист.Cells(i,15).NumberFormat = "@";
Лист.Cells(i,15).Value = Стр.KZT;
Лист.Cells(i,16).NumberFormat = "############0,00";
Лист.Cells(i,16).Value = Стр.Сумма;
Лист.Cells(i,17).NumberFormat = "@";
Лист.Cells(i,17).Value = Стр.ДатаВремя;
Лист.Cells(i,18).NumberFormat = "@";
Лист.Cells(i,18).Value = Стр.СчетУС;
Лист.Cells(i,19).NumberFormat = "@";
Лист.Cells(i,19).Value = Стр.КорСчетУС;
Лист.Cells(i,20).NumberFormat = "@";
Лист.Cells(i,20).Value = Стр.ТипДанных;
КонецЦикла;
Эксель.Visible = true;
Лист = 0;
Книга = 0;
Эксель = 0;
КонецПроцедуры

отлаживайте обработку.
перво наперво убедитесь что КОМ объект корректно создается,
потом непосредственно выгрузку...

Добавлено: 14 Апр 2015, 13:31

Можно внутри самой обработки свойство visible сделать истиной и посмотреть что там происходит.

Да все вроде так как и должно быть.

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
вы его видимым делаете только после обработки. а у вас до этой точки скорее всего не доходит. сделайте его видимым вначале и смотрите что там происходит.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
вы его видимым делаете только после обработки. а у вас до этой точки скорее всего не доходит. сделайте его видимым вначале и смотрите что там происходит.

{Обработка.ВыгрузкаДанных.Форма.Форма.Форма(1622)}: Ошибка при установке значения атрибута контекста (Value)
Лист.Cells(i,8).Value = Стр.А5;
по причине:
Произошла исключительная ситуация (0x800ac472)

Поставил как Вы сказали, открывает Эксель и заполняет данные, но почему то выкидывает такую ошибку как выше причем каждый раз в разных строках.


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4115
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2426
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8574
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 948
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1232
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 240
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal