Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Узнать номер строки  (Прочитано 1521 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tmpnikl

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-24
  • Сайт: 
есть цикл, хотелось бы узнать номер текущей строки, вариант ввести счетчик и по счетчику, можно, но может есть какая-нибудь функция, пока написал ТекущаяСтрока, но в СП, написано, что эта функция устанавливает указатель на запись и делает текущецй, а мне надо чтоб функция возвращала номер строки...
Пока ТаблЗначений.ПолучитьСтроку()=1 Цикл
Сообщить(ТаблЗначений.получитьзначение(ТаблЗначений.ТекущаяСтрока(),1);
КонецЦикла;

Не знаю, будет работать такая конструкция или нет...


Оффлайн valmus7

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 1
  • КПД: 20%
  • Регистрация: 2015-04-07
  • Сайт: 
  • Профессия: Ученик 1С
Может так: :kmtu:

//*******************************************
Процедура Выполнить()
// Фигура 1 - Инициализационная
Таб = СоздатьОбЪект("ТаблицаЗначений");
Таб.НоваяКолонка("Цвет","Строка", 20);
Таб.КоличествоСтрок(4);
Таб.УстановитьЗначение(1, 1, "Красный");
Таб.УстановитьЗначение(2, 1, "Синий");
Таб.УстановитьЗначение(3, 1, "Зеленый");
Таб.УстановитьЗначение(4, 1, "БуроБармалиновый");

// Фигура 2 - Эксперементальная
ЭН = Таб.КоличествоСтрок();
Для КА = 1 по Эн Цикл
Значение = Таб.ПолучитьЗначение(КА, 1);
Сообщить(Строка(КА) + "   " + Значение)
КонецЦикла;
Сообщить("И фсё...!!!!")

КонецПроцедуры

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
НомерСтроки
не поверите. почаще в отладчик чтоли заглядывайте.. ужас блин.. мерри попинс
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн tmpnikl

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-24
  • Сайт: 
Спасибо
valmus7 > .. У Вас цикл Для ... по ... Цикл, а в условии цикл Пока...Цикл, и алгоритм менять не хотелось бы...
дфтын   > Просмотрел в СП все методы ТЗ, забыл заглянуть в атрибуты, спасибо за подсказку...,


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 340
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal