Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Сен 2020, 12:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Замена склада по определенному счету  (Прочитано 2453 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KoD

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-10
  • Сайт: 
Здравствуйте товарищи. Столкнулся я вот с чем. В документе по счету 10,02 надо заменить один склад на другой, но почему то заменяет и на других счетах. Подскажите где ошибка в коде программы.....
           СтарыйСклад1 =  Справочники.Склады.НайтиПоКоду("000000026");
   СтарыйСклад2 =  Справочники.Склады.НайтиПоКоду("000000030");
   СтарыйСклад3 =  Справочники.Склады.НайтиПоКоду("000000027");
           НовыйСклад1 = Справочники.Склады.НайтиПоКоду("000000011");   
   НовыйСклад2 = Справочники.Склады.НайтиПоКоду("000000013");   
   НовыйСклад3 = Справочники.Склады.НайтиПоКоду("000000012");
ДокСсылка = Документы.ВводНачальныхОстатков.НайтиПоНомеру("00000000003",дата('20100101000000'));
   ДокОбъект = ДокСсылка.ПолучитьОбъект();
   
   СчетаМатериалов = Новый Массив;
   СчетаМатериалов.Добавить(ПланыСчетов.Хозрасчетный.НайтиПоКоду("10.02"));
   ПервоеЗначение = СчетаМатериалов[0];   
           ПервоеЗначение = СчетаМатериалов.Получить(0); 
 Для Каждого СтрокаМПЗПриобретенные Из ДокОбъект.МПЗПриобретенные Цикл     
      Если СтрокаМПЗПриобретенные.Склад = СтарыйСклад1 И СтрокаМПЗПриобретенные.СчетУчета = ПервоеЗначение Тогда
         СтрокаМПЗПриобретенные.Склад = НовыйСклад1
      КонецЕсли;
      Если СтрокаМПЗПриобретенные.Склад = СтарыйСклад2 И СтрокаМПЗПриобретенные.СчетУчета = ПервоеЗначение  Тогда
         СтрокаМПЗПриобретенные.Склад = НовыйСклад4
      КонецЕсли;
      Если СтрокаМПЗПриобретенные.Склад = СтарыйСклад3 И СтрокаМПЗПриобретенные.СчетУчета = ПервоеЗначение  Тогда
         СтрокаМПЗПриобретенные.Склад = НовыйСклад5
      КонецЕсли;
   КонецЦикла;
   СчетаМатериалов.Очистить();
ДокОбъект.Записать();


Оффлайн KoD

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-10
  • Сайт: 
Прошу прощения за номерацию складов в середине кода......

Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Твой код противоречит принципам программирования в 1С. (Хотя я эти принципы тоже не всегда поддерживаю, по незнанию  :D)
Ты не учитываешь работу с регистром сведений - Счета учета номенклатуры.
Есть под него стандартные процедуры/функции возвращающие структуру, для выбранной номенклатуры.
Т.е. по номенклатуре можно определить и ее счет и склад.
Поэтому нет смысла копаться в твоем коде.


Теги:
 

Почему в "ОСВ по счету" на 10 счете нет группировки по номенклатуре?

Автор Vika_22Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5090
Последний ответ 01 Сен 2014, 15:17
от pof4tomini
Как сформировать стандартный отчет "обороты по счету 51"?

Автор jiuraРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5115
Последний ответ 17 Окт 2013, 17:00
от MuI_I_Ika
Помагите добавить колонку дата долга и дата последенего платежа в отчет ОСВ по счету 60 бух. 2.0(за вознаграждение)

Автор RaideresРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3058
Последний ответ 06 Апр 2016, 08:52
от vitasw
Невозможен вычет НДС по счету-фактуре, выставленному "упрощенцем"

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1170
Последний ответ 28 Окт 2015, 00:24
от news
Необходимо выбрать все документы формирующие проводки по счету "90.01"

Автор Сергей КрутиковРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 946
Последний ответ 18 Окт 2017, 07:07
от Сергей Крутиков

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
oooo800
40 Сообщений
LexaK
30 Сообщений
IL2016
29 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
antoneus antoneus
25 Сообщений
DmitriyF DmitriyF
16 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
11 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal