Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 12:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как получить значение из файла с двоичными данными (управляемая форма, внешняя обработка)?  (Прочитано 2557 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн РусланВалиев

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-06
  • Сайт: 
  • Профессия: Программист 1С
Доброго дня! Имеется файл, сохраненный методом ЗначениеВФайл. Требуется выполнить код ЗначениеВРеквизитФормы(ЗначениеИзФайла(ИмяВременногоФайла),"Объект").
Но при помещении во временное хранилище вышеуказанного файла, его преобразуем в двоичные данные ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ФайлНаДиске),УникальныйИдентификатор). Но при получении из временного хранилища ФайлИмпорта = ПолучитьИзВременногоХранилища(АдресФайла) мы конечно же получаем получаем файл с двоичными данными. Как следствие ЗначениеИзФайла(ИмяВременногоФайла) не работает. Подскажите, пожалуйста, как быть-то?

&НаКлиенте
Процедура ВосстановитьНастройки(Команда)

ИмяФайла = СформироватьИмяФайла(РежимДиалогаВыбораФайла.Открытие,"Восстановить из файла");

Если ПустаяСтрока(ИмяФайла) тогда
Возврат
КонецЕсли;

ФайлНаДиске = Новый Файл(ИмяФайла);

Если НЕ ПроверитьСуществованиеФайла(ФайлНаДиске) Тогда

Возврат

КонецЕсли;

АдресФайла = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ФайлНаДиске),УникальныйИдентификатор);

ВосстановитьНастройкиНаСервере();

КонецПроцедуры

&НаСервере
Процедура ВосстановитьНастройкиНаСервере()

ФайлИмпорта = ПолучитьИзВременногоХранилища(АдресФайла);

ИмяВременногоФайла = ПолучитьИмяВременногоФайла("dat");

ФайлИмпорта.Записать(ИмяВременногоФайла);

        //Наверно где-то здесь я что-то не дописал

ЗначениеВРеквизитФормы(ЗначениеИзФайла(ИмяВременногоФайла),"Объект")

КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Чтение = Новый ЧтениеТекста(ИмяВременногоФайла);
ЗначениеВРеквизитФормы(ЗначениеИзФайла(Чтение.Прочитать()),"Объект");
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн РусланВалиев

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-06
  • Сайт: 
  • Профессия: Программист 1С
Чтение = Новый ЧтениеТекста(ИмяВременногоФайла);
ЗначениеВРеквизитФормы(ЗначениеИзФайла(Чтение.Прочитать()),"Объект");

Спасибо за быстрый ответ. Только я пробовал делать так, не работает... и в параметры ЗначениеИзФайла я подставлял путь к файлу, как написано в синт. помощнике.

ps: в предыдущем моем посте следует читать
АдресФайла = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ИмяФайла),УникальныйИдентификатор);
вместо
АдресФайла = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ФайлНаДиске),УникальныйИдентификатор);


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 755
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal