Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 17:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обращение к реквизиту табличной части другого документа  (Прочитано 1316 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Сергей120

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-05
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! У меня есть документ "ПервичныйЗавозТовара" с табличной частью "Товар" с реквизитами табличной части Наименование и Количество. Регистр накопления "КоличествоТовара": измерение - "Наименование", ресурсы - "Количество". И документ "Продажа",табличная часть "Товар", реквизиты "Наименование", "Количество" ,в котором я создал форму "ФормаДокумента1". (1С - Предприятие 8.2)

В модуле формы в функции я создаю запрос на вытаскивание Наименования и Количества товаров из  РегистраНакопления, мне нужно сравнивать Наименование товара который я выбрал для продажи в документе с наименованием товаров вытащенных из регистранакопления и если они совпадают, то возвращать в колонку "Количество" количество товаров на складе данного наименования. Как обратиться к реквизиту табличной части документа ПервичныйЗавозТовара?

&НаСервереБезКонтекста
функция ВыбираемИзЗапроса()
Перем КолТов;
Запрос = Новый Запрос("Выбрать Количество, Наименование ИЗ РегистрНакопления.КоличествоТовара");
РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();

СтрокаТабличнойЧасти = Элементы.ПервичныйЗавозтовара.Товар.ТекущиеДанные;
ОбъектДляЧегоТо = ПолучитьИмя(СтрокаТабличнойЧасти.Наименование);
СтрокаТабличнойЧасти.Наименование = ОбъектДляЧегоТо;

Пока Выборка.Следующий() Цикл
Если Выборка.Наименование = ОбъектДляЧегоТо Тогда
  КолТов = Выборка.Количество;
КонецЕсли;
КонецЦикла;
Возврат  КолТов;
КонецФункции


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
"ВЫБРАТЬ
|   РеализацияТоваровУслугТовары.Номенклатура,
|   РеализацияТоваровУслугТовары.Количество КАК КоличествоВДокументе,
|   ЕСТЬNULL(ТоварыНаСкладахОстатки.КоличествоОстаток, 0) КАК КоличествоВРН
|ИЗ
|   Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
|      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ТоварыНаСкладах.Остатки КАК ТоварыНаСкладахОстатки
|      ПО РеализацияТоваровУслугТовары.Номенклатура = ТоварыНаСкладахОстатки.Номенклатура
|ГДЕ
|   РеализацияТоваровУслугТовары.Ссылка = &Ссылка"

Оффлайн Сергей120

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-05
  • Сайт: 
  • Профессия: Ученик 1С
т.е. для моего случая код будет выглядеть так?

&НаСервереБезКонтекста
Функция ЗапросКоличества()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|   ПервичныйЗавозТовараТовар.Номенклатура,
|   ПервичныйЗавозТовараТовар.Количество КАК КоличествоВДокументе,
|   ЕСТЬNULL(КоличествоТовараКоличество.КоличествоОстаток, 0) КАК КоличествоВРН
|ИЗ
|   Документ.ПервичныйЗавозТовара.Товар КАК ПервичныйЗавозТовараТовар
|      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.КоличествоТовара.Количество КАК КоличествоТовараКоличество
|      ПО ПервичныйЗавозТовараТовар.Номенклатура = КоличествоТовараКоличество.Номенклатура
|ГДЕ
|   ПервичныйЗавозТовараТовар.Ссылка = (&Ссылка)";
 Запрос.Параметры.Вставить("Ссылка");
 Выборка = Запрос.Выполнить().Выбрать();
 Возврат Выборка;
КонецФункции


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Сергей120, примерно так, только обращаться нужно наверное к таблице остатков, а не ко всей таблице регистра...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.КоличествоТовара.Количество КАК КоличествоТовараКоличество
? что есть это?!?! это разве работает???


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
|      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.КоличествоТовара.Количество КАК КоличествоТовараКоличество

оу
май
гаш!!!
:o
:xfbnsdfb:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Сергей120

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-05
  • Сайт: 
  • Профессия: Ученик 1С
нет, не работает, поле не найдено


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4476
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7746
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4786
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8520
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7343
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 580
  • Точка Скрытых: 1
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal