Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Работа с документами  (Прочитано 2499 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Рус25

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-04
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Есть два документа: ЗаказыПокупателя и РеализацияТоваровИУслуг. Документ РеализацияТоваровИУслуг создаётся на основании документа ЗаказыПокупателя.
задача состоит в следующем: доработать код, созданный с помощью конструктора, таким образом, чтобы при создании документа реализации товаров на основании заказа, в документ попадали не все товары и услуги из заказа, а только те, которые ещё не отгружены по данному заказу.
Задачу нужно решить без использования регистров накопления и регистров сведений и желательно без запроса.

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)

// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
// Заполнение шапки
КонтактноеЛицо = ДанныеЗаполнения.КонтактноеЛицо;
Контрагенты = ДанныеЗаполнения.Контрагенты;
ОбщаяСумма = ДанныеЗаполнения.ОбщаяСумма;
ИдентификаторЗаказа = ДанныеЗаполнения.Ссылка;
Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
НоваяСтрока = Товары.Добавить();
НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаТовары.ЕдиницаИзмерения;
НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
КонецЦикла;
Для Каждого ТекСтрокаУслуги Из ДанныеЗаполнения.Услуги Цикл
НоваяСтрока = Услуги.Добавить();
НоваяСтрока.Номенклатура = ТекСтрокаУслуги.Номенклатура;
НоваяСтрока.Сумма = ТекСтрокаУслуги.Сумма;
КонецЦикла;
КонецЕсли;

КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
делаем выборку проведенных реализаций (через Выбрать()) с отбором по документу основание - заказу.
собираем из этих реализаций табличку отгруженной номенклатуры.
далее заполняя ТЧ Товары текущей реализации исключаем номенклатуру из вышеупомянутой таблицы.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Рус25

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-04
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо.
а кодом можешь помочь?)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
т.е. не просто разжевать а еще и в рот положить? :trhregerhg:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Задачу нужно решить без использования регистров накопления и регистров сведений и желательно без запроса.

Афигеть условие!!! Как определять товар который еще не был отгружен?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Как определять товар который еще не был отгружен?

выборка документов с помощью Выбрать()...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
СтрПоиска = ТЧОтгруженныеТовары("Номенклатура", ТекСтрокаТовары.Номенклатура)
Если СтрПоиска = Неопределено Тогда           
НоваяСтрока = Товары.Добавить();
            НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаТовары.ЕдиницаИзмерения;
            НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
            НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
ИначеЕсли НЕ ТекСтрокаТовары.Количество = СтрПоиска.Количество Тогда // Если какую-то часть товаров отгрузили, а остаток - нет
НоваяСтрока = Товары.Добавить();
            НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаТовары.ЕдиницаИзмерения;
            НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
            НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
НоваяСтрока.Количество = ТекСтрокаТовары.Количество - СтрПоиска.Количество;

 КонецЕсли;       
КонецЦикла;
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
СтрПоиска = ТЧОтгруженныеТовары("Номенклатура", ТекСтрокаТовары.Номенклатура)

вот из вис?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
выборка документов с помощью Выбрать()...
Т.е. один и тот же товар нельзя отгрузить дважды?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
выборка документов с помощью Выбрать()...
Т.е. один и тот же товар нельзя отгрузить дважды?

ну да, как то так
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal