Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 06:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вывести табличный документ в форму "Печать документов"  (Прочитано 2704 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Вот так не работает
&НаСервере
Функция ОжидаемыеПоступлнеияСервер(Номенклатура)
Макет=Справочники.Номенклатура.ПолучитьМакет("ОжидаемыеПоступления");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказПоставщику.Ссылка,
| ЗаказПоставщику.ЖелаемаяДатаПоступления,
| ЗаказПоставщикуТовары.КоличествоУпаковок,
| ЗаказПоставщикуТовары.Количество
|ИЗ
| Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПоставщику КАК ЗаказПоставщику
| ПО ЗаказПоставщикуТовары.Ссылка = ЗаказПоставщику.Ссылка
|ГДЕ
| ЗаказПоставщикуТовары.Номенклатура = &Номенклатура";

Запрос.УстановитьПараметр("Номенклатура", Номенклатура);

РезультатЗапроса = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьЗаголовок.Параметры.Номенклатура=Номенклатура;
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
ТабДок=Новый ТабличныйДокумент;
ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
ТабДок.ТолькоПросмотр=Истина;
ТабДок.АвтоМасштаб=Истина;
    Возврат ТабДок;
КонецФункции


&НаКлиенте
Процедура ОжидаемоеПоступление(Команда)
Если ЭтаФорма.Элементы.СписокРасширенныйПоискНоменклатура.ТекущиеДанные<>Неопределено  Тогда
Строка=ЭтаФорма.Элементы.СписокРасширенныйПоискНоменклатура.ТекущиеДанные;
Номенклатура=Получить(Строка.Наименование);
КонецЕсли;
ТабДок=ОжидаемыеПоступлнеияСервер(Номенклатура);
МассивОбъектов=Новый Массив;
МассивОбъектов.Добавить(ТабДок);
ПараметрыОткрытия = Новый Структура("ИмяМенеджераПечати,ИменаМакетов,ПараметрКоманды");
ПараметрыОткрытия.ИмяМенеджераПечати = "Справочник.Номенклатура";
ПараметрыОткрытия.ИменаМакетов = "ОжидаемоеПоступление";
ПараметрыОткрытия.ПараметрКоманды = МассивОбъектов;
ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия, ЭтаФорма.ВладелецФормы);
КонецПроцедуры


Теги:
 

Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 20720
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 520
Последний ответ 18 Авг 2017, 11:57
от ZSS
Убрать документ из обмена. Правила обмена.

Автор bestnameРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 725
Последний ответ 10 Май 2017, 15:18
от bestname
1C:ERP 2.2 Документ Этап производства. Дата производства.

Автор Pavel_0573Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1107
Последний ответ 31 Май 2017, 16:59
от Pavel_0573
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 456
Последний ответ 14 Ноя 2017, 10:43
от oleg-x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
30 Сообщений

* Кто онлайн

  • Точка Гостей: 245
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal