Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 03:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборка в выборке  (Прочитано 2543 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
Помогите разобраться.
Вот код:

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);//Здесь мы обращаемся к сгруппированным данным запроса
Пока Выборка.Следующий() Цикл
Если Выборка.Количество > Выборка.количествоостаток тогда
Сообщить("Не хватает товара   " + Выборка.Товар + " в количестве " + (Выборка.Количество - Выборка.КоличествоОстаток));
Отказ = истина;
Движения.Общий.Записывать = ложь;
КонецЕсли;
КонецЦикла;
Если отказ тогда
Возврат;
КонецЕсли;

Выборка.Сбросить();//Сбрасываем результаты предыдущей выборки
Пока Выборка.Следующий() Цикл //Снова обращаемся к первоначальному результату запросу
ОсталосьСписать = Выборка.Количество;

ВыборкаПартии = Выборка.Выбрать();// А ЧТО ВОТ ЭТО ЗА ВЫБОРКА ВНУТРИ ОСНОВНОЙ ВЫБОРКИ? ЧТО ОНА ВЫБИРАЕТ И КАК ЭТО РАБОТАЕТ?

Пока ВыборкаПартии.Следующий() И ОсталосьСписать <> 0 Цикл
Списать = Мин(ОсталосьСписать, ВыборкаПартии.КоличествоОстаток);
Себестоимость = Списать / ВыборкаПартии.КоличествоОстаток * ВыборкаПартии.СтоимостьОстаток;
СуммаПродажи = ВыборкаПартии.ЦенаПродажи*Списать;                   
    
      Движение = Движения.Общий.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
      Движение.Период = Дата;
      Движение.Склад  =Склад;
      Движение.Товар = ВыборкаПартии.Товар;
      Движение.Количество = Списать;
      Движение.Стоимость = Себестоимость;
        Движение.СуммаПродажи = СуммаПродажи;
      Движение.Партия = ВыборкаПартии.Партия;
      
      ОсталосьСписать = ОсталосьСписать - Списать;

   КонецЦикла;
   КонецЦикла;


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
когда у вас в запросе имеются ИТОГИ ПО ...
результат получается многоуровневым.
запихните текст запроса в консоль и только выберите отображать результат в виде дерева...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
Ну обход по итогам делает первая выборка.
А вот что дальше происходит:

Выборка.сбросить();
Пока Выборка.Следующий() Цикл
ВыборкаПартии = Выборка.Выбрать()?


Первая выборка обходит Итоги, вторая выборка это основная выборка из запроса, а что делает то третья выборка? она получается выборкой внутри выборки?:dfbsdfbsdf:

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
если у вас итоги только по одному полю, то в результате получаете 2 уровня - по полю итогов и так называемые детальные записи.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1591
Последний ответ 25 Май 2016, 19:38
от marshalbratsk
выборка счетов из плана счетов

Автор markgenuineРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3395
Последний ответ 22 Ноя 2012, 12:13
от markgenuine
Выборка - "не может использоваться в данных формы"

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1872
Последний ответ 20 Фев 2015, 09:15
от ferrari314
Выборка данных из табличной части справочника в табличную часть документа

Автор GerryРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 600
Последний ответ 01 Июн 2016, 17:57
от Rasty
Выборка и выгрузка всех документов из одной базы в другую - 1С

Автор Святослав БалашовРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 570
Последний ответ 02 Дек 2016, 21:38
от Святослав Балашов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 125
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal