Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись из 1С в txt. Как удалить пустую строку?  (Прочитано 3014 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн roofless

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Stay hungry, stay foolish (с)
  • Регистрация: 2014-06-21
    • Skype: roof-less
  • Компания: РЦ "Капитан"
  • Профессия: Ученик 1С
Записываю в файл примерно таким образом:
Файл = Новый ТекстовыйДокумент();

Файл.ДобавитьСтроку("##@@&&");
Файл.ДобавитьСтроку("#");
Файл.ДобавитьСтроку("$$$DELETEALLWARES");
Файл.ДобавитьСтроку("$$$DELETEALLBARCODES");
Файл.ДобавитьСтроку("$$$DELETEALLASPECTREMAINS");

Для Каждого Товар Из Товары Цикл
Строка = ...
Файл.ДобавитьСтроку(Строка);
КонецЦикла;

Файл.Записать(Параметры.БазаТоваров, КодировкаТекста.ANSI); //записываем в указанный путь в указанной кодировке

После записи в файле последняя строчка пустая. Пример см во вложении
При загрузке из файла программа фронтофиса ругается именно на пустую строчку. Как её удалить?
УдалитьСтроку() не предлагать


Оффлайн k_aleks80

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 14
  • КПД: 22%
  • Регистрация: 2011-09-08
  • Сайт: 
  • Профессия: Программист 1С
Правильно я понимаю, что если ручками в txt файле удалить пустую строку, тогда загрузка во фронтофис проходит успешно?

...
Строка = ...
...

Мое мнение - беда где-то здесь ...

Оффлайн roofless

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Stay hungry, stay foolish (с)
  • Регистрация: 2014-06-21
    • Skype: roof-less
  • Компания: РЦ "Капитан"
  • Профессия: Ученик 1С
Правильно я понимаю, что если ручками в txt файле удалить пустую строку, тогда загрузка во фронтофис проходит успешно?

...
Строка = ...
...

Мое мнение - беда где-то здесь ...

да, успешно.

пустую строку я не добавляю. моё мнение, что после ДобавитьСтроку() 1с автоматически переводит каретку на следующую строчку

Оффлайн k_aleks80

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 14
  • КПД: 22%
  • Регистрация: 2011-09-08
  • Сайт: 
  • Профессия: Программист 1С
А в коде: Файл.КоличествоСтрок() - что дает?
Добавлено: 02 Апр 2015, 10:20

В СП: смотри 3-й параметр метода Записать() ТекстовогоДокумента

Последний раз редактировалось: k_aleks80; 02 Апр 2015, 10:20. Причина: Объединение сообщений

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
вот попробуйте такой код, у меня получилось, последней, пустой строки нет
Файл = Новый ТекстовыйДокумент();

Файл.ДобавитьСтроку("##@@&&");
Файл.ДобавитьСтроку("#");
Файл.ДобавитьСтроку("$$$DELETEALLWARES");
Файл.ДобавитьСтроку("$$$DELETEALLBARCODES");
Файл.ДобавитьСтроку("$$$DELETEALLASPECTREMAINS");

Для Каждого Товар Из Товары Цикл
Строка = ...
Файл.ДобавитьСтроку(Строка);
КонецЦикла;

//удаление последнего символа Перевода строки
Файл.УстановитьТекст(СтрЗаменить(Файл.ПолучитьТекст()+"~Ё",Символы.ПС+"~Ё",""));

Файл.Записать(Параметры.БазаТоваров, КодировкаТекста.ANSI); //записываем в указанный путь в указанной кодировке

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн roofless

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Stay hungry, stay foolish (с)
  • Регистрация: 2014-06-21
    • Skype: roof-less
  • Компания: РЦ "Капитан"
  • Профессия: Ученик 1С
вот попробуйте такой код, у меня получилось, последней, пустой строки нет
Файл = Новый ТекстовыйДокумент();

Файл.ДобавитьСтроку("##@@&&");
Файл.ДобавитьСтроку("#");
Файл.ДобавитьСтроку("$$$DELETEALLWARES");
Файл.ДобавитьСтроку("$$$DELETEALLBARCODES");
Файл.ДобавитьСтроку("$$$DELETEALLASPECTREMAINS");

Для Каждого Товар Из Товары Цикл
Строка = ...
Файл.ДобавитьСтроку(Строка);
КонецЦикла;

//удаление последнего символа Перевода строки
Файл.УстановитьТекст(СтрЗаменить(Файл.ПолучитьТекст()+"~Ё",Символы.ПС+"~Ё",""));

Файл.Записать(Параметры.БазаТоваров, КодировкаТекста.ANSI); //записываем в указанный путь в указанной кодировке


супер, спасибо!

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
еще вариант
с помощью этого метода можно настроить удаление пустых строк внутри текстового файла
//удаление последнего символа Перевода строки
Файл.УстановитьТекст(СтрЗаменить(Файл.ПолучитьТекст(),Символы.ПС+Символы.ПС,Символы.ПС));

еще вариант удаления последнего символа ПС
лкТекст = Файл.ПолучитьТекст(); 
Файл.УстановитьТекст(Лев(лкТекст,СтрДлина(лкТекст)-1));
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Как понять запись ?(НачОстаток = Null,0,НачОстаток)

Автор olgahachnewРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2576
Последний ответ 07 Апр 2011, 17:38
от chuevsf
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14356
Последний ответ 11 Янв 2011, 10:04
от nomer13
Запись элемента справочника из модуля объекта другого справочника

Автор 12040Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1415
Последний ответ 05 Май 2016, 09:29
от LexaK
Запись регистра регистра сведений стали не уникальными: РасчетПереоценкиВалютныхСредств

Автор GinayatРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 171
Последний ответ 09 Ноя 2017, 21:42
от Геннадий ОбьГЭС
При формир. "Книги покупок" в 1С УПП двойная запись в основ. книге и в доп.листе

Автор Dasha_Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4212
Последний ответ 14 Сен 2012, 09:36
от Dasha_

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 253
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal