Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 21:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как открыть форму нового не записанного документа?  (Прочитано 1802 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С


Оффлайн blackmoon89

  • Разработчик 1С
  • ***
  • Сообщений: 105
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2015-02-28
    • Skype: klimsrv
  • Компания: ООО Стимпроект
  • Профессия: Разработчик 1С
пример

ОткрытьФорму("Документ.ЗаказКлиента.ФормаОбъекта");

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
ОткрытьФорму("Документ.ЗаказКлиента.ФормаОбъекта");
немного разобрался)))

вот что получилось:
&НаСервере
Процедура   ПредзаказПоставщикуНаСервере(ДанныеФормы)

Для каждого стр из Объект.Товары Цикл
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Поставщики.Номенклатура КАК Номенклатура
|ПОМЕСТИТЬ Поставщики
|ИЗ
| &Поставщики КАК Поставщики
|
|ИНДЕКСИРОВАТЬ ПО
| Номенклатура
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| НоменклатураПоставщиков.Поставщик КАК Поставщик,
| НоменклатураПоставщиков.Номенклатура
|ИЗ
| РегистрСведений.НоменклатураПоставщиков КАК НоменклатураПоставщиков
| ЛЕВОЕ СОЕДИНЕНИЕ Поставщики КАК Поставщики
| ПО НоменклатураПоставщиков.Номенклатура = Поставщики.Номенклатура
|ГДЕ
| НоменклатураПоставщиков.Номенклатура = &Номенклатура
|
|СГРУППИРОВАТЬ ПО
| НоменклатураПоставщиков.Поставщик,
| НоменклатураПоставщиков.Номенклатура";
Запрос.УстановитьПараметр("Поставщики",Объект.Товары.Выгрузить(,"Номенклатура"));

Запрос.УстановитьПараметр("Номенклатура",Стр.Номенклатура);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();


Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Док = ДанныеФормыВЗначение(ДанныеФормы, Тип("ДокументОбъект.ПредзаказПоставщику"));
Док.ЗаказПокупателя=Объект.Ссылка;
Док.Поставщик=ВыборкаДетальныеЗаписи.Поставщик;
Док.Дата=ТекущаяДата();
ЗаполнитьЗначенияСвойств(Док,Объект);
ЗаполнитьЗначенияСвойств(Док.Товары.Добавить(),стр);
ЗначениеВДанныеФормы(Док,ДанныеФормы);

КонецЦикла;
КонецЦикла;



КонецПроцедуры


&НаКлиенте
Процедура ПредзаказПоставщику(Команда)   

Форма = ПолучитьФорму("Документ.ПредзаказПоставщику.ФормаОбъекта");
ДанныеФормы = Форма.Объект;
ПредзаказПоставщикуНаСервере(ДанныеФормы);
КопироватьДанныеФормы(ДанныеФормы, Форма.Объект);
Форма.Открыть();

КонецПроцедуры
чет тут я запорол(((.. в итоге мне нужно, чтобы создались и открылись несколько документов(должно создаться столько документов сколько у номенклатуры из документа"ЗаказПокупателя" поставщиков)


Добавлено: 31 Мар 2015, 21:27

Друзья ну подскажите мне как открыть несколько форм??
Добавлено: 01 Апр 2015, 22:42

помогите же....товагищи

Последний раз редактировалось: mashencev_anton; 01 Апр 2015, 22:42. Причина: Объединение сообщений


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15908
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 620
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7735
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4773
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 304
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal