Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 16:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ВПФ недопустимое значение параметра  (Прочитано 3657 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ego_Solnce

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-30
  • Сайт: 
Всем здравствуйте. Создаю внешнюю печатную форму в 1с Документооборот для печати внутренних заявлений. Синтаксических ошибок не обнаружено, в 1с тоже нормально загрузилась, но при печати из документа сразу вылетает ошибка: Недопустимое значение параметра (параметр номер 1). Подскажите, где ошибка.


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Почитайте в спр. ВПФ требования к подключению этих самых ВПФ.

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
какая строчка в коде хотя бы скажите

Оффлайн Ego_Solnce

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-30
  • Сайт: 
он не выдает ошибок, а сама я не знаю какая строчка в коде((
вообще если честно никогда в 1с не программировала и не работала, я секретарь)
поэтому если можете, укажите мне где что нужно исправить:nhsrm:

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
запустите базу в режиме конфигуратора, после нажмите f5 - запуск клиента в отладке. В момент когда высочит ошибка можно будет посмотреть в каком именно месте кода ошибка.

Оффлайн Ego_Solnce

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-30
  • Сайт: 
запустите базу в режиме конфигуратора, после нажмите f5 - запуск клиента в отладке. В момент когда высочит ошибка можно будет посмотреть в каком именно месте кода ошибка.
Ошибка времени выполнения:
{ВнешняяОбработка.Внешняя.МодульОбъекта(60)}: Ошибка при вызове метода контекста (Получить Макет)в модуле ВнешняяОбработка.Внешняя.МодульОбъекта, строка 60
Добавлено: 30 Мар 2015, 11:23

Эта ошибка в Общем модуле ДополнительныеОтчетыИОбработки,
вот процедура в которой вылетает ошибка:
// Формирует печатную форму по внешнему источнику
//
// Параметры:
//   Ссылка (СправочникСсылка.ДополнительныеОтчетыИОбработки) Внешняя обработка
//   ПараметрыИсточника - Структура -
//       * ИдентификаторКоманды - Строка - Список макетов, перечисленных через запятую
//       * ОбъектыНазначения    (Массив)
//   КоллекцияПечатныхФорм - ТаблицаЗначений - см. описание процедуры Печать() в документации.
//   ОбъектыПечати         (СписокЗначений)  см. описание процедуры Печать() в документации.
//   ПараметрыВывода       - Структура -       см. описание процедуры Печать() в документации.
//
Процедура ПечатьПоВнешнемуИсточнику(Ссылка, ПараметрыИсточника, КоллекцияПечатныхФорм,
   ОбъектыПечати, ПараметрыВывода) Экспорт
   
   Если Не ПолучитьФункциональнуюОпцию("ИспользоватьДополнительныеОтчетыИОбработки") Тогда
      Возврат;
   КонецЕсли;
   
   КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(ПараметрыИсточника.ИдентификаторКоманды);
   
   ПараметрыВывода = УправлениеПечатью.ПодготовитьСтруктуруПараметровВывода();
   
   ОбъектыПечати = Новый СписокЗначений;
   
   ВнешняяОбработкаОбъект = ПолучитьОбъектВнешнейОбработки(Ссылка);
   
   Если ВнешняяОбработкаОбъект = Неопределено Тогда
      ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
         НСтр("ru = 'Внешняя обработка ""%1"" (тип ""%2"") не обслуживается подсистемой ""Дополнительные отчеты и обработки""'"),
         Строка(Ссылка),
         Строка(ТипЗнч(Ссылка)));
   КонецЕсли;
   
   ВнешняяОбработкаОбъект.Печать(
      ПараметрыИсточника.ОбъектыНазначения,
      КоллекцияПечатныхФорм,
      ОбъектыПечати,
      ПараметрыВывода);
   
   // Проверим, все ли макеты были сформированы
   Для Каждого Стр Из КоллекцияПечатныхФорм Цикл
      Если Стр.ТабличныйДокумент = Неопределено Тогда
         ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru = 'В обработчике печати не был сформирован табличный документ для: %1'"),
            Стр.ИмяМакета);
         ВызватьИсключение(ТекстСообщенияОбОшибке);
      КонецЕсли;
      
      Стр.ТабличныйДокумент.КоличествоЭкземпляров = Стр.Экземпляров;
   КонецЦикла;

КонецПроцедуры

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
ищите в модуле объета
МакетОбработки = ПолучитьМакет(""); //было
МакетОбработки = ПолучитьМакет("Заявления"); //сделайте так

Оффлайн Ego_Solnce

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-30
  • Сайт: 
ищите в модуле объета
МакетОбработки = ПолучитьМакет(""); //было
МакетОбработки = ПолучитьМакет("Заявления"); //сделайте так
Изначально так и было. Сделала.При запуске печати из заявления выдает теперь такую ошибку: Значение не является значением объектного типа (Ссылка)

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
я не смогу помочь, без указания на номер строки, в которой ошибка. Полный код модуля не нужно печатать, просто строка и описание ошибки, при запущенном конфигураторе

Оффлайн Ego_Solnce

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-30
  • Сайт: 
я не смогу помочь, без указания на номер строки, в которой ошибка. Полный код модуля не нужно печатать, просто строка и описание ошибки, при запущенном конфигураторе
Ошибка времени выполнения:
{ВнешняяОбработка.Внешняя.МодульОбъекта(62)}: Значение не является значением объектного типа (Ссылка) в модуле ВнешняяОбработка.Внешняя.МодульОбъекта, строка 62


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6857
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3226
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 965
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1076
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8508
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 697
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal