Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 08:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя печатная форма.  (Прочитано 1533 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн иванБИТ

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-04
  • Сайт: 
  • Профессия: Разработчик 1С
Здравствуйте. Такая проблема. Создаю внешнюю печатную форму. вывожу по группам товаров. вроде все по учебнику. но во время вывода первой выборки "ВыборкаОбщийИтог " что то идет не так. может усталость сказывается. но немогу понять почему область выводит. но параметры не заполняет. и другие области кроме ОблШапка не видит.





Функция Печать() Экспорт
   ТабДок = новый ТабличныйДокумент;
   
   
   Макет = ПолучитьМакет("Макет");

   ОбластьШапки   = Макет.ПолучитьОбласть("ОблШапка");
   ОбластьГруппа = Макет.ПолучитьОбласть("ОблГруппа");
   
   ОбластьДанные   = Макет.ПолучитьОбласть("ОблДанные");
   ОбластьПодвал   = Макет.ПолучитьОбласть("ОблПодвал");
   
   ОбластьШапки.Параметры.Контрагент = СсылкаНаОбъект.Контрагент;
   ОбластьШапки.Параметры.Договор = СсылкаНаОбъект.ДоговорКонтрагента;
   ОбластьШапки.Параметры.Организация = СсылкаНаОбъект.Организация;
   ОбластьШапки.Параметры.Проект = СсылкаНаОбъект.Проект;
    ОбластьШапки.Параметры.Подразделение = СсылкаНаОбъект.Подразделение;

         
   ТабДок.Вывести(ОбластьШапки);
      
   Запрос = новый запрос;
   Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
   Запрос.Текст = "ВЫБРАТЬ
                  |   СУММА(РеализацияТоваровУслугТовары.СуммаНДС + РеализацияТоваровУслугТовары.Сумма) КАК СуммаСНДС,
                  |   РеализацияТоваровУслугТовары.Номенклатура.Родитель.Ссылка КАК ТоварнаяГруппа,
                  |   РеализацияТоваровУслугТовары.Номенклатура.Ссылка КАК Номенклатура
                  |ИЗ
                  |   Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                  |ГДЕ
                  |   РеализацияТоваровУслугТовары.Ссылка = &Ссылка
                  |
                  |СГРУППИРОВАТЬ ПО
                  |   РеализацияТоваровУслугТовары.Номенклатура.Родитель.Ссылка,
                  |   РеализацияТоваровУслугТовары.Номенклатура.Ссылка
                  |ИТОГИ
                  |   СУММА(СуммаСНДС)
                  |ПО
                  |   ОБЩИЕ,
                  |   ТоварнаяГруппа";
               
               Выборка = Запрос.Выполнить().Выбрать();
                              
   ВыборкаОбщийИтог = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    ВыборкаОбщийИтог.Следующий();
   
    ЗаполнитьЗначенияСвойств(ОбластьПодвал.Параметры,ВыборкаОбщийИтог);
    Табдок.Вывести(ОбластьПодвал);
   
    ВыборкаПоГруппамТовара = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
   Пока ВыборкаПоГруппамТовара.Следующий() Цикл
       ЗаполнитьЗначенияСвойств(ОбластьГруппа.Параметры,ВыборкаПоГруппамТовара);
     
    ТабДок.Вывести(ОбластьГруппа);

   ВыборкаПоНоменклатуре = ВыборкаПоГруппамТовара.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

    Пока ВыборкаПоНоменклатуре.Следующий() Цикл
      
      ЗаполнитьЗначенияСвойств(ОбластьДанные.Параметры,ВыборкаПоНоменклатуре);
       ТабДок.Вывести(ОбластьДанные);
      
   КонецЦикла;
       
    КонецЦикла;
   
   возврат ТабДок;

   

КонецФункции


Оффлайн иванБИТ

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-04
  • Сайт: 
  • Профессия: Разработчик 1С
платформа  8.2. УПП 1.3.50.1

Оффлайн blackmoon89

  • Разработчик 1С
  • ***
  • Сообщений: 105
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2015-02-28
    • Skype: klimsrv
  • Компания: ООО Стимпроект
  • Профессия: Разработчик 1С
масса вариантов

приложите свой файлик к сообщению

Оффлайн Luzer1C

  • ****
  • Сообщений: 455
  • РЕПУТАЦИЯ: 56
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Я вижу только то, что между строк:
Цитировать
Выборка = Запрос.Выполнить().Выбрать();
                             
   ВыборкаОбщийИтог = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
нужно добавить цикл и строку следующего содержания:

Пока Выборка.Следующий() Цикл
... и в конце
КонецЦикла
Халамбалам.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Выборка = Запрос.Выполнить().Выбрать();
                             
   ВыборкаОбщийИтог = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    ВыборкаОбщийИтог.Следующий();

вот это место неправильное
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Luzer1C

  • ****
  • Сообщений: 455
  • РЕПУТАЦИЯ: 56
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
вот это место неправильное
Вот вот. И я о том же.:btbzdb:
Халамбалам.


Теги:
 

УТ 11.3 форма "УправлениеЭквайринговымТерминалом"

Автор skelaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 238
Последний ответ 09 Фев 2018, 21:23
от Геннадий ОбьГЭС
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5545
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94
Вопрос по УНФ (форма "Задание на работу")

Автор tantonyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 623
Последний ответ 22 Июн 2017, 18:22
от tantony
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5489
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7890
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 220
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal