Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 02:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод табличной части документа на макет  (Прочитано 2438 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pinhet

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-13
  • Сайт: 
Добрый день. Есть документ Ремонт, в нем есть табличная часть Устранение. Я создал макет для печати и выделил на нем область (Назвал ОбластьРемонт). Как в выделенную область поместить табличную часть этого документа с данными?


Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Нужно нарисовать область, назвать ее например СтрокаТабЧасти. В цикле перебирать строки таб части и выводить область в таб док.
Примерно так:
[code
Для каждого стр из табчасть цикл
]областьСтрокаТабЧасти = табдок.получитьобласть("СтрокаТабЧасти");

Код заполнения строки
Табдок.вывести(областьСтрокаТабЧасти);

КонецЦикла
Добавлено: 28 Мар 2015, 19:26

Нужно нарисовать область, назвать ее например СтрокаТабЧасти. В цикле перебирать строки таб части и выводить область в таб док.
Примерно так:
[code]
Для каждого стр из табчасть цикл
областьСтрокаТабЧасти = табдок.получитьобласть("СтрокаТабЧасти");
[code]
Ваш код
[code]
Табдок.вывести(областьСтрокаТабЧасти);
КонецЦикла
Народная мудрость: Программу встречают по интерфейсу

Последний раз редактировалось: SitnovaMarina; 28 Мар 2015, 19:26. Причина: Объединение сообщений

Оффлайн Pinhet

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-13
  • Сайт: 
Нужно нарисовать область, назвать ее например СтрокаТабЧасти. В цикле перебирать строки таб части и выводить область в таб док.
Примерно так:
[code
Для каждого стр из табчасть цикл
]областьСтрокаТабЧасти = табдок.получитьобласть("СтрокаТабЧасти");

Код заполнения строки
Табдок.вывести(областьСтрокаТабЧасти);

КонецЦикла
Добавлено: 28 Мар 2015, 19:26

Нужно нарисовать область, назвать ее например СтрокаТабЧасти. В цикле перебирать строки таб части и выводить область в таб док.
Примерно так:
[code]
Для каждого стр из табчасть цикл
областьСтрокаТабЧасти = табдок.получитьобласть("СтрокаТабЧасти");
[code]
Ваш код
[code]
Табдок.вывести(областьСтрокаТабЧасти);
КонецЦикла
Спасибо, а такой цикл будет работать?
колвострок = СпособыУстранения.Количество();
номерстр = 0;
Способ = Макет.ПолучитьОбласть("Способ");
Пока номерстр <= колвострок-1 Цикл 
    реквстроки = СпособыУстранения.Получить(номерстр);
Способ.Параметры.Способ = реквстроки;
ТабличныйДокумент.Вывести(Способ);
    номерстр = номерстр+1;
КонецЦикла;


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7735
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4773
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8488
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7334
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal