Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 02:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: управляемые формы незаписанных документов  (Прочитано 3669 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн glna

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Программно создаю и открываю несколько однотипных документов без записи. В результате получаю одну открытую форму последнего документа. Использую приблизительно такой код

 КопироватьДанныеФормы(ОбъектыФорм1, Формы1.Объект);
 Формы1.Открыть();
 КопироватьДанныеФормы(ОбъектыФорм2, Формы2.Объект);
 Формы2.Открыть();

Насколько понимаю, в этом случае формы всех полученных незаписанных документов получают одинаковый уникальный идентификатор.
Можно ли программно открыть несколько созданных, но еще не записанных  документов?


Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Создал документ, заполнил, записал, создал еще один, заполнил, записал.
Это мой вариант, было бы интересно можно ли такое реализовать =)
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн glna

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Создал документ, заполнил, записал, создал еще один, заполнил, записал.
Это мой вариант, было бы интересно можно ли такое реализовать =)

При записи как раз все хорошо. Например:
Док=Документы.ТребованиеНакладная.СоздатьДокумент();
заполнение .....
Док.Записать();
ПоказатьЗначение(,Док);

А вот в случае, если документы требуется не записывать, возникает вышеуказанная проблема.

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Нужно открыть несколько форм по созданию документа?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн glna

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Нужно открыть несколько форм по созданию документа?

Да, создаются несколько документов, но не записываются. И их все нужно открыть.
А для пользователя открывается только один последний документ.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн glna

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
glna, http://katalog.forum-1c.ru/public/118784/

Проблем с открытием созданного, но еще незаписанного документа нет.
У меня вопрос другой:
Как одновременно открыть НЕСКОЛЬКО таких документов. Т.к. в результате я получаю только ОДНУ форму последнего созданного документа.

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Ответ предельно прост, никак, это тоже самое что создать документ из 1Ски, заполнить его, свернуть, и нажать снова кнопку добавить, откроется то же окно, так что никак.
А если кто-то знает как, поделитесь, очень интересно
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
у ПолучитьФорму() и ОткрытьФорму() есть параметр - КлючУникальности...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
есть способ создания (без записи) нескольких документов и открытия их форм (несколько штук)

написал простенькую обработку с одной кнопкой СоздатьОткрытьДокумент,
вот весь ее код:


&НаКлиенте
Процедура СоздатьОткрытьДокумент(Команда)

СоздатьДок();

ОткрытьФорму("Документ.СборкаКомпьютера.ФормаОбъекта",
Новый Структура("Документ",Объект.Док),,Объект.Док.Номер);

КонецПроцедуры

&НаСервере
Функция СоздатьДок()

//на сервере создаете и заполняете документ
лкДок = Документы.СборкаКомпьютера.СоздатьДокумент();
лкДок.Номер = Объект.Номер;
Объект.Номер = Объект.Номер + 1;

//помещаете его в реквизит формы
ЗначениеВРеквизитФормы(лкДок,"Объект.Док");

КонецФункции

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
//какие-то начальные значения для заполнения
//обязательно должен быть реквизит который будет уникальным, при открытии форм!
//в моем примере это номер, может быть дата, :+) при условии что пользователь
//создает документы с интервалом в секунду
//или еще как вариант генерить самому ссылку документа и использовать ее
Объект.Номер = 111;
КонецПроцедуры


ИИИИИИИИИ еще код вставляем в форму открываемого документа в событии ПриСозданииНаСервере

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
//Вставить содержимое обработчика

Если Параметры.Свойство("Документ") Тогда
лкДок = ДанныеФормыВЗначение(Параметры.Документ,Тип("ДокументОбъект.СборкаКомпьютера"));
ЗначениеВРеквизитФормы(лкДок,"Объект");
КонецЕсли;

КонецПроцедуры


Добавлено: 27 Мар 2015, 13:42

Получается такая картинка
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 282
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4812
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3404
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4984
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 582
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 262
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal