Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Хранилище настроек  (Прочитано 3358 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
УТ 11.1
Ошибка при заполнении ТЧ из хранилища
Процедура ПриОткрытииСерв()

КлючОбработки = РеквизитФормыВЗначение("Объект").Метаданные().ПолноеИмя();
Объект.ТЧ.Загрузить(ХранилищеОбщихНастроек.Загрузить(КлючОбработки,"ТЧЗаполненая"));

КонецПроцедуры

Процедура ПриЗакрытииНаСервере()

  КлючОбработки = РеквизитФормыВЗначение("Объект").Метаданные().ПолноеИмя();
  Настройки = Новый Соответствие;
  Настройки.Вставить("ТаблицаЗначений", Объект.ТЧ.Выгрузить());
  ХранилищеОбщихНастроек.Сохранить(КлючОбработки,"ТЧЗаполненая", Настройки);

КонецПроцедуры


Ну и ошибка
{Форма.Форма.Форма(231)}: Ошибка при вызове метода контекста (Загрузить)
Объект.ТЧ.Загрузить(ХранилищеОбщихНастроек.Загрузить(КлючОбработки,"ТЧЗаполненая"));
по причине:
Несоответствие типов (параметр номер '1')
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Коме интересно вот рабочий код

&НаКлиенте
Процедура ПриОткрытии(Отказ)

ПриОткрытииСерв();

 КонецПроцедуры
 
&НаСервере
Процедура ПриОткрытииСерв()
Настройки = Новый Соответствие;
    Настройки.Вставить("ТаблицаЗначений", Объект.ТЧ.Выгрузить());
КлючОбъекта = РеквизитФормыВЗначение("Объект").Метаданные().ПолноеИмя();
ТЗ = ХранилищеОбщихНастроек.Загрузить(КлючОбъекта,"ТЧЗаполненая",);
Объект.ТЧ.Загрузить(ТЗ);

КонецПроцедуры

&НаКлиенте
Процедура ПриЗакрытии()
ПриЗакрытииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриЗакрытииНаСервере()
КлючОбъекта = РеквизитФормыВЗначение("Объект").Метаданные().ПолноеИмя();
    Настройки = Новый Соответствие;
    Настройки.Вставить("ТаблицаЗначений", Объект.ТЧ.Выгрузить());
ТЗ = Новый ТаблицаЗначений;
ТЗ = Объект.ТЧ.Выгрузить();
    ОбщегоНазначения.ХранилищеОбщихНастроекСохранить(КлючОбъекта, "ТЧЗаполненая", ТЗ, Настройки);

КонецПроцедуры
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн k_aleks80

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 14
  • КПД: 22%
  • Регистрация: 2011-09-08
  • Сайт: 
  • Профессия: Программист 1С
Мне пригодиться. Спасибо за информацию :btbzdb:

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а спасибо сказать? :)
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн k_aleks80

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 14
  • КПД: 22%
  • Регистрация: 2011-09-08
  • Сайт: 
  • Профессия: Программист 1С
Сказал. Вопрос вдогонку - как мне такое же спасибо сделать? :dfbsdfbsdf:


 

У значения тип - "Хранилище значения" как его очистить?

Автор БухРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 10423
Последний ответ 12 Ноя 2009, 11:40
от Стаф
ОШИБКА 1С 8.3. Файл не найден в хранилище файлов. Возможно файл удален антивирусной программой. Обратитесь к администратору

Автор Сергей БатуринРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 6390
Последний ответ 18 Май 2016, 18:18
от Сергей Батурин
Очистить значение типа "Хранилище значения"

Автор ЛеонидРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4730
Последний ответ 22 Ноя 2009, 17:45
от Никитина
Как проверить тип значения, помещенного в реквизит с типом «Хранилище значения»?

Автор СтафРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3904
Последний ответ 22 Ноя 2009, 17:43
от Никитина
Часть вторая: переход на «1С ЗУП» версии «3.0». Работа с «Параметрами учета» и проверка всех настроек программы после транспортировки из предыдущей редакции

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4271
Последний ответ 16 Мар 2015, 16:19
от 1cwiki

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 257
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal