Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 09:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор даты пользователем в СКД  (Прочитано 3119 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лесной Лес

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Ученик 1С
Бухгалтерия предприятия, редакция 2.0 (2.0.54.13)

Необходимо чтобы пользователь выбирал даты из диалога на форме а не лез в настройки. Не могли бы уважаемы господа подсказать примерный алгоритм привязки полей формы к значениям НачалоПериода и КонецПериода?



Оффлайн Лесной Лес

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Ученик 1С
Хотя бы где почитать подскажите:trhregerhg:

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Если конфа доступна для редактирования, то проще все сделать на управляемых формах, чем иметь такой секс.

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
добавьте на вашу форму табличное поле
где в данных путь: КомпоновщикНастроек.Настройки.ПараметрыДанных
получится см.картинку
только не забудьте в текст запроса в нужные места добавить код
что-то типа
{Где <ВашДокумент>.Ссылка.Дата Между &НачалоПериода и &КонецПериода}
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Лесной Лес

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Ученик 1С
Если конфа доступна для редактирования, то проще все сделать на управляемых формах, чем иметь такой секс.

Я учусь, поэтому такой секс иметь придется..
Добавлено: 19 Мар 2015, 17:37


только не забудьте в текст запроса в нужные места добавить код
что-то типа
{Где <ВашДокумент>.Ссылка.Дата Между &НачалоПериода и &КонецПериода}
Благодарю за подсказку, немного не то решение что мне нужно, но что Вы имели ввиду я понял.

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать

только не забудьте в текст запроса в нужные места добавить код
что-то типа
{Где <ВашДокумент>.Ссылка.Дата Между &НачалоПериода и &КонецПериода}
Благодарю за подсказку, немного не то решение что мне нужно, но что Вы имели ввиду я понял.

без этого кода ваши параметры работать не будут,
да-а-а, небольшой совет, почитайте книжку по отчетам СКД, их полно в интернете,
и у вас все наладится! удачи!
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Благодарю за подсказку, немного не то решение что мне нужно, но что Вы имели ввиду я понял.

Наоборот это самый верный способ если без программирования.
В противном случае гуглим на темы:
1. Как сформировать отчет на СКД программно
2. Программная установка параметров отчета на СКД
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Лесной Лес

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Ученик 1С


Наоборот это самый верный способ если без программирования.
В противном случае гуглим на темы:
1. Как сформировать отчет на СКД программно
2. Программная установка параметров отчета на СКД
Благодарю за подсказку. Почитал, решил таким образом. ВВел реквизиты НачалоПериода, КонецПериода, Привязал к ним элементы вормы и собственно код:

Процедура ПриОткрытии()
Если КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода").Использование = Истина
      Тогда
НачалоПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода").Значение;
КонецЕсли;
Если КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода").Использование = Истина
      Тогда
КонецПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода").Значение;

КонецЕсли;
КонецПроцедуры

Процедура НачалоПериодаПриИзменении(Элемент)
   
КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода").Использование = Истина;
Если ЗначениеЗаполнено(НачалоПериода) Тогда
КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода").Значение = НачалоПериода;
Иначе
КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода").Значение = Неопределено;
КонецЕсли;

КонецПроцедуры

Процедура КонецПериодаПриИзменении(Элемент)
   

КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода").Использование = Истина;
Если ЗначениеЗаполнено(КонецПериода) Тогда
КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода").Значение = КонецПериода;
Иначе
КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода").Значение = Неопределено;
КонецЕсли;

КонецПроцедуры

Оффлайн blackmoon89

  • Разработчик 1С
  • ***
  • Сообщений: 105
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2015-02-28
    • Skype: klimsrv
  • Компания: ООО Стимпроект
  • Профессия: Разработчик 1С
Ничего программно делать не нужно, нужно взять книжку по СКД и почитать.

Во вложении ваш отчет, в него не добавлено ни строчки кода, пользуйтесь.:zebzdr:
Добавлено: 22 Мар 2015, 00:17

Ничего программно делать не нужно, нужно взять книжку по СКД и почитать.

Во вложении ваш отчет, в него не добавлено ни строчки кода, пользуйтесь.:zebzdr:

А вот тут еще красивее

Последний раз редактировалось: blackmoon89; 22 Мар 2015, 00:17. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
blackmoon89, может быть старею, да и толком посмотреть результат не удалось - нет под рукой целевой конфиги, но...

в чем идея то?
кроме как:
1. бросить на форму ТП связанное с КомпоновщикНастроек.ПараметрыДанных
2. присвоить параметры программно

какие еще варианты?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

выбор параметра "Склад" в отчёте.

Автор The KAINРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 813
Последний ответ 22 Июн 2016, 08:11
от The KAIN
Как записать в поле ввода "Единица Измерения", которое заполняется через выбор из формы.

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 278
Последний ответ 12 Окт 2017, 14:30
от Ivan94
Выбор элементов из ТЧ одного документа для переноса в ТЧ другого документа

Автор Никита ВикторовичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 95
Последний ответ 01 Дек 2017, 19:29
от Никита Викторович
Значение параметра "ВыбраннаяСтрока" в событии Выбор Табличного поля.

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7638
Последний ответ 09 Дек 2013, 15:03
от Katish
Внешняя Печатная Форма. Выбор шапки макета по варианту склада.

Автор shustrikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1552
Последний ответ 13 Сен 2010, 09:01
от shustrik

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
45 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 718
  • Точка Скрытых: 0
  • Точка Пользователей: 18
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal