Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 16:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: поиск двух одинаковых строк  (Прочитано 3336 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте вопрос такой есть таблица "справки" нужно чтобы в ней после ввода имени сотрудника он выбирается из справочника "сотрудники" , если такой сотрудник уже заведён выводилось сообщение, что то типа он уже заведён и ни давал его заводить.

я нашёл код, но что то не могу в него въехать т.к. на 1с я программирую недавно объясните пожалуйста, кому не трудно

Процедура ПоискДублейСтрокВТабЧасти(ТЧ, Отказ) Экспорт

 Если Тип(ТЧ) = Тип("ТаблицаЗначений") Тогда
  ТаблЗнач = ТЧ;
 Иначе
  ТаблЗнач = ТЧ.Выгрузить();
 КонецЕсли;

 Отбор = Новый Структура();

 Для каждого Стр Из ТаблЗнач Цикл
  Отбор.Очистить();
  Для каждого Колонки Из ТаблЗнач.Колонки Цикл
   Если Колонки.Имя <> "НомерСтроки" Тогда
    Отбор.Вставить(Колонки.Имя, Стр[Колонки.Имя]);
   КонецЕсли;
  КонецЦикла;

  Строки = ТаблЗнач.НайтиСтроки(Отбор);
  Если Строки.Количество() > 1 Тогда
   Для каждого НайденныеСтроки Из Строки Цикл
    Если Строки.Найти(НайденныеСтроки) > 0 Тогда
     СтрокаСообщения = "Строка № " + Строки[0].НомерСтроки + " совпадает со строкой № " + НайденныеСтроки.НомерСтроки;
     СообщитьОбОшибке(СтрокаСообщения, Отказ, "Уберите задвоения строк!");
    КонецЕсли;
   КонецЦикла;
     КонецЕсли;
 КонецЦикла;
КонецПроцедуры

я вставляю его в модуль формы где находится таблица, как я понимаю вместо ТЧ мне надо подставить "Справки" но что то он ругается на синтаксис заранее спасибо   


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
поле с сотрудником это ссылка на справочник Сотрудники.
при наборе руками ФИО платформа сама попытается по введенному значению найти в справочнике подходящий элемент.
другой вопрос что при нажатии на "..." вы попадаете в форму выбора из справочника где есть возможность создать новый элемент,
а вот тут уже никаких проверок - хоть 100 Ивановых заводите.
по большому счету именно в перед записью сотрудника и надо добавлять проверку на уникальность.
в любом случае приведенный код тут ваще никаким боком...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
Вот что надо сделать в форме элемента, когда мы выбрали сотрудника(красным цветом) надо сделать проверку на то, что если этот сотрудник выбран в форме (синим цветом) выводил сообщение,что типа он уже есть.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Тогда в справочнике Справки в ПередЗаписью() проверяете нет ли записываемого сотрудника среди уже введенных элементов.
Делается запросом.
Т.е. приведенный код вам по прежнему не помощник.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
Тогда в справочнике Справки в ПередЗаписью() проверяете нет ли записываемого сотрудника среди уже введенных элементов.
Делается запросом.
Т.е. приведенный код вам по прежнему не помощник.

подскажите пожалуйста как обращаться к таблице, которая находится на форме списка и вообще как обращаться к элементам, которые находятся на форме. допустим в делфи делается так a:=form1.Edit1.Text; заранее спасибо.   

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
элементы.ИмяЭлемента
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
элементы.ИмяЭлемента

а можете на примере объяснить, конкретно к этому вопросу   

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
применительно к вопросу - для проверки дублей элементы формы НЕ используются.
да и старый добрый RTFM никто не отменял.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
применительно к вопросу - для проверки дублей элементы формы НЕ используются.
да и старый добрый RTFM никто не отменял.

тогда подскажите книжку хорошую по 1с 7.7 программированию где описана работа с формами

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
так у вас 7.7???????????????????????????????!!!!!!!!!!!!!!:xfbnsdfb:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 789
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal