Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 15:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Время ожидания!  (Прочитано 4423 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vvvlad85

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-07-21
  • Сайт: 
Подскажите как сделать чтобы было время ожидания 5 минут?


Оффлайн Admin

  • Администратор
  • *****
  • Сообщений: 260
  • РЕПУТАЦИЯ: 38
  • КПД: 15%
  • Регистрация: 2008-07-10
  • Сайт: forum-1c.ru
  • Профессия: Программист 8.1
Re: Время ожидания!
« Ответ #1: 23 Авг 2010, 16:47 »
В параметрах информационной базы задайте.
Подпись

Оффлайн vvvlad85

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-07-21
  • Сайт: 
Re: Время ожидания!
« Ответ #2: 23 Авг 2010, 17:09 »
В цикле например программно задать...
типа delay() ....

Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Re: Время ожидания!
« Ответ #3: 23 Авг 2010, 22:17 »
Подскажите как сделать чтобы было время ожидания 5 минут?

Конфигуратор - Администрирование - Параметры информационной базы...

Оффлайн vvvlad85

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-07-21
  • Сайт: 
Re: Время ожидания!
« Ответ #4: 24 Авг 2010, 08:22 »
Подскажите как сделать чтобы было время ожидания 5 минут?

Конфигуратор - Администрирование - Параметры информационной базы...
Я имею например вот код:
             Элементыформы.Индикатор1.Значение = 0;
   Пока Элементыформы.Индикатор1.Значение <=100 Цикл
       Элементыформы.Индикатор1.Значение = Элементыформы.Индикатор1.Значение + 1;
       Если Элементыформы.Индикатор1.Значение = 100 Тогда
           Прервать;
       КонецЕСли;
                             //что суда вставить чтобы выдерживалась определнное время?
   КонецЦикла;

Как остановить программный код во время работы в цикле, ч

Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Re: Время ожидания!
« Ответ #5: 25 Авг 2010, 15:54 »
Подскажите как сделать чтобы было время ожидания 5 минут?

Конфигуратор - Администрирование - Параметры информационной базы...
Я имею например вот код:
             Элементыформы.Индикатор1.Значение = 0;
   Пока Элементыформы.Индикатор1.Значение <=100 Цикл
       Элементыформы.Индикатор1.Значение = Элементыформы.Индикатор1.Значение + 1;
       Если Элементыформы.Индикатор1.Значение = 100 Тогда
           Прервать;
       КонецЕСли;
                             //что суда вставить чтобы выдерживалась определнное время?
   КонецЦикла;

Как остановить программный код во время работы в цикле, ч

Я такое не использовал, но для примера я сделал обработку с кнопкой. В форме обработки всего две процедуры:

Процедура Сообщение() Экспорт
Сообщить("Конец: " + ТекущаяДата());
КонецПроцедуры


Процедура Кнопка1Нажатие(Элемент)
Сообщить("Старт: " + ТекущаяДата());
ПодключитьОбработчикОжидания("Сообщение",20,Истина);
КонецПроцедуры

Эта штука работает.
Через 20 сек выскакивает второе сообщение.
Т.е. если тебе надо остановить Процедуру2 пока не выполнится Процедура1, то в Процедуре1
пишешь:
ПодключитьОбработчикОжидания("Процедура2",ТаймаутВСекундах,Истина);
тогда
Процедура2 будет вызвана только через ТаймаутВСекундах (у тебя 300 с)
 :D
Процедур2 должна быть экспортной, Истина - однократный останов. (В хелпе 1С все расписано...)

Оффлайн vvvlad85

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-07-21
  • Сайт: 
Re: Время ожидания!
« Ответ #6: 26 Авг 2010, 08:25 »
Спасибо! Это идея классная)))
ПодключитьОбработчикОжидания("Сообщение",20,Истина);
П посему только 300 сек я не понял?

Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Re: Время ожидания!
« Ответ #7: 26 Авг 2010, 18:39 »
Спасибо! Это идея классная)))
ПодключитьОбработчикОжидания("Сообщение",20,Истина);
П посему только 300 сек я не понял?

300 сек это твои 5 минут. 5*60 = 300. Я тренировался на 20 секундах, а ты вроде хочешь тормознуть на 5 минут?

Оффлайн vvvlad85

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-07-21
  • Сайт: 
Re: Время ожидания!
« Ответ #8: 27 Авг 2010, 11:43 »
Спасибо большое))) Ступил просто


Теги:
 

Во время обмена выпадает ошибка: "При подписке на событие произошла ошибка."

Автор alexkissРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 5195
Последний ответ 11 Авг 2010, 08:58
от alexkiss
Расчет неявок (выходных) в ЗУП по регистру "Рабочее время сотрудников организации"

Автор BlogonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1133
Последний ответ 25 Ноя 2016, 17:25
от alex0402
ФНС во время выездной проверки может доначислить земельный налог, вне зависимости от того, как прошла камеральная проверка

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1290
Последний ответ 24 Сен 2014, 14:48
от topics
Если произошел технический сбой сервера, и форма 4-ФСС не во время была доставлена, компанию нельзя оштрафовать

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1790
Последний ответ 18 Ноя 2014, 14:25
от topics
Сумма подотчетных средств может включаться в базу по страховым взносам, если работник во время не отчитался за них

Автор newsРаздел Новости

Ответов: 0
Просмотров: 899
Последний ответ 29 Дек 2014, 17:53
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 300
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal