Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 09:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Прогноз по анализу дерева решений  (Прочитано 1258 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fenlou

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Помогите исправить ошибку, все написал, но ничего не выводит. Обработка ниже


Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Долго Вам будут помогать с такой формулировкой вопроса :mellow:
Народная мудрость: Программу встречают по интерфейсу

Оффлайн Fenlou

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Долго Вам будут помогать с такой формулировкой вопроса :mellow:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПриОткрытииНаСервере()
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | РасчетОСАГО.Возраст,
               | РасчетОСАГО.Стаж,
               | РасчетОСАГО.КН
               |ИЗ
               | Документ.РасчетОСАГО КАК РасчетОСАГО"; 
ДеревоРешений.Загрузить(Запрос.Выполнить().Выгрузить());
МинимальноеКоличествоСлучаев = 0;
МаксимальнаяГлубина = 1000;
ТипУпрощения = ТипУпрощенияДереваРешений.НеУпрощать;
КонецПроцедуры

&НаСервере
Процедура Анализ(ТабДок)
Анализ = Новый АнализДанных;
Анализ.ТипАнализа = Тип("АнализДанныхДеревоРешений");
Анализ.ИсточникДанных = РеквизитФормыВЗначение("ДеревоРешений");
Анализ.Параметры.ТипУпрощения.Значение = ТипУпрощения;
Анализ.Параметры.МинимальноеКоличествоСлучаев.Значение = МинимальноеКоличествоСлучаев;
Анализ.Параметры.МаксимальнаяГлубина.Значение = МаксимальнаяГлубина;
РезультатАнализа = Анализ.Выполнить();
Построитель = Новый ПостроительОтчетаАнализаДанных();
Построитель.Макет = Неопределено;
Построитель.ТипАнализа = Тип ("АнализДанныхДеревоРешений");
Построитель.Вывести(РезультатАНализа,ТабДок);
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьАнализ(Команда)
ТабДок = Новый ТабличныйДокумент;
Анализ(ТабДок);
ТабДок.Показать();
КонецПроцедуры

&НаКлиентеСервера
Процедура Прогноз(Команда)
МодельПрогноза = РезультатАнализа.СоздатьМодельПрогноза();
МодельПрогноза.ИсточникДанных = РеквизитФормыВЗначение("ДеревоРешений");
ТаблицаЗначенийПоследовательностей = МодельПрогноза.Выполнить();
Если ТаблицаЗначенийПоследовательностей.Количество()>0 тогда
РезультатПрогноза.Очистить();
ЭлементыФормы.РезультатПрогноза.Значение = ТаблицаЗначенийПоследовательностей;
ЭлементыФормы.РезультатПрогноза.СоздатьКолонки();
КонецЕсли;
Если РезультатПрогноза.Количество() = 0 тогда
Предупреждение("Предложений нет");
Иначе
ЭлементыФормы.РезультатПрогноза.СоздатьКолонки();
КонецЕсли;
КонецПроцедуры




Добавлено: 15 Мар 2015, 12:31

или так
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПриОткрытииНаСервере()
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | РасчетОСАГО.Возраст,
               | РасчетОСАГО.Стаж,
               | РасчетОСАГО.КН
               |ИЗ
               | Документ.РасчетОСАГО КАК РасчетОСАГО"; 
ДеревоРешений.Загрузить(Запрос.Выполнить().Выгрузить());
МинимальноеКоличествоСлучаев = 0;
МаксимальнаяГлубина = 1000;
ТипУпрощения = ТипУпрощенияДереваРешений.НеУпрощать;
КонецПроцедуры

&НаСервере
Процедура Анализ(ТабДок)
Анализ = Новый АнализДанных;
Анализ.ТипАнализа = Тип("АнализДанныхДеревоРешений");
Анализ.ИсточникДанных = РеквизитФормыВЗначение("ДеревоРешений");
Анализ.Параметры.ТипУпрощения.Значение = ТипУпрощения;
Анализ.Параметры.МинимальноеКоличествоСлучаев.Значение = МинимальноеКоличествоСлучаев;
Анализ.Параметры.МаксимальнаяГлубина.Значение = МаксимальнаяГлубина;
РезультатАнализа = Анализ.Выполнить();
Построитель = Новый ПостроительОтчетаАнализаДанных();
Построитель.Макет = Неопределено;
Построитель.ТипАнализа = Тип ("АнализДанныхДеревоРешений");
Построитель.Вывести(РезультатАНализа,ТабДок);
МодельПрогноза = РезультатАнализа.СоздатьМодельПрогноза();
МодельПрогноза.ИсточникДанных = Анализ.ИсточникДанных ;
РезультатПрогноза = МодельПрогноза.Выполнить();
РезультатПрогноза.СоздатьКолонки();
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьАнализ(Команда)
ТабДок = Новый ТабличныйДокумент;
Анализ(ТабДок);
ТабДок.Показать();
КонецПроцедуры
ошибка такая
{Обработка.ДеревоРешений.Форма.Форма.Форма(36)}: Ошибка при установке значения атрибута контекста (РезультатПрогноза)
РезультатПрогноза = МодельПрогноза.Выполнить();
по причине:
Нельзя изменять поле, содержащее объект данных формы
Нельзя изменять поле, содержащее объект данных формы

Последний раз редактировалось: Fenlou; 15 Мар 2015, 12:31. Причина: Объединение сообщений

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 473
  • РЕПУТАЦИЯ: 85
  • КПД: 18%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
По-моему совершенно ясный текст ошибки: вы результат присваиваете в реквизит.
Присвоение должно заменить реквизит, а это невозможно. Нужно просто присвоить переменной, а в реквизит потом скопировать эти данные.


Теги:
 

Обход дерева значений на клиенте / развернуть многоуровневое дерево на клиенте

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5146
Последний ответ 01 Ноя 2015, 10:07
от Азиман
Рекурсивный перебор дерева значений и вывод в макет

Автор demon3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7227
Последний ответ 09 Фев 2014, 23:36
от GRADUS
копирование дерева из спецификаций в технологические операции

Автор forhelpРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1901
Последний ответ 06 Июл 2010, 12:27
от forhelp
Как отключить отображение в виде дерева номенклатуры

Автор boldinovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1105
Последний ответ 24 Окт 2014, 14:22
от has
Вывод дерева значений на управляемую форму

Автор victor-o555Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3112
Последний ответ 24 Сен 2015, 14:39
от victor-o555

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 585
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal