Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Анализ данных "общая статистика"  (Прочитано 1803 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fenlou

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, есть анализ данных общая статистика. Нужно вытащить оттуда значения, при нажатии соответствующей кнопки в другую форму или на этой же, в другое табличное поле: наибольше встречаемые клиенты. Обработка и скриншот, из которого нужно вывести значения прикреплены ниже. Т.е. в другом табличном поле должны быть Иванов Иван Иванович и Григорьев Иван Владимирович


Оффлайн Fenlou

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
&НаСервере
Процедура Анализ(ТабДок)
Анализ = Новый АнализДанных;
Анализ.ТипАнализа = Тип ("АнализДанныхОбщаяСтатистика");
Анализ.ИсточникДанных = РеквизитФормыВЗначение("ОбщаяСтатистика");
РезультатАнализаДанных = Анализ.Выполнить();
Построитель = Новый ПостроительОтчетаАнализаДанных();
Построитель.Макет = Неопределено;
Построитель.ТипАнализа = Тип ("АнализДанныхОбщаяСтатистика");
ТабДок = Новый ТабличныйДокумент;
Построитель.Вывести(РезультатАнализаДанных, ТабДок);
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииСервер()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | РасчетОСАГО.Клиент,
               | РасчетОСАГО.Клиент.Пол КАК Пол,
               | РасчетОСАГО.Возраст,
               | РасчетОСАГО.Стаж
               |ИЗ
               | Документ.РасчетОСАГО КАК РасчетОСАГО";
ОбщаяСтатистика.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьАнализ(Команда)
ТабДок = Новый ТабличныйДокумент;
Анализ(ТабДок);
ТабДок.Показать();
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПриОткрытииСервер();
КонецПроцедуры

&НаКлиентеСервера
Процедура Вывести(Команда)

КонецПроцедуры
Добавлено: 15 Мар 2015, 16:56

Сделал :)

Последний раз редактировалось: Fenlou; 15 Мар 2015, 16:56. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 131
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal