Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 23:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПустаяСсылка() и тип Перечисление ссылка  (Прочитано 3691 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Делаю вот так:
	Запрос = Новый Запрос;
      Запрос.Текст =" тут бооольшой запрос"
   
Для каждого Строка из Запрос.Выполнить().Выгрузить() цикл
Если Строка.ТипРассылки.ПустаяСсылка() Тогда
                   //юзадж
КонецЕсли;
КонецЦикла;

Ругается на  то, что у Строка.ТипРассылки нет метода ПустаяСсылка()
Отладить не дает. Тк обработка - тупо залипает.

Мы знаем, что:
 1 - запрос не пустой (рисую рядом динсписок с тем же запросом - строки есть)
 2 - ТипРассылки имеет тип ПеречислениеСсылка и метод ПустаяСсылка() у него тоже есть. Но не в это конкретном месте.


Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Нашел решение:
Если Строка.ТипРассылки = ПредопределенноеЗначение("Перечисление.ТипРассылки.ПустаяСсылка") Тогда..
Топик Клозед

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ЗначениеЗаполнено()?

Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
неправильно используете метод ПустаяСсылка(),
в вашем примере нужен метод просто Пустая(), см. код

    Запрос = Новый Запрос;
      Запрос.Текст =" тут бооольшой запрос"
   
    Для каждого Строка из Запрос.Выполнить().Выгрузить() цикл
        Если Строка.ТипРассылки.Пустая() Тогда
                   //юзадж
        КонецЕсли;
    КонецЦикла;
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 685
Последний ответ 20 Мар 2018, 16:54
от alex0402
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2499
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3524
Последний ответ 29 Май 2013, 16:24
от leklerk
Cоздать значение по типу [пустая ссылка по типу]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 3101
Последний ответ 08 Июл 2015, 17:21
от MuI_I_Ika
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5469
Последний ответ 24 Ноя 2015, 15:38
от welldone

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
ilyay ilyay
29 Сообщений
Alter
29 Сообщений
Анюта17
29 Сообщений

* Кто онлайн

  • Точка Гостей: 277
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal