Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 06:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Невыгружаются даныые в Excel  (Прочитано 2211 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
При выгрузке данных в Таблицу в колонке с Валютой все выгружается и показывается, но при выгрузке этой же таблицы в Excel, колонка валюты в Эксель не заполняется. В чем может быть проблема?

Процедура ВыгрузитьВЭксельНажатие(Элемент)
Если ТЗ.Колонки.Количество() = 0 Тогда
Предупреждение("Нет данных для выгрузки.");
Возврат;
КонецЕсли;


Эксель  = Новый  COMОбъект("Excel.Application") ;
Книга = Эксель.WorkBooks.Add();
Пока  Книга.Sheets.Count > 1 Цикл
Книга.Sheets(1).Delete();
КонецЦикла;
Лист = Книга.WorkSheets(1);
Лист.Name = "ВыгрузкаДанныхВНАКПолная";

i = 0;

Для Каждого Стр Из ТЗ Цикл
i = i + 1;
//Val_2 = Формат(Стр.Год,"ЧГ=0;ЧЦ=10")+"."+Мц;
Лист.Cells(i,1).NumberFormat = "@";
Лист.Cells(i,1).Value = Стр.Период;
Лист.Cells(i,2).NumberFormat = "@";
Лист.Cells(i,2).Value = Стр.КодОрганизации;
Лист.Cells(i,3).NumberFormat = "@";
Лист.Cells(i,3).Value = Стр.НомерСчета;
Лист.Cells(i,4).NumberFormat = "@";
Лист.Cells(i,4).Value = Стр.А1;
Лист.Cells(i,5).NumberFormat = "@";
Лист.Cells(i,5).Value = Стр.А2;
Лист.Cells(i,6).NumberFormat = "@";
Лист.Cells(i,6).Value = Стр.А3;
Лист.Cells(i,7).NumberFormat = "@";
Лист.Cells(i,7).Value = Стр.А4;
Лист.Cells(i,8).NumberFormat = "@";
Лист.Cells(i,8).Value = Стр.А5;
Лист.Cells(i,9).NumberFormat = "@";
Лист.Cells(i,9).Value = Стр.А6;
Лист.Cells(i,10).NumberFormat = "@";
Лист.Cells(i,10).Value = Стр.А7;
Лист.Cells(i,11).NumberFormat = "@";
Лист.Cells(i,11).Value = Стр.А8;
Лист.Cells(i,12).NumberFormat = "@";
Лист.Cells(i,12).Value = Стр.А9;
Лист.Cells(i,13).NumberFormat = "@";
Лист.Cells(i,13).Value = Стр.А10;
Лист.Cells(i,14).NumberFormat = "@";
Лист.Cells(i,14).Value = Стр.А11;
Лист.Cells(i,15).NumberFormat = "@";
Лист.Cells(i,15).Value = Стр.KZT;
Лист.Cells(i,16).NumberFormat = "############0,00";
Лист.Cells(i,16).Value = Стр.Сумма;
Лист.Cells(i,17).NumberFormat = "@";
Лист.Cells(i,17).Value = Стр.ДатаВремя;
Лист.Cells(i,18).NumberFormat = "@";
Лист.Cells(i,18).Value = Стр.СчетУС;
Лист.Cells(i,19).NumberFormat = "@";
Лист.Cells(i,19).Value = Стр.КорСчетУС;
Лист.Cells(i,20).NumberFormat = "@";
Лист.Cells(i,20).Value = Стр.ТипДанных;
КонецЦикла;
Эксель.Visible = true;
Лист = 0;
Книга = 0;
Эксель = 0;
КонецПроцедуры

Выгрузка в строке

Лист.Cells(i,15).NumberFormat = "@";
Лист.Cells(i,15).Value = Стр.KZT;


Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Стр.KZT; - это что? Валюта?
попробуйте явно передать в Ексель наименование, примерно так
Лист.Cells(i,15).NumberFormat = "@";
Лист.Cells(i,15).Value = Стр.KZT.Наименование;
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Стр.KZT; - это что? Валюта?
попробуйте явно передать в Ексель наименование, примерно так
Лист.Cells(i,15).NumberFormat = "@";
Лист.Cells(i,15).Value = Стр.KZT.Наименование;

Да это валюта, попробовал выдает ошибку

{Обработка.ВыгрузкаДанных.Форма.Форма.Форма(1672)}: Значение не является значением объектного типа (Наименование)
Лист.Cells(i,15).Value = Стр.KZT.Наименование;

Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
посмотрите у себя в базе, в конфигураторе как называется Реквизит в котором хранится имя вашей валюты,
вы же не пишете какая у вас конфигурация...

и/или смотрите запрос который вашу ТЗ формирует, что это за поле KZT (валюта Казахстана?), его тип.

тогда сразу так пишите

Лист.Cells(i,15).NumberFormat = "@";
Лист.Cells(i,15).Value = "Тенге";
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Загрузка из Excel , Загрузка справочника физ.лица и сотрудники

Автор yojРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 272
Последний ответ 24 Янв 2018, 02:55
от Геннадий ОбьГЭС
Круглый стол "Автоматизация учета и отчетности по МСФО: Excel против программных продуктов"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1900
Последний ответ 10 Сен 2014, 10:25
от mixqn
работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3446
Последний ответ 11 Фев 2016, 12:49
от Rasty
Внешняя компонента для прямого чтения файлов Excel всех версий

Автор CrazyDaveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2304
Последний ответ 01 Мар 2012, 16:23
от CrazyDave
Не создается COM объект Excel.Application, хотя всё установлено и права есть

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 8944
Последний ответ 23 Июл 2015, 14:25
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
162 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
61 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Alter
29 Сообщений
Анюта17
29 Сообщений
ilyay ilyay
29 Сообщений

* Кто онлайн

  • Точка Гостей: 300
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal