Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 16:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: В периферийной базе не формирует штрихкоды  (Прочитано 1391 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн svv1979

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-14
  • Сайт: 
  • Профессия: Программист 1С
Добрый день
УТ 11.1.9.7 Платформа 8.3.5.1460
Проблема такая
Есть ЦБ в номенклатуре формируем новый штрих код в ней он формируется нормально а в периферийке пишет
РегистрСведений.ШтрихкодыНоменклатуры.МодульМенеджера(113)}: Преобразование значения к типу Число не может быть выполнено

Почему не понятно может кто-нибудь с чем-нить подобным сталкивался


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
скопируйте строчку на которой ошибка
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн svv1979

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-14
  • Сайт: 
  • Профессия: Программист 1С
         Четн   = Четн   + Сред(ШтрихКод, 2 * Индекс, 1);

Добавлено: 11 Мар 2015, 20:15

Сама функция

// Функция вычисляет контрольный символ кода EAN
//
// Параметры:
//  Штрихкод     - штрихкод (без контрольной цифры)
//  Тип          - тип штрихкода: 13 - EAN13, 8 - EAN8
//
// Возвращаемое значение:
//  Контрольный символ штрихкода
//
Функция КонтрольныйСимволEAN(ШтрихКод, Тип) Экспорт

   Четн   = 0;
   Нечетн = 0;

   КоличествоИтераций = ?(Тип = 13, 6, 4);

   Для Индекс = 1 По КоличествоИтераций Цикл
      Если (Тип = 8) и (Индекс = КоличествоИтераций) Тогда
      Иначе
         Четн   = Четн   + Сред(ШтрихКод, 2 * Индекс, 1);
      КонецЕсли;
      Нечетн = Нечетн + Сред(ШтрихКод, 2 * Индекс - 1, 1);
   КонецЦикла;

   Если Тип = 13 Тогда
      Четн = Четн * 3;
   Иначе
      Нечетн = Нечетн * 3;
   КонецЕсли;

   КонтЦифра = 10 - (Четн + Нечетн) % 10;

   Возврат ?(КонтЦифра = 10, "0", Строка(КонтЦифра));

КонецФункции

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
А. а какой штрихкод забит у номенклатуры? пробелов впереди нету? или позади.. буквы может?..
Думаю или номенклатура не совпадает с центральной. чтото отличается.
ну вообще в отладчике посмотрите, 5 минут. и все поймете
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн svv1979

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-14
  • Сайт: 
  • Профессия: Программист 1С
Администрирование ==> Настройки синхронизации данных ==> Префикс внутренних штрихкодов этого узла РИБ. Надо указать какое-либо значение (хоть ноль), лишь бы пустым не было.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 819
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal