Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2017, 01:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обыкновенное уравнение (в отчёте)  (Прочитано 367 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ник8

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-03
  • Сайт: 
Это сложение двух чисел, записанных, например, в ячейки R1C1 и R1C2, результат в R1C3 (по всем строкам, R1-Rn)

&НаКлиенте
Процедура ТабДокПриИзмененииСодержимогоОбласти(Элемент, Область)

ПриИзмененииДанныхОбластиТабДока(Элемент, Область, ЭтаФорма);

КонецПроцедуры


&НаКлиенте
Функция ПриИзмененииДанныхОбластиТабДока(Элемент, Область, Контекст) Экспорт

ПозицияКолонки = Найти(Область.Имя,"C");
Строка = Сред(Область.Имя, 1, ПозицияКолонки-1);
Колонка = Сред(Область.Имя, ПозицияКолонки);

Если Колонка = "C1" или Колонка = "C2" Тогда
Попытка
Контекст[Элемент.Имя].Область(Строка+"C3").Текст = Число(Контекст[Элемент.Имя].Область(Строка+"C2").Текст) + Число(Контекст[Элемент.Имя].Область(Строка+"C1").Текст);
Исключение
КонецПопытки;
КонецЕсли;

КонецФункции

А как реализовать решение системы уравнений? Хотя бы типа таких?
x-y=-5
2x+y=-7


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame
73 Сообщений
alex0402
52 Сообщений
ilyay ilyay
51 Сообщений
andron81_81
44 Сообщений
oleg-x
35 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 197
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal