Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура сложения чисел  (Прочитано 3169 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
Помогите написать процедуру для сложения 2-х чисел.
Функцию написать смог, а вот процедуру никак.
Буду очень признателен. Заранее спасибо!


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Процедура СуммаЧисел(Число1, Число2)
Результат = Число1 + Число2;
КонецПроцедуры
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Процедура СуммаЧисел(Число1, Число2)
Результат = Число1 + Число2;
КонецПроцедуры

ну-ну, и куда вернется результат?

наверно так имелось ввиду:

Процедура СуммаЧисел(Результат, Число1, Число2)
Результат = Число1 + Число2;
КонецПроцедуры

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Вам, сударь, основы программирования бы почитать.
Функция тем и отличается от процедуры, что возвращает значение. Процедура не может вернуть ничего в принципе по определению, в ином случае это будет функция.
Если же стоит особая задача "через нос достать аппендикс" можете в процедуре передавать значение в реквезит.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
ferrari314, вариант LexaK вполне рабочий, что не так?
Результат = 0;
СуммаЧисел(Результат, Число1, Число2);
//дальше можно использовать Результат

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
LexaK, чойто оно возвращать то должно? РТФМ
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Может так надо?
Процедура СуммаЧисел(Число1, Число2)
Результат = Число1 + Число2;
Сообщить(Результат);
КонецПроцедуры
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
дфтын, Luzer1C, вы чего? пятницоо? ;)

правильно LexaK написал. параметры в процедуру передаются по ссылке, т.е. если изменить внутри процедуры значение параметра, то после выхода из процедуры у переменной, которую отправляли в процедуру будет новое значение!

Процедура СуммаЧисел(Результат, Число1, Число2)
Результат = Число1 + Число2;
КонецПроцедуры
............

Результат = 0;
СуммаЧисел(Результат, 5, 2);
Сообщить(Результат); //угадайте, что здесь получим? ;)

ясный компот что сумма чисел логичнее возвращать функцией, но и вариант с процедурой имеет место быть.
да та же встроенная функция ВвестиЗначение()! она хоть и функция, но возвращает отнюдь не введенное значение, а булево.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ef0din

  • ***
  • Сообщений: 115
  • РЕПУТАЦИЯ: 5
  • КПД: 4%
  • Регистрация: 2015-01-27
  • Сайт: 
  • Профессия: Ученик 1С
Только наверно "Процедура(Результат = Неопределено, Число1, Число2)" лучше ?
Добавлено: 06 Мар 2015, 15:13

Или тогда уж "Процедура(Число1, Число2, Результат = Неопределено)" для удобства

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Только наверно "Процедура(Результат = Неопределено, Число1, Число2)" лучше ?
Добавлено: 06 Мар 2015, 15:13

Или тогда уж "Процедура(Число1, Число2, Результат = Неопределено)" для удобства

что за помутнение сегодня у всех???
для параметра Результат задавать значение по умолчанию не критично, оно все равно заменится на сумму Число1 и Число2.
скажите уж лучше задать значения по умолчанию для Число1 и Число2
    Процедура СуммаЧисел(Результат, Число1=0, Число2=0)
хоть какой то смысл (чтобы можно было не задавать один из (или все) операндов и чтобы в этом случае не генерировалось исключение)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Процедура "ОбработкаПроведения"

Автор demon3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1264
Последний ответ 22 Июн 2016, 14:46
от demon3
Процедура "Подсчет площади"

Автор Seregin63Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2611
Последний ответ 28 Ноя 2013, 13:00
от Seregin63
1c 8.2: как называется процедура/функция, которая вызывается при вводе значения в поле на форме?

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1564
Последний ответ 08 Сен 2014, 08:28
от cska-fanat-kz
Процедура госрегистрации ИП и юрлиц будет проходить в течение трех дней

Автор newsРаздел Новости

Ответов: 0
Просмотров: 747
Последний ответ 03 Апр 2014, 15:16
от news
Процедура Инициализации при создании внешней обработки таб. частей

Автор crow1983Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 11672
Последний ответ 23 Авг 2010, 16:51
от crow1983

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 318
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal